VR Clickspots and Windows

After installing SU8 all of my clickspots in VR have shifted to the right. Very hard to set up a flight when you can’t push the buttons. Anyone else have this issue? Plus whenever I open one of the windows in VR an resize them when I hide and bring them back up again the size is back to default.

1 Like

Hey there - I’ve noticed the same shift in the click positions in VR too. I haven’t tried window resizing.

For possible fix to click spots issue, perhaps try turning off the Lens Correction. It’s just a no-risk gamble - see if that has any positive impact.

I’ve been experiencing the same issue. After takeoff, trying to engage auto pilot and it’s not clickable. So annoying, i need to use right mouse button which moves it to some other position and then it starts working. I am going to try without lens correction as you recommended.

I have also had the same issue. I have to shake my mouse around for it to reset the position. ATC also doesn’t seem to work when using the keyboard. Again shaking the mouse around seems to resolve that as well. I have also found major issues with stability since SU8, especially when fly to and from major airports that have been upgraded

Thanks for the suggestion. I tried lens correction but it did not work. Still have the same issue

Exactly the same problem for me since su8, it’s very frustrating and makes flying very difficult. It seems to affect the FBW a32nx the worst but I’ve also seen it on other aircraft. If anyone finds a solution, I’d love to hear it.

What I’ve tried without success

Reinstalling dev/experimental a32nx
Clearing out community folder - same
Turning on and off lens correction (was already off)
Turning on and off home cockpit (was already off)
Unplugging TCA throttle quadrant (as that also has a start switch lag issue)
Moving Logitech 502 mouse to different USB port
Trying different mouse
Trying different VR headset (now have HP reverb G2, used to have Oculus Quest 2)
Update TCA firmware
Update mouse drivers
Update MB BIOS
Update MB drivers esp USB
Defaulting mouse profile
Defaulting controller profiles and re-setting up
Adding dead zone to above controllers.
Disabling OpenXR toolkit
Reducing world scale in OpenXR toolkit

I’ve added the above incase any help others. I’m now out of ideas. I don’t really want to reinstall the sim unless I thought it would actually work. I’ve done it 4 times already after previous SU foulups and it’s never fixed any Asobo bugs.

1 Like

I often have problems clicking things too recently so here’s 2 tricks I found to get it working. I’ve been meaning to make a post about this to find if others are having the same issues I’m finding but then I saw this post. I’m not sure if my issues are the same but maybe these will help somebody. Good luck.

  1. I notice if I raise my mouse cursor above the cockpit dashboard, like up to the windshield, and then lower it again, then the click spot works properly again. It goes bad though after a time but then raise/lower it again and all is well for a time. Just do this as needed throughout the flight.
  2. Some planes kind of show 2 cursors, one for each eye. Sometimes the dual cursors are obvious and sometimes not. So if the first trick doesn’t work then try closing your right eye. The cursor showing in your left eye is the accurate one so closing your right eye helps you see the proper spot.

That works as a work around but closing your eye every time. I like flying airliners and that makes for a frustrating workload.

1 Like

This happens because your 2d mouse cursor is at the edge of your 2d desktop.

I have the exact issue and use the same workaround as you. By moving the mouse further up then bringing it down, you’ve brought your 2d cursor away from the edge of your 2d desktop.

It’s very frustrating. As if fs2020 is running in windowed mode. Could it be the disabling of full screen optimizations option ?

That’s an interesting theory that it’s related to the position of the mouse on my normal screen. I’ll pay attention next time it happens. Also I’ve been switching back and forth with full-screen and windowed mode so maybe that’s related as well.

I am in full screen mode but it still happens. If you figure it out please let me know what you did.

I find if you resize the window at all, the clickspots fix themselves.

@Jonny5Alive6618 and @wheeliemonsta

Note that I’m using full screen mode.

I had the issue last night again as normal. This time though when the issue happened, I took off the headset and could see that my cursor was all the way at the top of the screen. So that’s the bug. I guess the work-around of moving the mouse up and then down again ensures the mouse cursor is not at the top of the screen when you try to click a button.

I don’t know what a solution for that could be.

1 Like

Thanks for your help but I haven’t found this is the case

Exactly my problem. Glad you confirmed it. I wonder if it’s related to that ‘disable fullscreen optimizations’ check box. Seems like the mouse shouldn’t act that way. Imagine if a first person shooter did this.

You’re a genius! I had that setting also so tonight I unchecked it and after 2 flights, lasting over 1.5 hours, I didn’t have any problems with the mouse. I even tried to force the mouse to the top of the screen and it still worked without issue. I’ll keep my eye on it but I think you solved it. Also I didn’t notice any negative impact to unchecking it so that’s how I’ll fly from now on.

Where do you disable fullscreen optimizations option? Is it windows or msfs. I googled it and it was an option in windows 10 that was taken out. In order to change the setting in windows I had to edit the registry. I found no difference in the click spots so for me that’s not the issue. Unless there is a setting in msfs that I don’t know about

EDIT 1: Nevermind, its stopped working after tabbing out to post this…
EDIT 2: I turned VR off and on again and it starts working as we’d hope. I’m trying to break it but now it’s working. There’s something to this.

Its working for me! Find your flight sim executable, right click it, hit the compatibility tab, change settings for all users, then check disable full screen optimizations.


Post flight thoughts:
At first I thought once you pull up a 2d window you would see the problem but even after alt+tab in and out of VR the problem seemed to persist.

This was the answer for me!!! Thanks :pray: running the sim in full screen while in vr solved the issue. Thanks for the suggestion

1 Like