[VR] Sound not working after jumping out of VR

Please tag your post with #pc and/or #xbox.

Are you on Xbox, Steam or Microsoft Store version?
Steam Store

Are you using Developer Mode or made changes in it?
No

Brief description of the issue:
When launching the simulator in 2D Sound is present. After turning on my VR headset (Valve Index) sound switches to Index headphones and is working fine. After take-off and leveling off on cruise altitude I take off the headset and switch back to 2D and all of the sudden no sound in simulation at all. In menus however sound is still working (interface ping in menu). I’ve never encountered issues with sound before Sim Update 8…

Detailed steps to reproduce the issue encountered:

  1. Launch simulator, plane and prepare flight in 2D with sound.
  2. Before pushback jump into VR by launching headset and using key stroke to change into VR-mode.
  3. After take-off switch back to 2D and disable SteamVR for sound to switch back to main output.
  4. No sound in plane to be heard. Menu sounds still prelavent.

Never had issues before Sim Update 8.

PC specs and/or peripheral set up if relevant:
Valve Index, SteamVR, Realtek Audio

Build Version # when you first started experiencing this issue:
With Sim Update 8.

This happened to me as well. Nothing I tried would restore the sound.

1 Like

Same here. Have to restart MSFS to bring the sound back.

1 Like

As an update:

I might have found a workaround to the sound issue switching between VR and 2D. Via Steam, go into Steam settings by right-clicking on MSFS in your Steam library. Under Beta you will find the option to roll back the simulator to Sim Update VIII Beta. As of now I’ve just done a quick check with the FBW A320 but it seems to be working. Even more surprising that the issue is not prevailing in the Beta. Let me know if this helps you out.

Not flagging as solved, as Asobo needs to fix the underlying issue.

Best
Sumner

I’m getting this issue with the store version. Slightly different. Sound working fine in VR in the menus, then the moment I spawn into the aircraft, all aircraft sound is missing. Interestingly, menu sounds are still present in VR - just aircraft noise is missing.

I have to reboot and restart the sim.

1 Like

Same for me, like unbeneva describes: engine sounds are played through the loudspeakers, not through the HP Reverb G2 headset speakers. But radio messages are played through headset…
Please fix this :slight_smile:

2 Likes

It may be coincidence but I think this happened to me in SU7 also. But first day with SU8 and it happened on every flight. All the options on VR setups can complicate trying to pinpoint the issue.

I just kept going in to the Windows sound settings and toggling the sources to get it to work.

My setup is Quest 2, Virtual Desktop, Steam VR.

And another update:

I tried again yesterday evening with the same results: Beta version of Sim Update didn’t work as well :confused:

I will try as you wrote Michail, but still I’m confused, as menu sounds are working.

I’m confused too! I just wanted to fly and kept clicking around until the sound worked. So I haven’t done a good job figuring out what exactly my issue is.

Did you try ingame or also through windows settings?

I might have found a real solution now, in this case nothing wrong with the simulator. Please confirm:

I’ve updated my graphics driver (Nviidia) to the most up-to-date version. While the audio driver remainis unchanged, it might just helped solving the issue. I’ll follow up once I’ve played around a little more with the simulator.

Best
Sumner

Everything I’ve tried has been either Windows or Virtual Desktop (for Quest headsets).

Well back into SU7 I’ve had occasion partial sound issues. There will be no engine/ambient sound but the Garmin may make sound.

Typically that clears up too by switching windows audio devices around.

it looks like this solved the issue for me. Now I’m back at performance degradation with long flights.

I use the HP Reverb G2, and what helped for me was: starting the Microsoft Mixed Reality Portal app before launching Flight Simulator.

Same problem here with Rift-S.
The issue appears randomly in my case, and it is 50% due to the oculus drivers which resets the USB from time to time. Anytime it happens windows changes the default audio output and then restores the rift. This disabling msfs audio (pc audio is ok). The other 50% is due to the new Asobo audio setting, and this is causing the problem.
This happens if I’m lucky. Otherwise it simply CTD.

Same problem here with G2: switching out of VR and back will stop all sounds for me. The only way to bring it back is to restart MSFS.

I see the original poster reported that upgrading to the latest nvidia driver fixed the issue for him. Anybody else can confirm? If this is the case, then all people who reported the issue above should have an older nvidia driver.

I’m having the same problem using a G2. I’ve tried everything sugested but no joy. This has only started happening since sim update 8.

I’ve also experienced this intermittently. I’ve got a Reverb G2.

  • Start flight out of VR: sound is fine
  • Open the mixed reality portal: sound switches to headset just fine
  • Switch to VR mode is MSFS: sound still fine
  • Switch out of VR mode: sound is fine; still outputting via headset speakers (as expected)
  • Close the mixed reality portal: sound switches to desktop speakers for a split second then cuts out; still get sound out of desktop speakers of hovering over menus when paused; but no engine noise, atc voices, etc.

I tried something different the last time. Before closing the mixed reality portal, I fully paused the sim and waited for all the engine noise to fade out. Then I closed the portal and resumed this sim. The engine noise faded back in through my desktop speakers as expected!

Wondering if I found a workaround or just got lucky this time. Curious what happens for others if they try doing it this way!

4 Likes

Hi guys,

thanks for your feedback. I didn’t try any further due to the performance issues since SU8, but I’ve removed the “solved”-ticker, as you still seem to encounter the same issue.

@jminz91: Seems like an interesting approach / workaround. I’m interested to hear if this can be reproduced by the others. Will try it out myself eventually.

Best
Sumner

I’ve just tried your workaround and it works for me too. Nice one for finding it.

1 Like