Warning: Your graphics device has encountered a problem

iam too using multitasking while the sim is opened, never had a problem, the crash scenarios i encountered were different, but the research papers i posted a screenshots from, points to a possible effects on “gpu virtual addresses translation” the cause of this gpu CTD, so i liked to share them as a basic knowledge not official examination to the sim’s gpu addresses translation failure itself.


It happens to me yesterday - the error caused by typing mistake in Nvidia Profile Inspector so my fault :rofl:


Well exactly, it’s not going to affect everyone. It’s almost but not quite funny how everyone thinks they have the most stable PC in the world but then a little bug like this can turn their world upside down. But the real good news is that this is likely to be remedied soonest because it really has gone on quite long enough.


I eventually cured this persistent and very annoying problem by biting the bullet and simply dialling back my overclocked GPU - 2080ti - by 100 Mhz or so, using MSI Afterburner (it was running at 1920, now at around 1800). I’ve noticed no difference in overall performance (although I run it at a fixed 30 fps, and if anything, it now runs smoother) and I’ve not had the error message for a couple of months now.
Why it only started back in September, I don’t know, but as everyone says, it would be nice if Asobo found out the underlying cause and fixed it.

By all accounts the problem has been found (see above) so presumably a fix is being worked on.
It’s not down to Asobo but more to do with MSFS not having strict safe performance caps which to be quite honest nobody wants. The time for that if ever would be before final release and that’s a long way off yet.

1 Like

Where is the rference to the problem being found?

Ok a bit of presumption on my part but the two white papers a few posts up … hopefully they provide enough information for a fix to be found

No, they are just papers, OP posted them in good faith but might be completely unrelated to this.

Maybe maybe not but we can all hope. I have long maintained video memory management/clockspeed is the main culprit and this seems to be right up that street. Even if it’s a windows/microsoft dll runtime error it’s vram where it actually hits us.

1 Like

The frustrating part is that after having the CTD for a few weeks, I did something and spent most of February CTD free, then NVIDA has an update to the driver, and WHAM back to CTD that happen about three minutes into taking off…

i agree.

the thing is this is not totally a bug, or a programming error, its kind of conflict in the sim’s performance behavior, since this CTD is happening only to MSFS, it means somewhere there in the sim can be tweaked to resolve this by the devs, hopefully.

as a small example, Hogwarts Legacy can hit 15 GB Vram usage @ max 4k settings with 100% gpu load with 70-90 c temp an average, without a single crash, & up tp 48 GB RAM with Virtual. however, experts from TechPowerUp revealed that some bad implementations leads to a performance issue in the game.

this is just a concept of how small things if tweaked right, the performance can always run right.

Link for reference:

Hogwarts Legacy: FSR 2.1 vs. XeSS vs. DLSS 3 Comparison Review | TechPowerUp

a game never implement a “performance cap” , why ?

If the system crash in high load, then it is not the application which is possible faulty . It is the system : a piece of hardware, a wrong setting, whats ever. If that is ensured the reason for the popup, then it would also explain why only “some” users get it and not all - the majority have a issue-free-system.

I have the exact same problem and reverted to Nvidia drivers 517.48 and so far no crashes anymore.

Yes that’s one of their most stable although those following it are slightly quicker. Just don’t try to hang on to it forever or future features won’t be supported etc.

1 Like

Hello All,

I tried starting the game today and received an error indicating I needed to update NVDIA drivers to greater than 526.98.

I did so and now I get an error that says that my graphic card may be overclocking etc.

Before posting I have tried / watched (youtube) / read every possible solution to no avail.

Does anyone has an easy fix for this error or at least some guidance?

Many thanks for your help.


The only remedy that has consistently worked for those with the bug is to underclock the GPU memory the GPU clock or both by some number, start with 100 or 200Mhz. You can do that using MSI afterburner making sure you click the tickmark to apply the changes.
It doesn’t matter if your GPU is overclocked or not just underclock it with afterburner and see if it helps.

This is on second place on “feedback logged” issues. And the only one up there that really is “devestating” to those who encounter it. The game just quits. So I hope they put effort into this one.

Current status from my part is that I forgot do downclock my card today. Still worked fine for me. Just now…

1 Like

It’s a massive thread. Whether it’s still quite as huge a problem as it was I have my doubts but of course that is no consolation to those that still suffer. Overclocked or unstable vram seems to be the biggest culprit but I’m sure not only so let’s see what NV, MS and Co finally come up with.

Yes it’s still a huge problem and getting worse. Last week I could do short hour long flights. Now I cant fly for more than 10 minutes without a ctd.

Maybe you misunderstood what I meant - there are considerably less people with this issue now as before, presumably they followed some of the advice peppered trough this thread but of course it hasn’t helped everyone … you are obviously one of the unlucky ones and yes the problem is certainly huge to you. Fingers crossed it will soon be relegated to the bowells of history.

1 Like