Warning: Your graphics device has encountered a problem

I’d given up on the sim while this graphic problem is still going on. I had been exclusively flying the PMDG 737. I don’t believe the 737 is the cause, but it is an airliner. Over the last week I decided to fly a GA plane and have been extensively flying that for seven days and in all sorts of weather etc. Not flying above FL150. Not once have I encountered the graphic error message during this time. Now I’m not suggesting this might be something nor am I interested in any sort of troubleshooting as this has to be down to Asobo.

Today I jumped into the 737, flew for about 1 hour, and the dreaded message appeared!

It’s weird, eh?

2 Likes

I’m totally over it. I’ve been playing around settings everywhere conceivable and the sim keeps crashing. I’m not going to touch the sim until it’s fixed as there is no point investing time with something that’s broken.

6 Likes

I am afraid you will never now if it is fixed for you particular situation if you don’t touch the sim. So just re-energize again, and come back when you can. Been there many times :frowning:

1 Like

tl;dr try a clean install of nvidia drivers 516.59, it worked for me.

=====

I have been playing this game for about 2 years, and I have never had any CTD issues. I recently plopped in a 3080ti to replace my 3070, and the graphics card error started happening while the game was loading. Could not even get into the game.

I downloaded to the 2nd newest nvidia drivers, same issue. I tried all of the other suggestions, nothing worked. A fun 3 hours!

I tried nvidia driver 516.59 last night, and all is perfect again. No idea if this will help others or if I just got lucky, but it worked for me and is worth a try, with a clean install.

Cheers

Before they released the game on Xbox it worked just fine. MS is not capable of distributing updates. Its a known fact.

1 Like

I get my update, thus the distribution of updates works well… but not sure how relevant that is for the topic :wink:

Well ok. I used the wrong words. They are capable of distributing updates. But the updates themselves are not always good updates.

I also have had no problem applying the updates, but in this particular case the application gets broken almost every time an update comes out…

You just need to wait for some week after an update, then it works again…Until some week before the next update, then it´s CTD time again…

They do need to speak up on this matter…it´s so obvious and annoying…

I have the same problem since i switched to DX12. Happened to me in VR when I tried to switch from cockpit to external view.

RTX2060S, driver 526.61

There is no problem having errors - bugs - conflicts, in any sort of updating process, to the OS, a software, a game…

the updating process is like a Lego, when you put a new piece for an intended advantage, sometimes you need to adjust other lego pieces due to the influence of the new lego piece.

the real problem will be in a case that we cant fix this complication, then what an expert meaning is revealed, & an appropriate action is needed as a result.

this can be handing over the fixing to a more specialized experts, even if it’s only temporary.

but this is rare, most cases just takes an extended periods of time to locate & to fix.

Yes, and therefore testing is needed prior to updating…

Can you suggest how it’s possible to test every hardware, software and peripherals configurations that over 2 million users of MSFS may have? Not to mention all the customization possibilities.

That would be a task.

4 Likes

Since an issue is under active locating, there is no complaints. Errors are part of making a software a masterpiece both in content and performance, in the end.

but after we acknowledge the complexity in the tech field generally, there is some helpful indications:

  • to be specific about this issue particularly, when an error is common to the latest and most powerful hardwares, and to a large set of hardwares, then we can conclude that the error is not due to a lack of hardware capabilities, and not related to the users hardware in the first place.

  • when having the error while not changing any settings, then trying changing every possible setting, then thats an indication that our problem not in the settings itself.

  • when the gpu is not overclocked and the temperatures are normal, then the error is not due to an overheating problem.

  • when we have the issue in vanilla sim, then the error is not due to add-ons.

  • when we encounter the problem in 4 nvidia driver versions, its so unlikely a driver failure, especially when nvidia confirms that they released combabilities with the sim latest updates.

  • when we reinstall the whole OS, then we can conclude that the problem is not due to an error in the os.

whats left?

  • its unlikely being the issue due to a programming error, because these are often obvious and easy to locate and usually not random like this issue.

  • personally, iam almost sure its due to a conflict in su10 update changes, which explains why we have the error in the installation process, and can explain why the error only happens to MSFS.

well, thats what i can conclude by following this thread up till now.

what we can suggest?

  • Microsoft already offers the uninstallation option to any installed update in the win for troubleshooting purposes, i think implementing that to MSFS is superb.

  • if not possible, restrict procedures of releasing betas is a must.

what we can demand?

since this is a common thing to have erros - conflicts - bugs - since the early days of dealing with windows and software running on it, we can only be helpful by contributing in tests, results, suggestions, and finally patience, in hope a certain problem will be fixed.

You made six points in your opening, all of which can and have been disputed so I respectfully disagree.

1 Like

These are only indications and personal conclusions, not official investigation results. most of them from simmers reports, personally, i encountered the error just in installation and first launch after updating to SU10, & can’t tell afterwards, as i didnt have any free time to test on my own.

but the main thing we all agree about is that this issue is an important thing to solve, no matter what is the exact cause is, which we cant really know it since we are not whom developed the sim, & dont know the structure of its internal proccess with our systems.

Indeed, it would!

I certainly can’t, nor would I even try!
But I do assume and hope, at least, that there are development computers (AI) that have been fed most if not all the configuration possibilities and are hard at this task.

You’re a master of understatement!
:wink:
There are some folks who have lower thresholds of pain regarding the complexities of today’s technology. They see it as either it works or it’s broken, it’s on or off, black or white, or now or never.

I truly believe that despite all of our theories and testing based on our myopic personal experiences, we’re all just basically floundering around here trying to find that gold nugget.

For many of us, much of the fun is in the challenge and the hunt, so to speak. For others, not so much…

Patience is the key, though.

5 Likes

Had this error come up on DX11 for every flight post SU10 (no CTDs before SU10).

Changed to DX12, had about two weeks of smooth sailing but it just occurred again.

This is a serious bug which which kills any hope of flying (and wastes our time).

5 Likes

Switching to DX12 seemed to have helped but now the mouse scroll wheel stops working from time to time. And the view-look issue still hasn’t been fixed in over a YEAR AND A HALF.

I use to fly every SINGLE day, but I haven’t in about a week. It’s no longer enjoyable fighting thru these issues. This whole thing is turning into more of a mess than it’s worth.

pla

1 Like

Sorry, haven’t been here in a while and I don’t think I answered you, but I did check that and that file is in that folder. Thanks for the suggestion!

I turned anti-aliasing back to TAA with otherwise optimized driver settings and have not gotten this error in a while (knocking on wood).

1 Like

It’s one of like 37.2 fixes, I hate to keep broken record repeating but this is a catch all message with nothing or everything to do with what the words on the pop up say.

It might have been a video error a memory error a program error or operating system or internet, Ethernet or CPU but the program felt a little wuz zat?? and throws that up.

It’s truly frustrating as it’s none all and some causes always never and sometimes.

1 Like