We need a HOTFIX for CTDs - Sim Update 5

I used to be in your camp until SU5 - can’t recall a single CTD. Now I have CTD in approximately 75% of my flights around the Seattle area, not to mention frequent 60-120 second freezes when approaching KSEA.

Same. CTD during a short fly time.

My event log (Nvidia 3090, Driver 471.41-desktop-win10-64bit-international-nsd-dch-whql

Faulting application name: FlightSimulator.exe, version:, time stamp: 0x00000000
Faulting module name: FlightSimulator.exe, version:, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x0000000002301000
Faulting process ID: 0x397c

I’m not having any issues currently. Vr is smooth, and all my satellite imagery is great, and everything is working great.

But then again I never uninstalled xplane and gave up on Microsoft flightsim after this update until I can fly in there with what we had at release.

One thing that I’ve noticed is most of the crashes occur when Multiplayer All is turned on and I’m in busy areas like London / New York that are overcrowded with thousands of players. Might be something there…

CTD nightmare with SU5! :rage: :rage:
I have filled some tickets and hope they soon find a fix…this is unplayable and unacceptable


I would also like to report that I am having CTD issues with Sim Update 5 that I’ve never had before. MSFS had run perfectly without problems. Did about a 30-minute test flight of the update and the game crashed as I was about to start my descent into KPDT. Was going to try again today but couldn’t even get to the runway before it CTD.

Yep, i installed Windows cleanly on Sunday so I would have no issues. What a waste of time that was.

Did anyone else download the update (40.27gigs) then have an additional 20.44 gigs of downloads awaiting in content manager? I’m having the CTD issues described here as well as many in-game challenges (nav not functioning on Garmin after Garmin package update), odd controller drift, etc. Doesn’t feel like a clean update release.

1 Like

Yes, most had the ~60gb spread across 2 downloads (the main game update window and then in the Content Manager). My garmins also initially did not work but that’s because I had not deleted/turned off my Garmin mods from Working Title in my community folder (yes, I had only moved some of my mods and not all of them before doing SU5 update, so that was my fault). I just removed all of that with my Add-On Linker tool and it all worked great then in base form. And Working Title has already posted new versions of the Garmin 3000 already that are SU5 compliant. For the Garmin 1000, I downloaded the one that is in the MSFS Marketplace (1000nxi) from Working Title and it’s great, or you can get the version from the WT Github/webpage that is very similar, both work fine. I have not yet seen the G3x mod from Working Title for SU5 but I am sure it’s on the way.

Just gave it another try.
No Mods, no AI, no Multiplayer.
Still half way of the flight, in cruise without anything going on or me touching anything → CTD

So I give up trying to find a workaround and wait for ASOBO / MS to release a fix.
But as I ruled out everything they published on their “Known issues” list I am afraid this might be 2 months till SIm Update or probably never happening.

Forcing an Update without an option to roll back when it simply doenst work for some, leaving those with an unusable program is not consumer friendly at all.

I am very annoyed and angry by this and even more disapojnted that there is no communication by the DEVs on this…


Its ghastly. While just in the menus it suddenly froze with GPU usage going to zero - but recovered.

Then running in 4K /60 Ultra with a decent Ampere GPU and Zen 3 CPU it was nearly 100% GPU when I see the Series X manages 1440p/30 upscaled with equiv quality.

Then after just minutes of playing a CTD Event 1000 Exception code: 0xc0000005

why, there are a huge number of ppl flying around now, i saw tens on mp.
so clearly not everyone has the issue.

Must be the xbox folks…from their point of view it’s probabaly amazing. We know better.

1 Like

I had also CTD after CTD since SU5…Now it is all gone. What i did?
Deleted all TESTPILOT and XBOX Liveries ( 3GB!!) But this was not the clue i think. What helped also to an better Performance is:

Unsinstall your Nvidia Drivers with DDU ( Display Driver Uninstaller )
Clean, custom Install the of the old good one Nvidia 457.30 Drivers. ( only the Drivers → check "reset Settings )

All Problems gone! No one CTD since then…give it a try!


1 Like

With any widespread issue people always have their own fixes - or make it never happens to me posts - but the CTDs will be random so its impossible to relate config changes to an actual ‘fix’. Only the devs have access to the tools that show the cause and the source code to make actual fixes.

That’s weird - my in-game Garmin 1000 download isn’t working. I’ll try an uninstall/reinstall

I made my own game: read the latest postings and see if you can get back to the mainpage without any new postings. I’m not fast enough :slight_smile:

Would you please mark this post as solved. That would direct people to your solution.

I had no CTD directly since update but it freezes regularly, so I have to kill it via task manager. The sensitivitie settings for joystick are bugged to, many stuff is inverted, but should´nt (not marked as inverted, but it is inverted).
Surprinsing that in year 2021 a company can still deliver updates, that all makes it worse as before. In this case is had been better to make a seperate version for console players and don´t add bugs to PC-players

The PC version is separate in terms of being on a different branch, being DX11, not being built for console h/w only etc etc. But their engine efforts over the last year will have been mainly for consoles for business reasons with changes coming over to the PC branch (maybe) - there’s no way they could support two completely parallel teams.