We need a HOTFIX for CTDs - Sim Update 5

Much appreciated. Unfortunately I’m sick of having to fix this app everytime it updates. Why do end users have to fix anything or troubleshoot crashes?

1 Like

You are totally right @monkeytennis245 but at least we could give Microsoft/Asobo something to work on :wink:

A post was merged into an existing topic: Completely unplayable and horrifying performance

I don’t have steam. Only through the store and since the hotfix no issues [at least with CTD]. I have RTX3060ti and i10700F and no mods. Like that it would seem it runs perfectly fine. I’ve now done a dozen IFR routes in the TBM 930 and apart form the autopilot trying to kill me everything else seems just fine. I also have VR and that has been behaving itself ok, but I only do short flights with that because my face hurts and it makes me sick.

I don’t know if anyone else made this suggestion, if so, sorry to repeat. I had massive CTDs after Sim Update 5. Clearing rolling cache solved the issue for me. I say “solved” but while the sim has been stable, I feel as thought it’s just hanging on. I have nothing to back this up, I guess it’s just low confidence after my update nightmare. My new procedure now is to clear rolling cache after any content change even when adding the standard, free content from Asobo. It only takes about 2 minutes. General Settings > Data - turn off rolling cache, delete rolling cache, turn rolling cache on. When you exit this setting it will rebuild. It takes less 2 minutes on my PC. That said, the only non-standard content I have is the FBW A32NX. I suppose it could take longer with more 3rd party content (just a guess). Hope this helps someone.

I have re-created the rolling cache, removed everything from Community Folder, and deleted all 3rd party content from the marketplace. I never had any crashes pre-SU5. But even with the cache re-created and all 3rd party content gone, my SIM either freezes mid-flight, during a load (not for the game but into the actual flight), or CTDs completely at times during flight or during loading into a flight.

Really hope Asobo fixes these problems. As of right now, it’s frustrating to try to sim.

I did a fresh windows install yesterday and vanilla MSFS. I still get a CTD for some reason…

Fresh install has never worked for me, gave up on it a while back.


Obviously this won’t work for everyone, but I am able to fly for the first time since release of Update 5. I tried everything under the sun. What worked for me was the following: Turned off Memory XMP, and turned off GPU overclock, and inside Nvidia Control Panel - 3D settings for Microsoft Flight Simulator I set Preferred Power setting as Prefer Maximum Performance. Hope this helps someone.

GTX 1660 (latest update) - i5 9400f - 16GB DDR4 RAM - Game installed on 500GB SDD (NTFS) - Windows 10 Pro (latest update)

I’m getting almost continuous CTDs now and had none prior to SU5 with loads of community content, I’ve removed everything from the community folder and all caches recreated, now getting random CTDs even on the built in landing challenges! This is on a recent install on a brand new machine. This is, also, on top of SU5.1 stopping some of the buttons on my thrustmaster airbus HOTAS from working for some unknown reason. Its getting to the stage where I’m dreading updates and spend more time troubleshooting and trying fixes than actually using the software.

C’mon Asobo sort it out

1 Like

i dont have anything called content.xml in that folder

New update did not solve my CTD issue. Have not flown in almost a month due to CTD when clicking fly now. I’m asking for a refund ASAP

CTD are back after the last Hotfix, What the hell is asobo playing with !!!

1 Like

Updated SU5 hotfix2, cleared the Community, updated the content manager, updated win10, updated the graphics driver, after selecting the airport, CTD will be CTD when the progress bar is halfway loaded. Now MSFS2020 cannot be run normally, and it has been CTD. Is there any solution?

1 Like

Same here, CTD’s after CTD’s That sucks. Before SU 5 everything was fine. Never had that sh… with MSFS before.


Same dude, i sended an email to the “support”, and they told me it’s may be my config, i have a ryzen 9 5900x with a 3080 ti and 3200 mhz cas 15 ram .
Devs are joke.

i don’t care about xbox players … it’s a simulation so it will be fine if devs give us choice to downgrade our game to play on a stable version without online in order to wait a real f***ing hotfix.

1 Like

I’m finding that the CTDs go away if I disable Live traffic and Multiplayer.

There have to be a source for the CTD for sure.
There is a trick to elimiante all CTD for ever: dont start FS2020.


Getting tired guys !
Ctd after Ctd !! Before Su5 everything was perfect !!
I have no idea what happened but i Do Not enjoy my msfs anymore !!
Today i tried again and in One hour i got 3 CTDs !!
This is Unacceptable …
I hope the guys at Asobo could solve these issues asap !
We do appreciate their efforts for a better Sim , but definitely one with No CTD’s and various problems.
I forgot to mention that , whenever i try to Zoom the Map in order to select an airport , i get an immediate CTD !!

1 Like

There are just so many issues with this Sim at the moment it’s painful to use it. My experience for the last 20 minutes…

  1. Set up flight and click fly. Whilst it’s loading make the rookie error of turning on my Bluetooth headphones which of course leads to the loading freezing and becoming completely unresponsive.
  2. Quit FS using Task Manager, load it back up, go back to the World Map and put in my Departure airfield. Complete freeze of everything this time (the 1st time I’ve experienced this), such that the only way to regain control of the PC is to hold down the power button until it shuts down.
  3. Reboot the PC and load in again. Get into the game this time and find that for no reason my GPU is completely maxed out but is at 35 degrees and the fps is 14 instead of my normal capped 50.

Fourth time lucky?! Before SU5 I had zero CTD.

Can they really sort this out by Aug 24th, with everything else that needs addressing? I sure hope so but I’m not remotely convinced.