Why is MSFS asking me for settings at update page for my settings EVERY time?

Trust me, this is very frustrating even though it sounds like a banal thing, why is the sim asking for my settings every time I start the sim now after the update?


same here and all my presettings for the joisting are gone since the last update

It is time to take a break from this sim…


Sounds like an issue with synchronising Xbox account/servers.

Agreed, I have the same issue today, coupled with the FPS tanking since the last update it’s time for me to move back to x-plane until they fix this.


same for me…that’s so annoying… has anyone managed to resolve it? I get “Accessibility settings” every time when i open the game, all settings are gone and I have to spend 10 minutes setting up again and again

1 Like

What did this comment add to the discussion? Have you considered being polite, it does not cost anything at all and might make you look less like a dork.


I have the same problem, is there a soloution for this?

Yes i gave a solution that worked for me but it was flagged by the community because i also called OP a drama queen for saying “Time to take a break from the sim.” for the umptienth time.

The solution was: Log out inside the sim (click on your name in the main menu and sign out) and sign in again. This worked for me, hope it works for you too.


Workaround > https://forums.flightsimulator.com/t/ui-broken-and-reset-user-settings/368832/159?u=tenpatrol

1 Like

OK, will try that, thanks.

1 Like

Sorry mate, did not work but glad it worked for you.

Workaround seems to have done the trick for me…

Edit - one day later after pc restart the issue persisted but updating gaming services via the store fixed it.

1 Like

Its already fixed. Microsoft updates the game service app. See the other treath.

1 Like

I was editing my post as you were typing :slight_smile: thanks sorted it now

Having this issue too… every time I start the sim I have to redo literally all my settings :roll_eyes:

Update Gaming Services from Windows Store - it should fix the problem.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.