Why is the auto pilot not working correctly

Ok, so after the new update and hotfix I went in to just fly around a little. When I did I noticed a few things. Let me tell you what I fly in the Sim. I fly the cessna 172 with the g1000. I created a flight plan with little nav map as I have been doing for a while now. Loaded the flight plan and began my flight. I noticed the Nav log was different. Going direct from one airport to another The Nav Log had three waypoints. The first one I expect was my enrout climb, the second was I assume the direction or bearing to fly to reach the airport. The third I assume was the actual bearing to the runway. As I was flying I decided to let the auto pilot do its thing. What I noticed was that I was flying on course at the correct heading or bearing, how ever I was not flying the magenta line as as it always did but now flying of to the right side of it. Has anyone else had this issue

If you look closer you’ll see neither left or right mfd show you flying the same path. If you hit v it shows another…

I dont understand what you mean Phineasfogg

The map zoom does not accurately show you on the line at the default zoom level. Unfortunately, the Zoom knob is bugged in many cases, but as long as the Scoreboard Annunciator reads GPS in green next to the AP indicator, you are guiding on course.

The G1000 in the planes is stock, no frills, effectively not far removed from August 2020 launch, which isn’t saying much.

Your options are:

  1. Stay with the Stock GPS as you have now.

  2. Install Working Title G1000 0.4.0 which is essentially No. 1 but with working Engine Pages for the MFD.

  3. Download the free G1000 NXi by Working Title from the MarketPlace. It’s far ahead of the stock Garmin, but still Early Access, meaning there are many things not working compared to 1 & 2 but WT will deploy a new version weekly that fixes bugs and adds features.

Working Title was hired by Asobo to fix the Garmins. Eventually everyone will have the NXi when it gets integrated into sim core code.

1 Like

Another alternative is to fly the Steam C172. I don’t know if Asobo have worked on it, or it’s some sort of back engine from the WT upgrade, but it’s suddenly started behaving itself (it used to periodically try to fly you to the moon or the earth’s core :wink: ). It’s still not quite right I think but it’s way way better now.

Or just fly straight VFR and/or use VORs and ADFs.

1 Like

I have experienced the same problem. I fly the 172 steam version. I also use Little Navmap to create my flight plans. If I creat the flight plan in the world map everything seems to work O.K. If I use Little Navmap loaded flight plans, it doesn’t. Something was changed in this last update that has messed up the flight planner. I do not like the automatically added “Time Climb, Descent, etc.”. I wish they could be turned off. I think these were added for the Xbox.

1 Like

FYI

We have a new master Pinned Post for the Working Title G1000 NXi. Please join the conversation there:

2 Likes

how do you get the Steam c172? I ask because I didnt buy msfs2020 through Steam. it was bought form the Xbox app on game pass, it is the pc version not the xbox version

I think the game pass is the basic version. To get the steam 172, you need to buy one of the paid versions, List of Microsoft Flight Simulator 2020 Planes and Aircraft | Windows Central , it’s.only part steam, gauges but still has the g1000. If you like barebones flying try the 152

yesterday i noticed the auto pilot worked as it should until i looked around the cockpit with mouse right click button
i have set a switch just for localiser which results in a work around (airbus 320 neo ) pc version

Blockquote
I had the same issue of drifting t the right. Both on VOR and ILS. Cessna Caravan(stock G1000) in Mumbai Rwy’s 14 & 27. GS was captured and the descend was too fast and way short of Rwy. Manually landed.
Unable to set a proper flight plan (G1000) now. I say now coz when I had the G1000 a month or so ago, it worked beautifully. Unfortunately the G1000 Nxi gave so much trouble, it was uninstalled and reverted to the G1000. Sorry state with MSFS 2020 with so much money spent. Little joy.

Sorry guy’s, the intention was to ‘add’ the quote (prior post) by ReliableSteam82 and inadvertently pushed Blockquote.

Auto-pilot doesn’t work for me on smaller aircraft (Icon A5, JMB VL-3 Vertigo, Beechcraft Bonanza etc), I tired it on A320 Neo and after three hours, my distance to the destination didn’t change. For some reason, it kept circling after some time over the Pacific (Asobo Studio to Microsoft HQ flight).

I saved the flight and shut down the computer after over three hours of gaining nothing and have never dared flying the A320 Neo again, except for the Landing Challenges.

I have placed all Working Title Garmin systems files (obtained from their website, latest versions) into the Community folder but I don’t see any change at all in the navigation system.

What am I not doing right?