Windows defender doesn't allow to install the SDK

Tried to install the SDK and the example plane. But when I click onto the .msi files Windows Defender tell me that my PC was secured and it doesnt know the origin of the publisher.
Has anyone else got this problem. Or is there a workaround ?

Screen Shot 08-18-20 at 03.57 PM Screen Shot 08-18-20 at 03.56 PM 001

1 Like

I got the same message but on my dialog window there was a “More Info” link that when clicked added a “Run Anyway” button that then launched the installer which ran to completion.

Did you try to turn Defender off then install?

I tried to turn off the defender, also adding the .msi file to the defender exclusion list. But it still shows up the message. Unfortunately I can only select “dont´ run”. There is no “run anyway” button.

There is also no option to run the installer as admin. Something is still blocking the installation even with defender switched off.

Maybe I need to restart the PC with defender switched off , to completely disable it. Just trying that now

ok found the solution. Its not the defender that is blocking the install, but “Windows Defender Smartscreen”

It is found via the Windows search bar, typing “smartscreen” -> App and browser control and then turn off " blocking" of files and apps.


just click the “MORE INFO” and it will allow you to bypass it, because its a .msi file, smartscreen automatically flags it.

1 Like

Well I didnt have “more info” on the warning message, I just disabled this defender smartscreen thing and installed the .msi file.

you should have

How is that even possible that an MS SDK is getting blocked by a MS device…

do you guys even Develop Games or wut??? this entire launch has been a massive joke.

1 Like

Because any antivirus will see any exe file being downloaded via a web browser as possibly harmful… Especially one thats 1.3GB… its not an microsoft issue.

That’s MS SmartScreen filter, it needs to be updated. Wait a few days and it works. The .msi is too big for scanning so SmartScreen is warning you. You can mark this file as safe to help others with this.

Oh but it is a MS issue padawan.

AV would ask me to allow or disallow, this straight up denied it all together and further i don’t have an AV installed.

It’s not denied, at least not for me. I could choose if I want to block it or execute it. Even though it’s a MS application it doesn’t mean that the filter gets updated so quickly. Because this msi is a developer tool and also very large, defender / smart screen can’t scan it. That’s the reason for this warning. If you want to develop something, you should be able to get around this.
This doesn’t happen to MS applications, only. Once I downloaded Teamviewer and got the same warning, and even with the epic launcher right after release (GOG Galaxy as well).
You can disable this, if you don’t want this kind of protection - it’s designed to create a safe environment for people who aren’t doing very well witch computers / windows.

I scanned it after downloading with Windows Defender. Was reported as safe by scan but SmartScreen still blocked it with no option to run away. Will follow Laut’s advice to temporarily turn off SmartScreen.

The problem in pic below. You’d think with “Microsoft” software that they could give it a valid digital signature, considering all the other stuff invested in the effort…


I found SmartScreen by searching Win10 settings for SmartScreen, App & Browser Control, Reputation-Based Protection (or paging directly through Settings, Update & Security, Windows Security, then to App & Browser Control, same from thereon…). I turned off both settings under Reputation-Based Protection.

1 Like

All - SmartScreen stops SDK from installing, I did have the “More Info” button. But I think you all need to be owner and full control on the whole C drive for the SDK to work properly. I did this and have access to all the files in MSFS period. The permissions are causing some issues, so just take control of the C drive and you should be good to go. Upon initial install of MSFS, could not gain access to the files/folder for the Simulator, I finally just took over the C drive (assumed install location) and nothing is blocked now. For development, this should cause any issues you are having new planes to be created to now at least show up and be counted. Now if they really work, that is another fly in the soup. It will take a few steps to be Owner-Full Control of C, if not familiar with process, someone more experienced than I could help you. I futzed around with it until I could get it to take, and it really wants you to be sure, you are aware of what you are doing, and then again, it still blocks some files from your access.
As an aside, I read the getting started html opener, and it was more complicated than my brain can process, so I’m leaving content/plane development to the real smart people, but volunteer to test any thing you create and let you know it works, if it blows up MSFS ok, lots of it has issues. And, think if you develop anything, you will have to tweak it, every time a patch is released because the code in the patch changes things enough that your “content” won’t work. That is another reason the commercial developers are waiting on most of the aftermarket Aircraft, they don’t have money to pay to rebuild the code for their planes each and every time a new patch is released. With the current schedule of two a month, lots of trouble for little gain at this point. I for one would be thankful for new stuff, but, it will be a labor of love to the rest of us because of above.

I have upgraded now to the 0.61 SDK and I haven’t had to do anything other than search Win10 Settings on “Smart Screen” and go to Reputation-based Protection and temporarily unblock the two settings related to app & browser downloads off. For SDK version 0.51, I was able to compile the Simple-Aircraft tutorial example, place the package in my Community folder and I could launch the aircraft in the sim. All the SDK tools that I’ve tried work fine in DEV mode when in the sim (have checked much with SDK 0.61, though).

I normally run with administrator permissions. My MSFS install is on a non-system NVMe SSD and the MSFS SDK is running off a different SATA drive.

Glad it’s working for you. I have had trouble with websites recently unrelated to MSFS, but nevertheless, Windows Defender is blocking some of them coming in. I follow an author, and his site is blocked, and I cannot figure out how to get it cleared. Something changed in WD, and me no like what they did. Never had this issue with Zone Alarm which disables WD. But ZA blocks all downloading of MSFS, maybe just never going to win in the battle.

For a couple of decades (3 or 4?), I anted up (as in “antee-ed”) the moola for Norton or Symantec security software. But reading recent reviews of Windows Defender giving it high marks relative to leading 3rd party software and going for periods as a Windows Insider where Symantec wouldn’t work with the latest build and finding Symantec more like a constant running ad for additional purchases, I switched to Windows Defender. In taking eleven Microsoft courses at (before MS left), I searched the web high and low for information on machine learning, math, etc., to supplement or help understand the course material. I never had a site, that I can recall, blocked by Windows Defender in something like 2 years of searching high and low on the Internet for helpful information. Perhaps sites related to gaming are a different matter in term of looking “suspicious” to Windows Defender?

Hello, I read a sci-fi series Called Kris Longknife. The author Mike Shepherd website for the series is, and a minute ago, I get this message. If it’s not WD, then I aint got a clue.

There has been a critical error on your website.

Learn more about debugging in WordPress.

I ran a scan no virus or malicious content on system. So I have tried to allow the site, but unsure exactly how to do it. There was another one, cannot remember now what it was.

I have been a loyal Zone Alarm fan for years, but its antimalware feature blocks MSFS from downloading period, so it’s off system. Once more stable patch system in place will put it back on, but once the two years I paid for is up, staying with WD, as it’s as good as anything else out there and is included with the OS.