Working title G1000 in marketplace today, not working for me

Just noticed the G1000 mod is available in the marketplace today. Installed it and had a go in the Cessna Caravan but most of it is not working for me.

The direct to function lets me enter a destination but I can’t activate it, and the middle screen is so dim I can barely read it.
Also that screen locks up if you play around with any of the options that are not greyed out.
Anyone having any success with getting it to work ok?

Tup same hear … almost nothing is working for me

Moved to #third-party-addon-discussion where it’s better placed.

I strongly recommend you join the Working Title Discord where they have an NXi Early Access Channel. You’ll get more responses quicker that way.

And I emphasize “Early Access.” This is the state of the Garmin right now. For those seeking stability, Working Title released an updated G1000 called 0.4.0 which is basically 0.3.7 with SU5 compatibility. It lacks all the bells and whistles of NXi but is very stable. Look for the link the WT Discord Garmin Channel. And remember you can only have on or the other installed.

OK thanks.
Seems strange to release a version on the marketplace that appears to have so many bugs that it’s almost unusable though.

It’s not strange, WT declared openly that this was being done to give folks what they wanted - an improved G1000 with more real-life features. And the G1000 NXi’s delivery through the Marketplace cements how Asobo is paying the bill for WT’s efforts - it makes the mod “Official.”

It’s the exact same way they deployed G1000/G3000/G3X and the CJ4 mod. They were a series of iterations that rapidly improved over time as small bites of features and stability were added on with each change.

Fair enough. I hadn’t tried the Mod before but had read good things about it, was just surprised they’d released a buggy version to the marketplace if they already have a more stable one available.

G1000 0.4.0 lacks many of the procedure legs needed to make the Garmins more useful and realistic. It’s stable, but not full featured. Like many Agile lifecycle projects, you fail small (bugs) but make lots of forward progress because of fast, multiple iterations. Argueably, the factor that may slow down WT is the relative pace of how soon updates to the NXi can be uploaded to the Marketplace, as many other third parties have found out to their product’s detriment.

Tell me if I’m wrong, but I think the latest version of the WT G1000 (version 0.4.0) is a downgrade compared to previous version 0.3.7. There is no PFD any more, it is the standard MSFS G1000 with engine page added, not as good as what we used to have from WT.
We can easily imagine they did this because they released the NXi that is supposed to replace any G1000 in the future. But as some said on this forum, the NXi is not finalized, it is an early version, and in my opinion it is dark and very hard to read in the sim, even with brightness set to maximum.
I am afraid we will have to wait a little more before having a complete G1000, but I will not complain because I really like the look of the NXi, it looks good and very realistic, I am sure it will be a great add-on when it will be finalized.

I tried the pre-release NXi version and found that, FOR NOW, I prefer the functionality of their G1000 mod. Because of that I removed the NXi version via Content Manager and installed the WT G1000 v 0.4.0 and it works fine for me. For me it is actually better than 0.3.7 as 0.4.0 fixed an issue that I had with scrolling of aeronautical features on the map. I really, really like it.

Do you perhaps have both the NXi and the v 0.4.0 versions installed at the same time? WT stated specifically that the two do NOT work together: you have to have one or the other and not both.

We have a new master Pinned Post for the Working Title G1000 NXi. Please join the conversation there: