A32NX AP from HDG to NAV? APPROACH Button not working?

Dear all :slight_smile:
I have not flown the A320NX (flybywire) for some months.
Now I downloaded the latest developer version, but struggle with something very simply in the autopilot:
I set up a flight plan in the world map, then start the flight and take off. But I can’t manage to bring the autopilot into flying my route. It’s always in HDG mode… but I want it to be in NAV mode so it just follows my route.
That worked super easy back in version 0.6.x when I last flown it.
But know I can’t get out of HDG mode… what is the trick here?
THanks a lot,

I believe you need to “push” the heading knob to enter NAV mode.

If you “pull” the knob you are in HDG mode.

Hold left click on Knop

Then while holding down left mouse button

    • right mouse button for pushing in (nav)
    • middle mouse button for pulling (HDG)
1 Like

Thanks guys, I figured it out!
However, now a new problem occured: I was not able to enable APPROACH Mode… the button just did not turn green and therefore of course also no glideslope was catched.
I landet on the same airport as many times before. Usually when I set the flight plan in the world map, I was just able to push the approach button and it went green and catched the glideslope.
Not, that’s not working anymore. Why?

Check rad nav if the right frequencys are set
And an approach is actually selcted in the fmc

Since this involves the FBW A32x, the thread belongs in #third-party-addon-discussion:aircraft

You need to be tuned in to the ILS frequency first, and press the LS button to display the ILS signal. Once the signal is detected (you see the purple frequency appeared, and the purple diamond icon is visible on the PFD with the LS on), then you can press the APPR button. If the signal is not detected yet, you won’t be able to arm the APPR.

Thank you.
I have to say: I’m not familiar with the FMC and frequences.
In the past, it was possible with the A32NX to set up a flight plan incl. RNAV landing in the world map, then start the flight and the autopilot was properfly following the path of each waypoint without ever having to go into the FMC.
All that was needed was to switch to approach mode (approach button of the AP) and it worked.
So that is not possible anymore?
I mean the flightpath still works… the only thing that seems not to work is the approach mode at the end

Yeah, with the current FBW Dev mode, they’ve implement the new FMGC function in the aircraft. This doesn’t work with the default flight planner and the default ATC anymore.

So if you want to keep using the default flight planner and ATC, you can only do so in the Stable version (for now, at least until the new FMGC gets deployed to Stable version, which in that case meaning all FBW A32NX version will no longer work with the default flight planner and ATC).

Otherwise, you’ll need to go through the FBW documentation on how to set the flight plan properly. Including assigning the RNAV approach.

Oh I see. Thank you.
Well that’s kind of a bummer for more casual pilots like me who don’t have a lot of free time where I could learn all the FMGC, etc.
I know that is much more realistic of course, but if you don’t have a lot of free time for the hobby of flight siming, the way via setting up a flight plan in the world map was and is very comfortable.
A bummer that they kill this option :confused:
Alltough: It worked quite well with the development version in terms of the flightpath and ATC as well. The only thing was the approach that was not working.

RNAV is Right now not supported as it needs VNAV. It’s work in progress. As a workaround you can fly in NAV and use FPA to descend.

I actually did a flight just now with the latest Dev version, and I can get it to work with the default flight planner (kinda).

So what I did was I create a SimBrief flight plan. Then in the default world map flight planner, I create a Gate-to-Gate flight plan, then I switch to IFR (High Airways), then I manually delete the waypoints, so I would end up with a direct Departure airport to Arrival airport without any waypoints.

Then I star the flight, and in the MCDU, there should only be the depature point and the destination airport. Then using the SimBrief OFP, I manually add the SID, and STAR using the MCDU, and all the waypoints and airways in-between. Once the full flight plan is complete, I can then request clearance from the default ATC, and it does take into account the IFR flight plan, including the cruising altitude. But it’s only based on the direct flight plan that you created in the world map. It doesn’t read the waypoints. But I think it’s good enough. You still get clearance to take off, clearance to land at the end, and clearance to park at the gate all using the default ATC.

Here’s a way the development version should work with MSFS ATC and SimBrief:

  1. Go to the EFB settings (A32NX) and make the MCDU to do nothing (Sim Options > Sync MSFS flightplan > None). (the setting should be a one timer, it stays as you configured it)
  2. Exit MSFS.
  3. Create and publish a SimBrief flightplan and also export/download it in .pln format (for MSFS).
  4. Launch MSFS and create a flight via World Map. Load the .pln file you downloaded (change the starting position to a Gate of your desire - via drop down menu pls)
  5. Start the flight. Do your preps as normal and import the flight plan from SimBrief into the MCDU.
  6. Now MSFS ATC should have your IFR flightplan (via .pln file) and the MCDU should have the same (via SimBrief import).

GENIUS!! So that’s what the MSFS Sync thing is for. I did saw it earlier on my flight, but I wasn’t sure what that was for. Thanks, I’ll definitely give this a go on my next flight.

:slightly_smiling_face: See here all settings and what they do:


With the latest FBW update and the custom FMS being standard now, is it a forgone conclusion that a Simbrief account is essentially required to use the plane to its fullest?

I have been using either Little Navmap or the stock world map planner to create .pln files up to this point, even with an occasional waypoint/SID/STAR disagreement when syncing. I have not created a Simbrief account.

LMN and World Map flightplans still work with the cFMS. But also, there are bugs to fix. That’s why it is the development version.

The main bug regarding World Map and .pln files: expect all radio based waypoints (VORs, NDBs) to be at the end of your flightplan, when loaded into the MCDU (you can fix that in the MCDU by hand - clear them at the end and insert them where they belong). I hope we fix most of the issues soon(ish).

Ah! I think that explains some oddities I have seen. I hadn’t seen that reported before, so thank you for the info.

I’m also not sure if all of the navigation databases are identical between the various programs, as I sometimes can’t find a waypoint in one tool that exists in another, so there will always be errors that need to be corrected before takeoff.

For example, I’ll sometimes create an IFR plan in the World Map, save it, then load it in Little Navmap so I can follow the route as I fly. Invariably, there will be nav aids or airways that Little Navmap warns me it couldn’t find. On the flip side, the STARs in Little Navmap seem to be much more comprehensive than what exist in the World Map planner when selecting approaches. It’s rare that I find a STAR completely syncing between the two.

Thanks for all the work on the A320. It’s an impressive mod for sure.

If you use the default database / AIRAC which comes with LittleNavMap, there are differences, even if you load the MSFS database into LNM.
I really don’t want to advertise (I would, if they would pay me :wink:) , but if you would like to have consistent databases you won’t be able to avoid paying some money for services like Navigraph. If you use the same AIRAC in both, LNM and the sim (which also means the A32NX MCDU), you shouldn’t have any issues.

1 Like

The Sync setting does work really well. But I think we need to also stop the sync for the flight number. If I set a flight number either from the livery aircraft.cfg or on the world map. The flight number gets overwritten by the flight number from simbrief. This makes the ATC callsign to be a bit weird, because instead of saying Delta 4316, it says Delta DAL4316 (where the DAL is pronounced phonetically). Maybe the flight number entered on the MCDU or imported from SimBrief shouldn’t sync to the MSFS flight number as well.