AMD Driver issue causing CTD

Is anyone experiencing CTD caused by AMD Drive problem. I updated the AMD drivers yesterday and now I am getting CTD at various points in flight. I look at the event log and it appears the driver amdkmdag “stopped responding and has successfully recovered” just before the CTD. If you have this problem, have you solved? I and going to uninstall drivers but not sure which one I should use.

TIA for help

AMD drivers is like russian roulette

2 Likes

I have been using 20.10.1 since its release in mid-October. It has been stable, and has “survived” all of the patches and updates to MSFS during the past ten weeks.

I have a Gigabyte 5700XT installed on a Gigabyte X570 board, with a Ryzen 5 3600 CPU. I am running 32GB of Corsair 3200 RAM; two sticks of 16GB

Good luck!

Thanks. I have a 570 and I may have overclocked it too much … going to try.

Yes, I barely get by using the default settings with my notoriously overclocked by manufacturer 5600xt. Overclocking in any form with MSFS is the first thing to get rid of.

570 and oclock. You got it. CTD every time I even mildly oclock my RX580. I use Adrenalin only for the driver. Let the sim do the rest.

had my other system running msfs w minor issues some CTD but nothing drastic, but build a new computer and still haven’t gotten msfs to work without CTD on startup

I was getting constant CTDs with latest AMD drivers (5700 XT), which appear to have been solved by uninstalling the drivers and installing the one provided by Windows Update (older Aug 2020 driver I believe).

I’ve seen quite a few posts saying any AMD Driver newer than 20.10.1 will cause problems with Oculus and probably MSFS. I backed down to it and have had no problems running RX580

1 Like

Same here. Had to go back a few drivers now all is ok.

Has anyone tried whether the newest 21.1.1 still results in crashes?

I haven’t updated yet, but my online flying partner did and he’s still getting them. I think I’ll roll back to the August drivers and see what happens.

I’m on the latest drivers and haven’t experienced any crashes yet.

Since you are using the exact same pc config as I am: how is your experience with the quest? Could you share your settings?
struggling to get it perfectly right - tricky beast at times

Just downloaded the latest drive - 21.1.1 and everything seems to be working as well as can be expected. Did have a crash with Quest after about 1 1/2 hours but was switching back and forth between Quest and PC plus turned on little nav map, so there may have been a overheat problem.

It looks, that the temperatur is to high in “automatic” modus.

Change the settings as shown. That cools the GPU from ~75++° C down to ~50°C

Since there, I had no more CTD

greatings from germany

Will give it a go…thanks

I’ve had occasional crashes (driver timeout and VCRUNTIME stuff). After changing my virtual memory a bit, it seems to have gotten rid of those.

Have a look here if you’re still struggling:
Finally…Solved CTD issues… for those us with < 32 GB ram - Self-Service / PC & Hardware - Microsoft Flight Simulator Forums

I rolled back to the Oct drivers last weekend. I’ve flown at least an hour a night since then without any CTDs. RX5700XT.

I too have had to roll back to the October driver for my RX 5700 XT to stop the CTDs I would eventually get on my longer flights, basically fights over an hour.

I just installed the most recently released AMD driver 21.2.2. So far so good. I’m into my 3rd hour of a flight and no CTD. This is with me also running NVM 2.6.7.

Keeping my fingers crossed…