Consistent CTD with ucrtbase.dll error - Very Frustrating!

I consistently get this error anywhere from 10 minutes to 2 hours into a flight. Curious if anyone else is having the same issues. I’ve tried the suggested options including:

  • Reinstalling Proper C++ Runtime Libs
  • Ensuring updated DirectX
  • Ensuring English Language Pack
  • Doing a “clean boot”

Fully updated Windows 10 v.2004. Nvidia driver 452.06. i5-9600, GTX 1060 6GB, 32GB RAM, 500 GB M.2 SSD.

There are quite a few threads on the forums where people are reporting crash to desktops and it seems there is no one single cause. Reports indicate that the ‘fix’ for one user doesn’t work for another user etc. Tracking down the cause is very time consuming. I suggest maybe using the forum search function to find other threads for this issue. If you wanted to be brave, even though it is time consuming, you could take the plunge and go ahead and reinstall windows. It might actually save you time in the long run. However, it doesn’t guarantee that it will solve your problem if the CTD is caused by hardware weaknesses (unlikely but possible) or driver issues.

To get you started, here are two links (Link1, Link2) to existing mega-threads about CTDs.

It would also be a good idea to check out the known issues post to see if you are affected by one of those.

For advanced troubleshooting, if none of the other fixes seem to work, then there may also be some useful information contained in this detailed thread: [FIXED] Random CTDs due to internet and hardware issues.

1 Like

I’ve tried pretty much everything in the above email. I was digging around in event viewer and I get these warnings every 10 seconds whether I’m in Flight Sim or not. It’s the only Microsoft Game that I have (other than what came with Windows 10).

Here’s the text of the error…
The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
to the user DESKTOP-G7XXXXT\Larry SID (S-1-5-21-537431538-215979622-3446920756-1001) from address LocalHost (Using LRPC) running in the application container Microsoft.GamingApp_2008.1001.11.0_x64__8wekyb3d8bbwe SID (S-1-15-2-1723189366-2159580849-2248400763-1481059666-1951766778-2756563051-3565589001). This security permission can be modified using the Component Services administrative tool.