Constant CTD's after Jan 2022 update

This fix has also worked for me, at least for two separate flights, second with Com Folder fully loaded. My PC has an Asus Rog Strix Z490-F motherboard. Like you say disabling the Sonic Studio Virtual Mixer seems to have fixed the CTD’s, at least for now.

Win10/settings/system/sound then lower down sound page click on Manage sound devices. Choose Speakers - then from drop down Sonic Studio Virtual Mixer DISABLE. Also choose Microphone - Sonic Studio Virtual Mixer. DISABLE.


Don’t know how you managed to sus this one out ShierLattice199 but I sure am grateful to you, thank you.

Hope this helps others too.

1 Like

trust me… that these asus sound tools ( also msi ) cause ctds is very old info/topic and I assume you will no longer get one because of these :slight_smile: … happy flight…

1 Like

Thanks a lot for pointing us in the right direction, info v much appreciated.

You are welcome
Well, my guess here is that I got lucky…
I do remember that I noticed this device a while ago in the windows taskbar by rightclicking on the speaker icon and thought ’ ***… how???’ but did not pay any further attention at that time, untill I ran into these constant CTD’s
In my 25 years of flightsimming, never ran into this kind of trouble though.
And it is possible that in future updates of this device, or in updates in the way windows OS deals with audio devices, or changes in the audio engine of the flightsim , this problem will go away

Very very glad it is sorted out.
Happy flying :smiley:

because these asus tools ( and horrible realtek drivers ) not exists 25years ago :rofl:

Yeh, … and the ironie is that I always use a dedicated soundcard.
Because I am interested in the buttkicker and follow the thread about it on this forum that I enabled the onboard sound device ( 2 sounddevices on 1 PC) a while ago.

Now I could kick my but … :rofl:

1 Like

I use the internal “card” and also external “cards” ( motu, steinberg ) to get more separate channels ( in and out )… Usually it works fine also in games. Also the internal card works in all case since we got while ago new sound-drivers for these realtek/avolute stuff. I never use these “best of” tools from mainboard-manufactors ( they should develop good hardware, but let the fingers from additional applications which often nobody need )

PS: long ago the ages of soundblaster :slight_smile:

1 Like

Could not agree with you more.
Still using SB soundcard here
But software gets outdated, new technologies introduced
That is part of evolution :smiley:

Here to report that it seems like the disabling of the Sonic Studio Virtual Mixer eliminated my CTDs after 2 frustrating months. Bloatware was the culprit after all, and I have no idea it installed itself

Ultra, 30FPS, disabled rolling cache, latest Nvidia drivers (RTX3080 OC model undervolted), XMP2, stock CPU speeds

1 Like

When I disable Sonic Studio Virtual Mixer I get a constant stuttering Sound…only in MSFS. It starts with the music in the loading screen and is still there during a flight. Has it something to do with NVIDIA High definition Audio?

For me, I ctd when I turn on the Battery in my plane. 4 hours before was all ok, but now, it‘s not working anymore.
Any news on the X-Plane 12 release? I am tired of spending my limited free time in anger with this constant problems. Every update needs fixes and follow up fixes.

1 Like

I was getting constant CTD’s so i dediced to reinstall windows> Now with a fresh install of everything and only MSFS instaled with latest bios and drivers I get CTD while changing keybindings and contoller setting. What on earth is going on??? what have we even paid for?

1 Like

this is what I allways do → manuall install :

I also have “High Def Audio device” in device manager “down”…

But not sure about your sound-stutters. It can be other reasons…

I don´t know why but stuttering is gone since I have changed audio device to headset and after that back to speakers…but thx.
And I really can´t believe it…no CTD for 1 hour with different planes and locations after disabling Sonic Studio Virtual Mixer. I have always searched for an App called Sonic Studio but couln´t find it though I thought I do not have this software. Is it possible to uninstall it or can we just disable it?

I couldn’t find any way to uninstall it but just disabling it seems to have done the trick.

I’m still not happy though seeing as I have windows update set to not update hardware drivers so why did I get this BS that I have no need for pushed on me.

Is’nt this mixer part of asus sonic studio 3 ?

yep… a guess: may be there was a change with a windows update, not sure… At least some file-update-timestamps match with a windows-update-install date in my case ( I not have these tools installed, but the nahimic service ). May be these correlates with these lots of reports at nearly “same” time … a while ago there was a similar “report wave”, therefore it is included in FAQ :slight_smile:

Uninstall or disable Sonic permenently and update/reinstall your chipset and other mainboard drivers. Guaranteed fix.

somewhere in big ctd thread I mentioned that these sonic-tool was agin auto-re-installed. But since second uninstall, I never again seen this stuff.

1 Like

I’m also experiencing frequent crashes after this new update, I had just gotten it the day before the update came out and it was perfectly fine then (besides the pains of the download system since I got it from steam, and there were a couple of crashes while it was downloading but none while actually playing)

Unfortunately I don’t have an Asus board or Sonic Studio and unlike a lot of you guys I don’t have a terribly high end setup.

Faulting application name: FlightSimulator.exe, version:, time stamp: 0x00000000
Faulting module name: clr.dll, version: 4.8.4420.0, time stamp: 0x6109cbc8
Exception code: 0xc0000005
Fault offset: 0x00000000000b222f
Faulting process ID: 0x1de0
Faulting application start time: 0x01d806dc9c25063a
Faulting application path: FlightSimulator.exe
Faulting module path: v4.0.30319\clr.dll
Report ID: b6f94d1d-1968-4043-a4da-ff4b27e452d4
Faulting package full name:
Faulting package-relative application ID:

you not have Capture one installed ?