Constant CTD's after Jan 2022 update

I do have it installed but I’ve not started it and have rebooted my machine multiple times without starting it.

The forum wouldn’t let me post the full path earlier due to it being flagged as a URL, and I didn’t realise I could use markdown codeblocks.
Faulting module path: C:\Windows\Microsoft.NET\Framework64\v4.0.30319\clr.dll

Capture-One… the second big trouble maker: As example

EDIT: would point to this topic

the problem is that these tool have a explorer extension…
( there is a way to disable this , then it should also work )

May be I should repeat the link to the FAQ with the list of known in-comp. apps , or we need a forum banner :joy: :

You may not have started it but something has … modules do not crash while sitting domant on a harddrive.

I have CTD now 15 minutes after departure on LPPR.

Using Cessa Longitude.

Nome da aplicação com falha: FlightSimulator.exe, versão:, carimbo de data/hora: 0x00000000
Nome do módulo com falha: FlightSimulator.exe, versão:, carimbo de data/hora: 0x00000000
Código de exceção: 0xc0000005
Desvio de falha: 0x000000000013d963
ID do processo com falha: 0x3a6c
Hora de início da aplicação com falha: 0x01d806fc57457bd7
Caminho da aplicação com falha: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.21.18.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Caminho do módulo com falha: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.21.18.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
ID do Relatório: 6a32edd2-2d1b-4f44-a937-11a91321edef
Nome completo do pacote com falha: Microsoft.FlightSimulator_1.21.18.0_x64__8wekyb3d8bbwe
ID da aplicação relativa ao pacote com falha: App

Following the advice of renaming the dll as outlined in the above post and it hasn’t crashed yet :smiley:

1 Like

Constant crash to desktops.

Updated to hotfix Jan. Constant ctd.

Emptied commuty folder. Still crash to desktop.

Loading into flights and exiting flights. Loading the bar and just freezes.

I have had enough of this now.

Yep. Confirmed. Longitude is broken causing CTD

is there a topic about ?

Reinstalled Nvidia drivers without the HD sound…CTD stopped. I’m pretty sure the CTD is sound related as right before it crashed, I always got a sound stutter. FWIW, I don’t have the Sonic Studio but I do have the Realtek sound drivers and app. I think the Nvidia HD sound is somehow conflicting with Realtek and other sound packages when using MSFS2020.

I assume these is the main-root-cause for all issues, these realtek stuff. I forgot why I no longer installed these nvidia sound-drivers. Doing so since a long time ( before msfs was released ) … I only remember that I had some issues with it.

1 Like

The real question is what changed with MSFS2020 this patch to make it unstable with these drivers. I know for a fact that the Realtek drivers aren’t new and I’ve never had CTDs until the Jan MSFS2020 patch.

1 Like

I use Nvidia HD 2:1 stereo sound exclusively and have never had a problem. Realtek is disabled on all 3 of my PCs and unless something changes it always will be, their drivers are nothing but trouble.


Sorry, I am lost a bit, how do you use Nv drivers for a Realtek chip ?

Disable RT in the device manager, in fact I actually have it uninstalled in W11, presumably NV puts other drivers in it’s place. All audio now runs through my HDTV monitor on a Bluetooth 5.1 dongle although I can also enable the PC’s native BT 5.0 for audio if I choose.

Hi All,

I too are suffering constant CTD since this update
I have a high end rig, working perfectly before but now I cannot even pan my view in any cockpit without a freeze and CTD.

Tried all I can, it’s unfortunate but I’ve had enough
This constant battle after every update just to get this game/sim working is beyond a joke
I will give it until the next update which is a planned bug fix special !! But after that if i’m Forced to spend hours changing settings, reloading because this time my views don’t work, last time it was controller issues, before that something else, then I shall walk away and get my simulation fix from DCS or Star Citizen or Elite …yes they have their issues too but I can at least usually just load up and play.
For those of you out there with no issues I’m genuinely pleased and happy for you, but for me my goodwill to this product is now wearing thin regrettably.


The same here. I tried anything but nothing helps. Ctd´s in every Condition. So the Game is not usable. It would help if Asobo tells the Gamer, that they know about the issue und are working for the solution.

1 Like

It is very concerning what is happening at the moment. We should be consultated if we chose to update on patches which seem to bring new issues. The other aspect is customer support, waitng here for 3 days for zendesk to get back to me. I also tried everyting, fortunately I have found a way to resolve these CDSs on my machine which was crashing wirh any driver old or new. The only thing that finally worked here is using a studio driver...511.09 for my 3090 card. I did a clean with DDU first. Worth a try if you did not do that so far. Good luck to you all and hope the devs are reading these posts. When it works its a lovely simulator and hope the future will get us betterment in this matter.

I can not exclude that somewhat within the patch caused the problem, but on other side I seen ( mention this in another topic ) an update in nahimic service etc. with match to an windows update (20h2). I know that a-volute and other stuff will be also updated “silent” and may be that caused it… it of course a guess. For me I know that I avoid to use these tools, drivers, also nvidia HD, etc. and so I played without ctd’s :slight_smile:

I am having sound problems as well. It sounds like a driver or memory problem (pun intended). Each time I start MSFS after the computer starts up, as soon as the first splash screen (Asobo Studio) with sound is displayed, there is no sound and the computer crashes with a “bugcheck” and creates a huge memory dump file. After the computer restarts, I try enabling/disabling various sound devices and eventually some combination works for MSFS to start correctly… at least until the next computer boot/reboot. Apparently Windows undoes the configuration changes I made at system boot.

There hasn’t been very much discussion of sound-related issues with MSFS. I wouldn’t be surprised if some CTDs or performance issues are caused by Realtek and NVIDIA conflicts.

On my computer the NVIDIA sound drivers version is different than the GPU driver which is confusing. Possibly adding to my confusion is that I have installed but not enabled “DTS Sound Unbound” and “Dolby Access” from the MS Store.

Right now I am okay with hacking around my sound devices enough to get MSFS to run each day. (And it runs great with SU7/hotfix

Hello guys, first of all, sorry for my English, it is not my native language.
I’m having exactly the same problems with the simulator, constant CTD, many times I can’t even take off, I’ve tried everything you kindly shared and it worked, but I still have the same problems.
This is very frustrating and disastrous.