Control sensitivity after update 5

Anyone else having trouble with the new sensotivity curves? My issue is this:

First mm i move the joystick ot’s very twitchy. After that it’s nothing. Untill i hit the sensitivity cure where it goes straight again and it gives me full input. In other words: 1mm twitchy controls. Then almost nothing and then everything.

And they said they made it less twitchy… Also what s the point of the neutral setting? So we can choose to pitch up all the time or pitch down all te time? Really… That’s what we asked for?

Sorry asobo but this is just dumb. Also the curves look so weird and out of the ordinary. They’re not even symatrical.

So much better this😑


Same for me:


Same here … Noticed straight after takeoff … Luckily was the C152 . Landed with a hop skip and jump. The SENSITIVITY settings and UI changed. Bedtime … that is another challenge for tomorrow to get it sorted.

Much improved here.Far more control of the response curve.


For asobo to get sorted yes. Unfortunately we’d probably have to wait another week or two because ‘hotfix’ is not in their dictionary.

1 Like

How? How do your curves look?

No hotfix needed. It is far better than the previous adjustment curves.


Can you share a screenshot of your curves maybe? Because for me it’s really messed up.

Especially that it’s not symmetrical. So pitch up is a different curve then down. Same as left and right. Both at 50% though.

Find this a bit strange

1 Like

1 Like

Yes, it felt really odd during my first flight after the update but it was an easy fix. I adjusted my usual 80% to 50% and it seems alright now. Dead zone at 10%.

1 Like

Thanks. What joystick/yoke you’re using? I’m using the thrustmaster t16000m and with a sebsitivity of 10% it’s almost inpossible to do small adjustments.

Before it was all good with 50% though. Very precise!

1 Like

HOTAS Warthog.

Okay thanks!

Well, let’s hope it’s somehting at my end then. I’m restarting/recalibrating/reinstalling drivers etc to see if it does anything.

Still think it’s weird😅

I don’t think these settings are right for you either, there is a break in the curve in your picture as well. -10% is enough for you, but not for anyone else. I needed -85% for a smooth experience. Would you try to adjust to a value similar to ours, what kind of curve is drawn for you, please?

1 Like

Setting deadzonedeadzones to about 2 makes it a bit better. Still don’t like the shape of that curve though. Also still feels worse then before.

1 Like

Just looking at the curves, -50% looks like what the ‘old’ -85% looked like.

The break in the curve is very useful. It gives you better control near the center of control surface deflection (most flying), but more deflection if you need it (aerobatics, etc). It’s a vast improvement on the old exponential curves.

1 Like

:grimacing: 10% !? I’m already crying with a set of 1% … would like to have 0.5% :stuck_out_tongue_winking_eye:

I agree it is just about unusable or I should say unflyable with crosswind pedals. They should put the rudder sensitivity back the way it was.

1 Like

Yes, there is something seriously wrong with how the settings affect the the curve calculation/formula after update 5.

Different exponential behaviour on different sides of neutral.
And certain settings, the control-surface will actually move backwards toward neutral the more you increase yoke input, this should not be possible at all.
PLEAASE, revert, and add linear sensitivity controls (min/max output)


Set sensitivities to 0%, and it’s linear. I have -30% now set to everything, and it works extremely well.

1 Like