Crash to desktop without error message

After reinstalling the vcruntime multiple times and running sfc, I had another vcruntime error again. All I can do now is just wait on Asobo

or read a bit within the mentioned specialized topic to vcruntime error and find possible a helpfull hint.

Sure ill read that thread for the 5th time and retry everything again. my apologies for asking in an active CTD thread

You’re sure you’re reading, because I just talked about CTDs caused by vcruntime140.dll and Microsoft Visual C ++
I did NOT say that I had found THE solution, but that I had been able to do a one hour flight stopped by fuel starvation, then another 11 hours without CTD.

Took off from KORD, looped around to land on a parallel runway, was on the ground for about 10 seconds, and crash. Total flight maybe 2 minutes. :wink:

Report.wer.pln (32.6 KB)

Faulting application name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x60420f33
Faulting module name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x60420f33
Exception code: 0xc0000005
Fault offset: 0x000000000011930a
Faulting process ID: 0x1ce4
Faulting application start time: 0x01d72f068af46678
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.14.6.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.14.6.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Report ID: 88a31e95-cea3-4c02-bc0d-a8c1d3ba26bd
Faulting package full name: Microsoft.FlightSimulator_1.14.6.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App

Fault bucket , type 0
Event Name: MoAppCrash
Response: Not available
Cab Id: 0

Problem signature:
P1: Microsoft.FlightSimulator_1.14.6.0_x64__8wekyb3d8bbwe
P2: praid:App
P3: 0.0.0.0
P4: 60420f33
P5: FlightSimulator.exe
P6: 0.0.0.0
P7: 60420f33
P8: c0000005
P9: 000000000011930a
P10:

A few hours later I relaunched, did 3 or 4 touch, and go landings at KORD, overflew Chicago, then headed North to KOSH. No crashes. This randomness is the worst, and it makes we wonder how Asobo are going to be able to resolve this.

CTD caused by vcruntime140.dll and Microsoft Visual C ++ (1)

CTD caused by vcruntime140.dll and Microsoft Visual C ++ (2)
1 hour flight without CTD after uninstalling Microsoft Visual C ++ (Without reinstalling)

CTD caused by vcruntime140.dll and Microsoft Visual C ++ (3)
11 hour flight LFPG to FACT without CTD after uninstalling Microsoft Visual C ++ (Without reinstalling)

I just did 3 hours of VFR flights doing a zigzag circuit to cover as much area as possible, still no CTD

So far, since uninstalling Microsoft Visual C ++ (Without reinstalling), I have been able to do a total of 15 hours of flight time, and I haven’t had a CTD.

To be continued…

1 Like

Ich habe den MSFS vollständig aus der AMD Adrenalin Applikation entfernt, weil ich ständig den Fehler ID 1000 hatte und damit einen Crash to Desktop hatte.

Since uninstalling Microsoft Visual C ++ (without reinstallation)

I just saw that it’s when WMR starts that the desktop disappears. If I press the Windows key, to display the taskbar, on which I attached the shortcut to WMR, and I close it WMR, the desktop reappears.

Everyone, I figured my issue out. I had horrible CTD problems and tried everything on file. Short and simple, it was my NVIDIA graphics driver causing random CTD’s all over the place. Now I can run ultra graphics settings and download map data on any aircraft without issue. Try going to device manager and uninstalling your display adapters. Go to the NVIDIA install drivers search website and put in your GPU info, download and run the installer.

Be patient with it as it will uninstall anything it needs to. Restart after and just start up the game normally. Turn your graphics settings down at first and then load into Sedona. Then, all you have to do is turn your graphics settings up to whatever you want and enjoy the game!

Please let me know if this worked for you so I can let Asobo know.

Out of curiosity, how long has it been since you reinstalled your GPU driver, and you haven’t had a CTD?
Besides, what do you have as a GPU?

I seem to have CTD’s at major airports where you’d expect low frames. SFO, JFK, LAX, for example. Would graphics settings being too high cause CTDs?

Some issues may be failing parts in your PC? Over heating is a more likely problem. MSFS is likely pushing your hardware to the limits where other games are not. We know MSFS is very demanding especially when it comes to graphics. It may just be too much for (one of) your components’ temperature.

I would add a temperature monitor while playing MSFS or other game to see what temperatures are. Reinstalling OS, games does not appears to solve your problem.

I experience a random MSFS slow-to-a-crawl when landing at a busy airport. MSFS consumer 12-14GB of RAM on my PC. Other software adds about 10GB. I noticed my GPU maxed memory and PC maxed RAM. I have 32GB and maxed out RAM? Turned out a background app, PC-Doctor, started. I opened task manager and killed it. MSFS resumed fine.

1 Like

STOP!
Stop with your stories that our setups, or our software settings, Windows, or whatever, is the cause of our problems.
It’s as annoying as a sick person on a hospital bed, which sounds like you’re not sick, it’s all going through your head.

If you have had experiences with CTD and have resolved them totally, or even partially, then bring your experience.
But come, like a guy from a hotline of a telephone operator, or an Internet service provider, who reads you a list of procedures, while he himself does not know what he is talking about, we have no need.

To say that MSFS by demanding, that it heat the material, is spoken to say nothing.
You are not going to tell us that MSFS is more demanding than stress test software, like OCCT, FurMark, Prime 95, MSI Kombustor…ect.

It is not for the user to have to adapt a game by becoming a computer engineer, with a development option. It is up to the developers of the game to adapt their game to all configurations, provided of course that they meet the minimum requirements.

6 Likes

Very good information and recommendations.

Just a word of caution, though.
You might prepare yourself for some push-back or scoffing and ridicule for suggesting the possibility that any of the described issues might be the result of someone’s inadequate/misconfigured/overstressed system. There are those who are 100% convinced that there is absolutely nothing wrong with their systems and that CTD’s are soley an ASOBO problem to solve.

So… heads up!

2 Likes

not many, but they are very loud and shout your opinion at the others in big letters… ( no , I tell no names :rofl: )

Installation is on a new PC Ryzen 5 3600XT / RX 5700 XT with 32 GB. Since day 1 have had very few CTDs until recently. In the last week or so however I have had every flight flown CTD. For example I created a Navigraph flight plan from Barcelona to Ibiza and loaded it at the flight planning menu. I first flew it in the King Air and CTD as I was approaching Ibiza from Majorca at cruising altitude. Today I ran the same flight plan in the TBM and CTD as I reached cruising altitude. Previously, I tried flying from Van Nuys to Las Vegas in the CJ4 using a flight plan previously flown without issue and CTD midway through the flight. My install has not changed since January and the only thing non standard are liveries. Something is going on and it is frustrating as heck.

Hmm…
All things being equal, I think I’d have to reluctantly, VERY reluctantly, admit that it sounds like something changed in MSFS.
:grimacing:

Is it just me but something that I seem to keep seeing in many of the troubled systems, though, is mention of the Ryzen CPU. Probably just me…

It’s nice to read messages about people who have CTDs, who are doing analyses, trying to figure out where the problem might come from.
It changes parrots who do not know how to repeat tirelessly, that the problem is necessarily you.

On my side, after having flown for 15 hours in all without CTD.
Yesterday on a flight with the Spitfire from LIRE to LOWI. I got a CTD after about 30 minutes, with vcruntime140.dll error
I started the flight again, same after about 30 minutes, CTD with vcruntime140.dll error.
Earlier, I did it again with the Corsair, same thing, after about 30 minutes, CTD with vcruntime140.dll error.

I made another flight trying to bypass the area where I had the CTD.
I flew over an hour without a CTD.

I read, here on the forum, it seems that a simple wind turbine, could cause a CTD.
The guy had rebuilt a very small area on the map, which caused a CTD.

I crossed Spain from north to south, with the Corsair without CTD

Yesterday I had my first CTD in months, without any warnings or error messages.

Z390m gaming mobo
i9-9900 CPU
RTX 2070
64GB of RAM
WIN 10 v10H2
Nvidia drivers 461.92
Game on its own 2TB SSD

Apart from that, I still keep on getting those awful “package” error messages from time to time…

If there was not only one person in 100 who specifies their PC configuration in their message, we could draw some conclusions. But here, we can only assume …