Crashed on bush trip, restarts from water and can't restart leg

After crashing in my Iceland bush trip, I tried to continue, thinking it would restart me from my current leg. But when I restart it places me in the water where I crashed, then after a second it reports that “You have crashed into the water”, then offers me the restart/main menu option. It’s an endless cycle. I tried to restart before the message appears but same thing happens.

In addition, I can’t even restart from the previous leg (see below):

image

I’ve crashed in other bush trips and was able to restart from take off. Anyone else seen this behavior and is there a simple workaround before I report a bug?

Something here I can hack?

[ATC_ActiveFlightPlan.0]
title=TT:asobo-bushtrip-iceland.Mission.1
description=TT:asobo-bushtrip-iceland.Mission.2
type=VFR
routetype=0
cruising_altitude=1000
departure_id=BIKR, N65° 43.90', W19° 34.37', +001500.00
departure_position=
destination_id=BIHK, N65° 42.28', W21° 41.78', +001500.00
departure_name=Alexander
destination_name=Holmavik
alternate_name=AlternateName
waypoint.0=, BIKR, , Alexander, A, N65° 43.90', W19° 34.37', +001500.00, , , , , , NONE, 0, 0, -1, 0, 0, +
waypoint.1=AE, POI18, , Hvtserkur, U, N65° 36.39', W20° 38.15', +001500.00, , , , , , NONE, 0, 0, -1, 0, 0, +
waypoint.2=AE, POI19, , Thidhriksvallavatn Lake, U, N65° 40.63', W21° 44.49', +001500.00, , , , , , NONE, 0, 0, -1, 0, 0, +
waypoint.3=, BIHK, , Holmavik, A, N65° 42.28', W21° 41.78', +001500.00, , , , , , NONE, 0, 0, -1, 0, 0, +

I had this happen to me. Due to the update, the C172 starts crabbing after a while and then only gets worse. When I tried to correct the crabbing, the tail was damaged, and the aircraft lost control.

So I tried to restart the bush trip. The file will only resume in its failed state.

The only difference between a restart and a resume is that resume goes back immediately to the flight, while a restart starts at the loading screen, and the “Ready to Fly” screen. Clicking “Ready to fly” simply goes back to the resumed condition rather than the start of the leg.

I will file a bug report. You should do the same.

Here is a video of the behavior:

I found a work-around for this problem. Start any other leg that you may have already completed, and then escape from the leg. This will cause it to be remembered for resuming purposes. Apparently, FSMS can only remember one flight, so you can not go back to the leg you were stuck on and restart it from the beginning.

New update seems fixed the issue only able to remember one flight, but it mean it keeps respawn to the same position unless I redo the previous flight.

This does work, however when this happens on Leg 1 there is no prior completed Leg to perform this trick.

Happened to me on Leg 1 Norway today and I am completely stuck (in a dense forest) unable to continue this Bush Trip…

You can delete/move the bush trip save from the sim install folder and go to \LocalState\MISSIONS\ACTIVITIES
There will be a folder for each bush trip you have started

There are at least 3 threads I could find on the same issue… can 1 be voted up so that it gets developer visibility. Not sure if moderators can merge these.

This is still happening BTW, places you at the right point but at ground level.

Also the Navlog is wiped.