Crashing to Desktop (Jan. 2022)


Fired up the ol Sim today, and right as it got done starting up I get

Faulting application name: FlightSimulator.exe, version:, time stamp: 0x00000000
Faulting module name: FlightSimulator.exe, version:, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x0000000001b2372a
Faulting process id: 0x266c
Faulting application start time: 0x01d8128c65ad7cb6
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.21.18.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.21.18.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Report Id: 4d73c117-f4db-43d8-83cb-6c91eb6cc8c8
Faulting package full name: Microsoft.FlightSimulator_1.21.18.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App

Fired it up again, and it was fine for a 2 hr flight.

I know, but I have community empty

1 Like

Getting CTDs also, I think nowadays for MSFS it’s normal to have CTDs XD - PArt of PC life and gamers life as a flight simmer.

Flying the twin otter and it pooped itself at the gate and CTD!
Imaged from the event.



What is happening to me at times is that the GPU drivers crash then recovers themselves and it’s been doing it allot while doing MSFS

you cannot compare, none of these other games stream in data.
msfs does things no other game does…for me i wait a few months to see how it goes then.

also some market-place add-ons cause issues…

Ok. After several tests I know more.

  1. Uninstalled NVIDIA driviers, reboot.
  2. Installed drivers (any, old or latest), custom installation, check clean installation, DON’T REBOOT COMPUTER.
  3. Open MSFS2020 and voila, it works without any crash.
  4. Rebooted computer and CTDs are back. So I have to proceed again from 1st point.
1 Like

Where do you have MSFS installed?

Don’t install onto C:

Create a new folder on a separate drive.

Be sure that Windows UAC is off

.NET runtime issue


sfc /scannow

One other thing…

You say your Community folder is empty but what about the Official folder where some addons find their nest (like the NXi in my setup) ? Anything added there from the Market Place ?

Also are you in Direct X 11 or Direct X 12 mode?

that is strange… no game in my experience ever behaved like this, and even then it’s a hot fix patch and then it’s back to normal.

1 Like

it seems that msfs2020 for me is working on default Windows drivers, right now I uninstalled NVIDIA drivers completetly and works pretty well, no CTDs. I think I have little drop on FPS because sometimes it can come from 60 to 30 for few seconds.

I am also wondering about my PSU, maybe someone can advice:
I have Ryzen 9 3950x, RTX 2070 SUPER, 64 GB RAM, and PSU is Fractal Design Ion 660W 80 Plus Platinum.

I wonder if that 660W is enough for this specs, can you tell?

No reports of anything broken… Aren’t that…

I started to have CTD after update my nvidia drivers for windows 11 (my current system). But when it was for windows 10, even I using windows 11, I had no issues.


Since 2 days ago, impossible to launch the sim. It crashs at load time again and again.
Even in safe mode (community folders cleared).
It looks like a software updates occured : Windows component or driver stuff (sound, nvidia, …).

Try to re-install today. Same thing. Didn’t pass the load screen.

THIS SIM IS A PAIN… Really sad to say that as I enjoy flying and did spent 270hr logged on it.
The truth now is that every month it is a quest to see what’s working or what has been broken.


Nom de l’application défaillante FlightSimulator.exe, version :, horodatage : 0x00000000
Nom du module défaillant : FlightSimulator.exe, version :, horodatage : 0x00000000
Code d’exception : 0x80000003
Décalage d’erreur : 0x00000000006eba11
ID du processus défaillant : 0x38b4
Heure de début de l’application défaillante : 0x01d813a7d13ebc31
Chemin d’accès de l’application défaillante : C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.21.18.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Chemin d’accès du module défaillant: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.21.18.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
ID de rapport : b57209ff-23cf-490e-bf75-2fa5162ac3b1
Nom complet du package défaillant : Microsoft.FlightSimulator_1.21.18.0_x64__8wekyb3d8bbwe
ID de l’application relative au package défaillant : App

1 Like

try to uninstall all nvidia drivers and don’t install them again, try to run game on standard Windows drivers and see if crashes, it helped me to play the game. NVIDIA drivers causing CTDs on my computer.

I tried a lot of things.
XBox store logout / login same with ms store.
When proceding at the re-install it crashes at the first start when “syncing data” with cloud.
After product is list in the xbox app as installed but it is broken.

I bought the DVD version, but it seems now it is available from the xbox app.

So did a Windows install with delete.

It crashes at first screen while syncing data :frowning:

I think my problem is with the store data.

When I launch dvd setup I have the store app that pops in.
then I open xbox app and I see the standard edition “available”.
After xbox app download data I have the setup package and soon after the first launch with Asobo logo. after the pilatus porter screen comes. when the window data sync comes it crashes at this point.

and got this error in event log :slight_smile:
Nom de l’application défaillante TCUI-App.exe, version : 3.60.2112.12001, horodatage : 0x61b61f5a
Nom du module défaillant : KERNELBASE.dll, version : 10.0.19041.1387, horodatage : 0x0b9a844a
Code d’exception : 0xc000027b
Décalage d’erreur : 0x000000000010b302
ID du processus défaillant : 0xc84
Heure de début de l’application défaillante : 0x01d814844e08b895
Chemin d’accès de l’application défaillante : C:\Program Files\WindowsApps\Microsoft.GamingServices_3.60.12001.0_x64__8wekyb3d8bbwe\TCUI-App.exe
Chemin d’accès du module défaillant: C:\WINDOWS\System32\KERNELBASE.dll
ID de rapport : c64411b1-1f2a-4bbe-9f71-67ffd6fc891e
Nom complet du package défaillant : Microsoft.GamingServices_3.60.12001.0_x64__8wekyb3d8bbwe
ID de l’application relative au package défaillant : Microsoft.GamingServices

yep… where we seen it, it pointed to corrupt cloud data: see Absurd error:can'install fs - #10 by MichaMMA

Still trying to fix it but none of the simple procedures worked

Always getting a crash at the sync data step.