Ctd ctd ctd ctd ctd ctd ctd

I normally refrain from typing when I am upset

I have spent literally the last 7 days trying to get this flight sim just not to CTD 10 min into the flight.
I’ve just spent 2 hours over and over trying to restart the sim to get it to just run under normal conditions.

Any flight.

Created with navigraph, created with msfs 2020. It does not matter.

Running as user. Running as admin. It does not matter.

I have no problem with my hardware.

I have nothing in my community folder.

I am running NO add on software.

I am running NO add on aircraft.

Just plain MSFS 2020, up to date, with Cessna longitude.

You can see my profile for my hardware. All high end. All working properly & up to date.

Am I the only one.

Just today, it started CTD every time I try to go into VR.

I don’t know what to do guys.

Sounds like a nightmare. Can you run it without VR or does it crash regardless?

Have you tried just loading in 2D with ridiculously low settings and no bing data just to see if it will fire up and stay open? If so, then you could theoretically increase settings and/or make changes until it doesn’t work anymore. A least then you might have an idea?

Alternatively, if it still doesn’t run, even in 2d with stupidly low settings, then there’s a horrible issue going on, potentially with your hardware or driver compatibility.

Nuclear option would be to reinstall Windows… but who would want to do that??

Thank you for suggestions Eddie, I will do as you suggest.

Edit:
I went back to basics as you suggested.
Everything set to default - min. Worked up slowly.
No overclocking.

Here is what I saw…when flying in VR it would jump out of VR and act like it was loading…then jump back into the game. Kept repeating the cycle, but no CTD…so far.

So I went in and shut down network connectivity.

That seemed to solve the issue.

I them want back in and turned on the network, but shut graphics off (who needs pretty at FL450. LOL

Then I set up a rolling cache of 100GIG on my super fast sim drive.

VR still glitches - they need to fix it.

But you may just have saved my MSFS 2020 experience. Thank you Eddie.

2 Likes

This may be a stretch, but it’s the only thing that has ever caused a CTD for me and I don’t have a top of the line system. I have an i7-4790K processor running at 4.3Ghz, 32 GB ram and an Nvidia GTX1080 video card.

But I also participate in the Windows Insider program and Microsoft likes to push video drivers that are not available directly from Nvidia. For example, the highest driver version on the Nvidia site is 461.72 but the last Insider build that Microsoft pushed had a driver version of 465.xx (I don’t recall the last digits in the version number).

I downgraded the video driver to 457.30 and the CTDs stopped.

Thank you Mike, that is very good information. I will look into this.

Another entire afternoon CTD.

8 setups and all CTD at some point.

One flight I managed to actually takeoff and the sim froze on me 5 min into the flight.

I used the CJ4 and latest WT mod for it.

It is looking like MSFS2020 or Steam is the problem.

4 messages, and no information about your PC configuration or your VR headset model

Good point GSX,

My pc configuration is listed for all to see in my profile:

CPU: Intel core i7-8700k @4.9GHz
RAM: DDR4 32GB @3200MHz
GPU: Nvidia 2080 Ti
Drive Model: Samsung SSD 970 EVO Plus 1TB

My VR is PIMAX 5k+ using Steam VR

People are reporting using Steam with no problems.
People are reporting using msfs 2020 with no problems.

I am beginning to believe that my problem is NOT msfs 2020 but a problem with my windows 10 install/config.

I will create a flightsim partition and install windows 10 with a fresh install of msfs 2020 ONLY, then let everyone know what I found.

Until then, I am grounded.

It is clear that I would not know how to look for it in the profile. I think it would have better valu, that we can display it in a siganture of our messages.

I just spent 15 days with CTD problems after 10 minutes, with my HP Reberv G2.
I started out thinking it was from my AMD branded GPU, RX 6800 XT, as I read many posts from people who had CTDs with AMD 5000 and 6000 series GPUs.
Finally, I read that this problem could be solved by installing the US English language for Windows. I did, and since then I have been able to do flights of at least and an hour, and 3 hours today without CTD.

All other solutions

Gsx,
I agree. Signature would be an appropriate option.

Checked…I have US English already installed.

I will continue my quest and let you know how it ends up.

Try increasing the page file on each drive to 32GB. I know it sounds asinine but it sounds like you are willing to try anything, and it worked for me when I thought all hope was lost

Will let you know if it works for me. Thanks.

Edit:
Page file at 32GB did not work for me.
CTD 15 min into flight, just beginning the ILS approach.

Continuing to search for a solution.

You are not alone.

1 Like

Getting constant CTDs as well, only managed to actually finish about 3 in 30 or so flights since the past update, and those were all short VFR hops. Tried all of the suggested fixes I can find on the forums.

Are you getting CTDs just as you press a switch? It doesn’t crash on every switch press, but ever crash seems to coincide with a switch for me. Touching anything on the overhead panel in the A320 is like playing russian roulette for me.

I guess I can consider myself blessed, as I have 2 adult sons who are programming and hardware techs.

I spent a long time discussing with them my “gamer” frustration and we came up with a plan after all the online/forum suggestions, that I faithfully implemented, did not work “for me”.

Along the way I have discovered that there is not a single cause for CTD and that “my” cause may not be “your” cause. Which makes it more difficult for asobos and gamers alike.

I will skip to the end…after doing everything that I am about to type, last night I successfully, for the first time ever, flew a full flight, a perfect ILS approach, with no CTD.

I am well aware that one flight does not prove much, but for me it is a BIG step forward.

Here is what we did:

  1. Added a new 1TB ssd drive, as my current C: drive did not have enough space left.

  2. I installed a fresh copy of windows 10 on that drive. Added updates to the windows 10 install, but did NOT install the “latest updates”.

  3. I installed all factory motherboard, video card and sound drivers, NOT the generic windows 10 drivers.

  4. Installed steam, and steam vr installed on a faster drive.

4a. I have a second hard drive, a very tiny drive, that runs about 7 times faster than my standard C: drive ssd. This is where I installed steam and my msfs2020.

So to be clear:
a. I have a normal C ssd drive that boots into my much crowded windows 10 chock full of all types of apps and nearly full.

b. I have another D ssd drive added last night with a fresh install of windows 10 and nothing else. Both a and b are set up as a duel boot on my computer.

C for my normal day chaos, D for my flight sim needs only.

The I have a G drive, very very tiny, extremely fast. This is where I installed the steam, steam vr and msfs 2020.

  1. NO anti-virus installed

  2. NO additional programs installed

  3. Turned “game mode” OFF in windows 10.

  4. Set up Nvidia 2080Ti. This can only be done with a more advanced video card I am told…right click on windows desktop / select display / select graphics settings / hardware-accelerated GPU scheduling / turn ON


at this point I tried loading a sim brief flight plan into msfs 2020. Immediate lock up.


  1. Under the windows power management:
    a. Tell windows NOT to put any hard drives to sleep - set minutes to “0”
    b. Disable windows power management

At this point I tried a flight. CTD right after takeoff.


Started another flight, noticed my wireless USB headset was off, turned it on, immediate msfs 2020 lockup.
Installed manufacturer drivers.
No more lock up.


  1. Device manager / on ALL USB and human interface devices / UN-check the power management scheduling that allows windows to shut the device down or put it to sleep (i.e. so they will stay ON ALL THE TIME).

Following all this - I flew successfully, perfect ILS, no CTD

I will need about 1 month before I am truly convinced this is a permanent solution for my situation.

I post it only in hopes that it might help some.

Stay tuned…you never know what could happen LOL

Thank you very much for that write up! I may end up directing a couple people this way.

Alongside the virtual memory increase, I also freed up 100GB of data from my C:// drive… I went from 5 GB free to 125GB free. Given that is the common denominator between our stories, maybe this should be given more attention as a reason for instability and CTDs

Edit:
2 more CTD.

Went into the bios, set everything to default.

No overclocking anything via the bios.
This had no effect.

My memory speed was dropped to 1/3 of what it was: 3200 down to 2100
This had no affect.

Set up and flew again.
Not even out of the traffic area and CTD.

Edit 2:
Found that the new m.2 drive that my msfs 2020 is installed and running on was using Microsoft generic drivers from 2006.

Downloaded and installed the current drivers for the m.2 drive.
This had no effect.

Then…a little light at the end of the tunnel.

I was speaking with my son, and he told me of a time then he was having trouble with a server that kept dropping.

He found that is was running on USB 3.0, which I understand has issues.

He moved the server to USB 2.0 and it ran like a dream.

Could it be that simple?

After checking I found that my VR PIMAX 5+ was running off a USB 3.0 port.

We changed it to a USB 2.0 port.

The following flight was perfect, smooth, seamless, crash free, AND my VR was not as “glitchy” when I move my head.

I realize again, that it is only one flight, so I’m not getting too excited…but I really am.

Will fly a few more flights and report results.

2 more CTD.

Took msfs 2020 “offline”, made a quick flight, still CTD.

Put msfs 2020 back “online”, took steam “offline” to where it would not communicate with my computer except to authenticate the msfs 2020, and after that it disconnects.

Flight was smooth. Flew all the way to the airport. No CTD.

Will report after a few more flights.

All the tests I did to try to
solve CTDs with my HP Reverb G2

I would add that you have to close all the applications that are running in the background, which can cause CTDs, because they can start for example to make an update.
On my last flight, I didn’t have a CTD during the flight, but RTSS.exe (RivaTuner) (Installed with MSI Afterburner) made me switch from VR to 2D. But it would cause a CTD.
I already had CTD because the Bluesoleil software (Bluetooth device management) which wanted to update.
For ÉnormeMercure163 it is GameBarFTServer.exe (Xbox Game Bar) which created a CTD for it.

I am always experiencing CTD when I have AI traffic set above 50%. I stopped using AI traffic.