CTD on load when internet is connected - No CTD when no internet

I have the same exact issue as the OP. Already submitted a ticket but have only received automated responses. I have been able to play MSFS2020 for a month just fine, but starting a few days ago the program crashes to desktop right before the Monument Valley screen. This even happens after uninstalling the game and launching the reinstallation app. Right as it crashes I noticed my internet usage spiked pretty good, so I tried launching the game without any internet connection. Believe it or not I was finally able to see the Monument Valley screen again! However this is a catch-22, because the game needs internet to connect to the servers and reinstall, and the game crashes again as soon as I plug in ethernet or connect to wifi. Like an instant crash upon reconnection to the internet.

What would cause the game to crash upon “seeing” an internet connection? Any help is appreciated.

There are numerous issues that could be at play once the connection is made.

Do a search in “Support” at the top of any forum page for “troubleshoot loading issues”.
It actually has the best recommendations.

Thank you, unfortunately I haven’t found a specific example of the program crashing to desktop upon receiving an internet connection. If I were to disconnect internet and boot up MSFS2020, the program gets to the monument valley screen and warns that there isn’t an internet connection, and prompts me to quit and try again later. If I hit Quit I see the black “press any key to continue” screen. If at any point during these screens I plug in ethernet or turn on Wifi, the game crashes within seconds.

I’ve already gone through the bit of GPU drivers, no mods in Community folder, PSU is adequate, etc. I’m seeing speeds around 80mbps and all other programs work just fine. For some reason MSFS2020 doesn’t like internet!

Hi @Birdrabbas,
I think I’ve seen this a few times - it’s a rare thing. Does the Event Viewer show an error?

Try logging out of the x-box app, then back in.

If that doesn’t help, this link (even though for speed issues) is quite good for troubleshooting connection issues.

Yep, I get the same code every time. I have been able to make a little headway in the last 20 minutes. I flushed my DNS and disabled IPV6 in ethernet settings. If I plug in ethernet right at the “we can’t connect to the server, try again later” screen and hit QUIT, I did finally see the Xbox login screen, however the program crashed shortly after. I do have an open ticket, 91454, for reference. Thank you for any help:

Faulting application name: FlightSimulator.exe, version:, time stamp: 0x5fda3fe4
Faulting module name: FlightSimulator.exe, version:, time stamp: 0x5fda3fe4
Exception code: 0xc0000005
Fault offset: 0x00000000019b907b
Faulting process id: 0xef8
Faulting application start time: 0x01d6fb6054c3a946
Faulting application path: C:\Program Files (x86)\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Faulting module path: C:\Program Files (x86)\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe

Moderator Hester jogged my brain dead memory with a similar case just today.
That poster had exactly the same symptoms, and solved his issue by updating Windows, even though he had auto update on.
It might be a good idea to check if your Windows version has any outstanding updates and is current.

Thanks. I checked again to be sure, and Windows is up to date. The problem persists.

Does the CTD occur about where it would be connecting?

And, when it was working before, have you changed any data limits (cap or speed) in MSFS?

Yes, if I were to keep internet on as normal and boot up the program, it CTD right before the Monument Valley screen (I see the intro Xbox, Asobo, and Blackshark screens every time). If I were to disconnect from the internet and boot the program, it goes to Monument Valley for a few seconds then stays on the “Press any key to continue” black screen. If I press Enter (with no internet), I see the loading wheel for a few seconds, then I get the “Press any key” screen again. By experimenting, I plugged in ethernet during the loading wheel after pressing Enter and I get the Xbox Login screen, but after a few more seconds I CTD.

I did not mess with any data limits when the program worked.

Are you using wifi, or a cable connection?

There have been a couple reports mentioning some users with boot up issues had changed to a wired rather than wireless cable which they claimed solved the issue.
Is your firewall blocking it?

Any virus protection program at the start, tuning tools, cleaner or similar?

This happens on both Wifi and cable. The farthest I was able to get yesterday was at the Xbox login screen. I plugged in ethernet right as the loading wheel was spinning and the program stayed frozen on the Xbox login screen without crashing to desktop (but the ambient music kept playing). I guess a frozen screen is better than a CTD.

I’m only using the default Windows Defender. No 3rd party antivirus, cleaner, etc.

The Zendesk ticket has asked for DxDiag and MsInfo reports, I’ll see if there’s any anomalies in there later today.

1 Like

Good luck, keep us up to date!

Check to make sure Defender didn’t block it.

To make double sure try to scan your computer online for Trojans, Rootkits, Viruses ond so on…
For example: ESET’s Free Online Scanner

Devil never sleeps! :wink:

So you not played since a months ?

Please… system specs :slight_smile:

Your issue is normaly xbox login or since the virtual memory.

Make sure windows store apps are updated
And try to start with firewall off, it may be blocking

Just a long shot…

If you run the “Xbox Console Companion” program and go to the “Settings” icon, there is a Network test. Tests the Teredo protocol, NAT status, Xbox Live services, etc. There is a repair button if the diagnostic fails.

Thank you everyone for your suggestions. I tried disabling Windows Defender and Firewall and booted the game via Steam but still got CTD. I updated my LAN, wifi, and chipset drivers, but still crashes. Even rolled back the latest Windows update. The farthest I can get is when I boot the game without any internet connection…I either freeze at the Xbox account login screen or CTD once I re-connect to the internet by LAN or wifi. I am far from reaching any internet data caps and I meet or exceed Asobo’s recommended connection speeds.

I’ll try messing with the Xbox and other windows apps next. Crossing fingers the folks at Asobo/zendesk can find something in the MsInfo report I sent them. I’m still scratching my head that I was playing Flight Sim perfectly fine a week ago.