[FIXED ON LIVE 1.19.8.0] You are missing packages that are essential to run Microsoft Flight Simulator. Please update the application and try again

,

As the tile says.
The update crashed 2 or 3 times, I had to restart MSFS and the update would continue but now I get the message “You are missing packages that are essential to run Microsoft Flight Simulator. Please update the application and try again.”

Well, I can’t. If I try to udpate and restart I’m back at the message.

Already went back into the Microsoft Store, no updates available and yes, I have already restarted my computer, a couple of times.

MS Store version, removed my community folder before updating.


If you are new to this thread here is a post with all of the mandatory files we found out over the course of 300+ messages:

ISSUE SOLVED:

Have you done the updates within the sim? Once the main update was done I had a half dozen others I had to do manually within FS 2020.

I don’t even get into the main menu, that is my issue, I can only click on quit:

Ive got same issue. sent ticket regarding error . has now been escalated for research

I also have the exact same issue. I should have manually updated the packages when i had the chance when upgraded to 1.8

Edit: fixed by verifying install via Steam

Same problem. I have CTD when try to update 103SOLO in content manager. I cant help. I will try copy backup whole MSFS directory and delete some files maybe 103 solo.

I have the same issue with the Steam version. Same package (103solo). If i verify the install with steam, it deletes the package and then I have to redownload 20 mb and i get through to the main menu. If i quit and load it again, I get the same error and have to do it all again.

I have created a ticket as well, they requested a CFG file and a list of all packages in my Offical folder. Since then 24 hours have gone and no news, ticket is still open.

This works for me.
Unzip and drop the below file into your Packages/Official/Onestore folder. This is a workaround until Asobo fix it. It is simply an empty placeholder for a missing package folder.
Thanks to @BrokenShower for this fix.

1 Like

Did this workaround work for you?

I only got the workaround some time after I already uninstalled and started to re-install everything.

Started the new installation/download 20 hours ago, I’m at 96% now (Germany, the land with the fastest internet in the world).

I will report back if a complete new installation fixed it.

BTW I haven’t had any new activity to my last answer to my official ticket for almost 48 hours now …

Haha, I´m from Germany, too. I already reinstalled everything twice. Luckily it took only abaout 8 hours each. For me, it didn`t work. After reinstallation I had the same issue

But if the workaround works I have still to check. The reinstallation did not work

No, it didn’t fix it.

Not the reinstalltion nor the workaround.

Here is what I have done so far, before I made the reinstallation I already deleted every folder which got not updated some days ago, it helped as it got me back to the update page and it redownloaded some folders. But afterwards it was hanging at this screen:


After the reinstallation I was back at the essential parts are missing message with the only option but to quit.
The workaround didn’t help at all for me.
So I deleted that folder and sure enough I was back at being able to update that folder.
And now I’m back stuck at that loading screen with a 100% bar … I will let it run for a hour or even the night.

■■■■. I`ll give it a try perhaps this evening or night. I will report. Hope you can get it started again

Did not fix it for me still missing packages. looks like its missing more that than just that folder. still awaiting a reply on ticket

I’m still at the same issue, even after the 1.18.4 update, if I delete a folder it gets redownloaded, then I’m stuck at the 100% blue status bar. If I then exit and restart I’m back at the start “missing packages”.

Still no reply to my ticket

That’s a shame. Hoped that would work. It works for me. If I don’t have the placeholder folder in place then I get the same message.
Does deleting the content.cfg file help?
Had you removed a lot of content from the sim that you didn’t want?

No content removed. deleting the cfg does not help. i still get the error with the placeholder in. looks to me more than 1 folder is missing

You can find all the mandatory content listed in Program Files/WindowsApps/Microsoft.FlightSimulator…/PublishedPackages/PublishedPackages_Content_Mandatory.xml
Here you can see all the packages that sim requires to run. I guess you have one or some of these missing.

1 Like