FlightSimulator.exe is now 16bit? "Unsupported 16-bit application" on startup

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No

Brief description of the issue:

All has been working fine. Updated to the latest version a few days back. Installed PMDG 737. Been going great. I started the game today and got the error in the screenshot. "FlightSimulator.exe cannot start due to incompatibility with 64-bit version of Windows.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

PC specs and/or peripheral set up if relevant:

Windows 11 latest update

Build Version # when you first started experiencing this issue:

1.25.9.0 x64


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Have you joined a beta for any insider hub applications? Are you using an insider build of Windows?

Same. And I now have something running alongside MSFS called “GameSupportHelp” which others don’t seem to have.

I was in the windows insider gaming beta which I left, but it also might be related to the Windows insider beta too. In any case, I think this specific issue is related to the gaming thing because it updated all kinds of gaming services and Xbox app services along with it. I left it, and have been able to launch, so we’ll see.

I am in the Windows Insider, but believe I am on the latest main Windows release right now.

THis is probably the problem. I am as well, and I’ve been having more issues than just this which aren’t sim issues but are windows process failures. I’ve opted out and am waiting for the next major update so I can finally get out of it lol.

For example I’ve had CTDs with the sim running perfectly fine without warning and there is no event viewer error except something related to system32 or some other windows service. So in my case anyway I think that’s what it is.

Maybe it is related to some Insider. I’m on Windows 11 Pro 22H2, installed on 16/5/2022. I’ve 100% run the game between then and now.

OK. Could you report once done? I might do the same as it seems a hell of a coincidence. But I’d say Asobo/MS should maybe be aware that the updates to Windows that will hit us all soon - will cause some issues.

Indeed. I’m probably going to do a fresh install so that I can just get out of the insider program since it makes you wait until the next major public release to opt out which could be a while. So I’ll do that and monitor it for a bit and report back.

I’ve just set my insider to Dev (From Beta). and when I select Windows Update, I see this:

So will try that.

I opted out of this via the Xbox Insider app and the 16-bit problem went away. I don’t discount that there is issues with the Windows Insider builds though, but that specific issue on my end anyway got resolved by opting out of the latest gaming services etc. via that insider.

Also, I wish you luck with the dev channel you brave person!

If you’re in this, leave it:

3 Likes

I am having the same 16 bit error problem and I am a member of both the windows insider and Xbox insider groups. Have we determined the Xbox insider is the offending program? Is a full reinstall of the game needed or can you simply opt out? Oh and finally, if anybody knows, which files need to be saved to backup your current settings and preferences if you reinstall or are they permanently lost? Thanks in advance!

Leaving the “Windows Gaming” preview from the Xbox Insider program fixed the issue for me as well. It took 20 or 30 minutes (and a reboot or two since I was inpatient) before I stopped getting the 16-bit error.

Thanks Clyde!

Just FYI for anyone else experiencing the same problem, I was able to correct it with a slightly different procedure. I knew MSFS worked just fine last night and I only had one update and restart so I knew it had to be the latest windows update. All I did was search for system restore (not system recovery) and picked a restore point from 2 days prior. It took about 5 minutes and now it loads fine. I also paused updates for the next two weeks. Hopefully there will be a better band-aide for the problem in 14 days. Hope this will prove useful to anybody else sharing this annoying problem.

Glad you got it fixed. I don’t think it was a Windows update problem. Mine was working fine this morning then Gaming Services got an update in the MS Store and that’s when I started getting the error. I hadn’t gotten any Windows updates in the meantime.

So, a sysem restore probably rolled back that update along with everything else but you’ll need to watch out for the Gaming Services update getting pushed to you in the store again.

For me I determined it was Windows Gaming Insider. I know this because it had started running a process along with MSFS called “GameLauncherHelp” which continued running even after a force quit of MSFS. After opting out of the Insider Gaming and reverting to public gaming services, that specific issue along with the weird sidebar .exe it was running with MSFS stopped immediately.

I wasn’t in the Xbox preview for me. I was in the Windows Preview. But in the ‘Beta’ channel. I changed to the one above. ‘Preview’? I now have an insider preview of Windows 11 - and the fault has gone. Here’s what I now see at the bottom left of my desktop. So, definitely still in Insider:
image

Hey guys, I know it’s been 6 days now, but after been to the parameters of Windows, Apps, MSFS2020 and clicked Reset, the problem was still there.

But I went to the Xbox App and clicked on the options of MSFS2020 and clicked Folders, and clicked on Verify and Repair, i’ve relaunched the game and it works, but I have to redownload the full 133Gb of the game…

(My xbox app is in French so i’ve just translated the options, it might not be written in the same way in English)

I might do a save of the Official folder, where the game is installed, that can avoid to redownload the full game after a problem like this…

Hope it can help…

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

Start Microsoft Flight Simulator

If relevant, provide additional screenshots/video:

Sim worked yesterday, today it does not.

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

Start Microsoft Flight Simulator (either via the desktop icon or in the xbox app)

If relevant, provide additional screenshots/video:

Sim worked yesterday evening, today it does not.

I also see error code (0x800700d8) after I press the “OK” button