Forever loading issue after Sim Update 6

Its sim issue i dont think addon have do anything with it. Sim update 5 broke addon most of addon are working prefectly after sim update 6 its something to do with server connection

1 Like

And both have been found guilty of causing problems in the past

Asobo MUST understand the importance of working hand in hand with developers, mostly with the most important as Aerosoft, FSDream Team, Orbix…

The greatness of this game, in particular, comes from the ability of the community to enhance it. It will never be a greater and powerful task force than a community in its whole (not only for games but for everything).

Yes, is great to have photogrametry, yes is great to have part of the original interphase that the 60% of the community grow using it, and yes is great to have the reflections and some candy eye that this version of MSFS offers, but in one point we will all get tired of expending half an hour loading a game just to find that our 3d developed sceneries, planes, etc can´t be used.

We want to play, not to be part of the development team, nor fight, nor expend time with our community arguing, but building the game that offers interaction, because everyone understands it and can improve it. As it has been in the past and kept active a version (FSX) for about 15 years!.

Lets ask Asobo to reconsider his 3d party policy (what ever the policy is) and strength its relation with the main developers; to simplify the .cfg files and so on…

1 Like

They do already but there’s a little thing called source code that belongs exclusively to Microsoft that they will never open up to 3rd parties.

Dude they only have to improve the communication. There is a thing call “ego” that is the main problem around the world. Once they understand how to find the way around it, they will find the way to walk together, and we, the way to use our game with the community improvements as it has been on the past.

1 Like

All I was saying is that stuck loading can come from a number of causes - servers and add-ons being two. To elimnate add-ons as the culprit, you also need to think about removing add-ons purchased through the marketplace.

But I agree that this seems often related to server issues - maybe gets stuck trying to download scenery as it loads the flight or something.

Liveries with an empty space in some of their text fields will also cause this loading bug.

atc_flight_number = “”

It can only contain a hidden character and not a space.

This is very sportatic for me. It seems to happen at any airport (both stock and 3rd party) and with any aircraft (both stock and 3rd party). It also doesnt seem to be related to addons because I have tried loading into the same airport with the same aircraft multiple times, and some of those times it will load in, and sometimes it will take forever to get to 100% then it hangs.

1 Like

Excatly that what i was trying to say all along doesn’t matter weather its stock or 3rd party addon it happan at random airports which have higher level LOD.

Only thing you do is lower garphics settings to minimise this issue and make it load at given airport but it 100% server or connection issue even if you do have a high speed Internet connection

I swear it never happened before sim update 6. I had so many addon and scenry they used to load within few second and to minimise the conflit i re- downloaded the game from scratch which a pain in itself just make sure addon where not the only issue but it does without addon just hangs at 100% loading for forever even on stock ones.

1 Like

These suggestions seem to work very well!! It would be great to have a batch.exe to execute these all at once!

I don’t think they Asobo or microsoft will let go there exclusive ‘ego’ so easily. Yes if they communicate well with 3rd party developers and open various open ended channels to improve flight simulatation experience to community . They need to open there DRM access to 3rd developers so that they can improve aircrafts and other stuff.

We don´t care about what they need to do…

FSX is a Microsoft brand, they make it great and everyone play and play and play.

If it works, don´t change it, just evolve it!

They really don’t because then they lose all control over quality … and before you say anything about now MSFS2020 is still very much a sim in development.

+1 on this. I have been systematically experiencing this issue since su6 (never ever happened to me before). This is a great update, but this issue is making it very hard to enjoy the sim. It feels like a random thing, although most of the times, in the very first load, with the a32nx and any airport, the load bar will quickly advance to the half and then somewhere between 75% to 100% the loading will remain there for minutes/forever.

Sometimes, the game will load after 10 minutes or more (when normally, the loading process would take about 1 minute or less), others, I just decided to close the app after 15 minutes. CPU and GPU are working hard when this happens, but no disk activity or internet activity after the first part of the loading is done. This is extremely irritating.

In my case, not related to heavy airports as I can get the infinite loading in small default airports too. I have a large community folder and tried removing few things but I’m not willing to delete/move averything for this.

This should be addressed in a hotfix, otherwise I’m done with msfs until this get sorted. Everytime this happens (about 80% of the attemps I tried) I waste 1/2 hour preparing the flight, starting the sim, loading, etc. so too cumbersome to continue like this.

2 Likes

I can really feel you pain man.:weary::weary: This issue is very frustrating indeed that why i made this topic so everyone can post. Its driving me nuts just to wait and wait forever to it load even. The blue loading bar just hangs up at 100%

2 Likes

Absolutely buddy!, you should make a thread about this in the bugs section so we can vote for this. Most glaring issue on su6 imho.

1 Like

A system clean up might create enough space for MS to do their stuff … e.g. old Windows installs can take up a lot of space

Just wanted to ask everyone whether they are also seeing long delays on the initial MSFS startup - before even reaching the main page where one chooses aircraft, airport, etc.

I am seeing long, sometimes infinite, delays before reaching the start page/menus. This started with SU6. Before that, my system took maybe 3 minutes to reach the main start page. Now, it sometimes takes 2 or 3 minutes, other times (most of the time now) it can run to 15 or 20 minutes or longer. Sometimes, it eventually gets there. Other times, I give up and close MSFS.

I am also often seeing long delays after making airport, aircraft, weather, etc. selections using the World Map. Not every time, but most times.

1 Like

Don’t know if this will help anyone, but it was posted over in the AVSIM forum.

Just ran into this same issue a few days ago (but was also happening with American and Euro Truck Sim) and I have a thread posted in the Hardware/GPU forum. Do you have Citrix Workspace installed by chance? If so, a recent update installed some kind of display driver that is being utilized instead of your Nvidia driver. I had to uninstall it and reinstall the Citrix version from the Microsoft store that does not contain this strange display driver.

1 Like