Gaming Service issue - Again - it's an absolute disaster

It’s an absolute disaster and I don’t understand why MS and/or Asobo ignore this problem, which has existed for about 1 year now!!
Today, out of nowhere, I get the dreaded “GAMING SERVICE” page when I start the game and I’m stuck.
If you read about this topic in the forum, there are 100+ recipes, including those from Microsoft, how to solve the problem, but none of them work. I had the same problem more than 1/2 year ago and had to set up my PC from scratch to install the program cleanly.

Should this continue? It is, to put it bluntly, outrageous that Asobo completely ignores this issue. The graphics may be nice. But the frustration about this problem makes me forget about playing it. Why does Asobo ignore this serious problem?
Thank goodness there are alternatives out there. They might not be as shiny as MSFS and have some minor bugs but are free of total game blockers.


Topic moved into Community Help > #self-service:install-performance-graphics

Gaming Services is a MS/Xbox component and not Asobo. This relies on other Xbox components to be up to date with Windows Update & MS Store updates.

1 Like

Click “start” > settings > apps.
Click gaming services > advanced options.
Take a screenshot and paste into topic, please.

Why a screen shot? Don’t you know how this page looks?

1 Like

It sounds like he’s trying to help you, says advanced options section he wants to look at not just the gaming services screen.


Gaming services version is important so …

That’s the kind of answer politicians give when they don’t have solutions, pointing the finger at others. I’m playing a game which MS has sold to me and which is created by Asobo. It is common law that the seller is contractually responsible for his product and cannot have any third parties involved in any way. Therefore I must’n know that there is some other service behind, like Xbox. I’m simply asking for a solution for this serious issues, this is legal right. I don’t want to be passed around to somewhere.
This is exactly what I’m complain about. This problem has been ignored since long, from whoever. So my question is: If it’s a matter of 1. Xbox components, 2. Windows update and/or 3. MS store updates - who should I address and how?
My realization that I’m on the wrong steamer because I can’t find a responsible captain to steer the ship is now frighteningly great.


Other than finding how to fix the issue with posts in the forum, I don’t know how to answer your question as I’ve never had this problem before. I keep all my PC’s (4 of them) up to date in my household without any issues of “gaming services”.

There are users on this forum willing to assist.


This is a community help forum not an official support channel, bit harsh on some responses to people trying to offer help…


And so do I and still are the Gaming Services a recurring trouble maker. It‘s always TenPatrol who eventually has a solution and resolves people‘s issues with Windows, not the developer of the sim or the OS who are connected and responsibel for their products. Imaging he wasn‘t there spending his unpaid leisure time… Dealing with Windows requires a degree today. What a shame all that is.


Sorry TenPatrol, I misunderstood your request “take a screenshot”. I didn’t get it full of anger. I think you wanted to analyze what is listed under “advanced” to further help. Sorry again.
I have seen a lot of posts from you here and assume that you are a proven expert on the subject. Hence my question: What if I buy the program again via STEAM, will I be rid of the problems with “gaming service” once and for all? Or is the STEAM version in some way connected to the MS store and Xbox items so I’ll be trapped again sooner or later?

This is almost certainly a simple case of having to update gaming services, which is why a screenshot was requested so we could see it’s current status.

With any potential updates waiting to be installed, I expect that to fix the problem. I’d recommend doing that instead of buying another copy of the sim.

Ok, if the problem can be solved simply by clicking “update” at gaming service in the MS store, then I don’t understand the countless and complex healing recipes that are published here. Are they all superfluous? Really? Is the solution that simple? Even MS has a page full of recommendations for the problem, but none says: “click update at gaming service”. If your tip is correct then I would be happy but understand it even less. Meanwhile I have installed everything from scratch as I have done it 6 months earlier. I’m confused and still frustrated that nobody from Asobo is taking care of this issue.

There may be many causes why the sim refuses to start cleanly, hence multiple solutions.

But why not concentrate on what is important, and whether those services needed to be updated or not, and if it has fixed your issue.

So have you tried it?

You haven’t post the image that was requested yet, so we can’t know, but I just checked mine, and I have two updates waiting to install, for “Get Help”, and “3D Viewer”. So I can confidently say my “Gaming Services” are up to date. The installed version of “Gaming Services” is “3.63.31001.0”.

You can also run the following Powershell command to display which version you currently have installed:

Get-AppPackage -Name Microsoft.GamingServices

I don’t know about that specifically but there is a section regarding repairing “Gaming Services”. I would assume that had you followed the process below, which it sounds like you almost certainly didn’t, it would have reset gaming services, and forced it to install the latest version, and may have fixed your issue.


If the problem persists after that, delete the Gaming Services registry keys and reinstall the Gaming Services app via Powershell.

  • In the Windows search bar, type Windows PowerShell
  • In the menu, select “Run as administrator
  • In the Administrator: Windows PowerShell screen, type the following command and press Enter:

get-appxpackage Microsoft.GamingServices | remove-AppxPackage -allusers

  • In the same window, type the following command and press Enter:

start ms-windows-store://pdp/?productid=9MWPM2CQNLHN

  • Click Get to install Gaming Services (select Yes if you receive the User Account Control (UAC) prompt)
  • Restart your device.

NOTE: if the Install button is not available, close the Microsoft Store then type the following command in the Administrator: Windows PowerShell screen, and press Enter:

get-appxpackage *gamingservices* -allusers

Open the Microsoft store, search for Gaming Services. The install button should be restored.

This makes me wonder why someone hasn’t yet proposed a kind of diagnostic script that could be executed by those having issues, that would gather all these disparate bits of information into a package that could be posted to the forums for those with these sorts of issues.

Version of the sim.
Version of gaming services.
Version of display drivers.

My take on that is that neither MS or Asobo are responsible for keeping our systems up to date. We are. What I think they could do is a better job of making us aware these updates are available to install. In my example above I didn’t know either of those updates were waiting to be installed. I received no notification anywhere that they were ready to install. A little “2” on the “MS Store” icon at the bottom of the screen would be really helpful in that regard. Or wrap it into the “Windows Update” somehow, which says I am up to date currently.

In the Store App I see this icon, with a blue dot:


I just had a quick look in the “App Settings”, and I see this option:

So that doesn’t seem to be working for me either, as those two updates are still waiting. :wink:

I manually updated those two apps. and hey presto the blue dot has disappeared:


So that’s it. The only notification we have that an update is ready to be installed, because the auto updater doesn’t appear to work, is that blue dot tucked away in the “MS Store” app.

I feel these needs some love.

Over to you @StrohSchema7980. I expect your next post to tell us you have updated/reset “Gaming Services”, and that the sim now launches cleanly.

ok, meanwhile I have reinstalled my PC with OS and MSFS 2020. So far so good. I’ve had to do that before. Before that I’ve done the whole registry fumbling procedure strictly according to the recipe, without success.
I have a feeling that you are someone who contributes valuable recommendations on this topic. My head is spinning now and I hope to be better prepared for the next gaming service “event”. I agree with you that a structured process for analyzing the respective situation is missing. If Asobo doesn’t solve the actual problem, then they should at least create some kind of checklist that analyzes the problem and offers 1:1 solutions.
Thank you again for your comprehensive and very helpful post.

Exactly so what about gaming services version?

Yep :wink:

Steam is connected to OS (windows) so “Anything that can go wrong will go wrong” - Murphy law.

One last question still moves me: It is obviously crucial that the Gaming Service app must be available in a specific, correct version, otherwise nothing will work, MSFS will not start. By what process or by which program is a non-correct (old) version detected, which then blocks the program start?
Is it a Windows update that will make the existing version of the gaming service app obsolete?
Or is it a MSFS update in which it’s programmed that a specific (new) version of the gaming service app is required to start the program normally?
Since the gaming service misery has not happened after an MSFS update so far, I suspect a Windows update that is silently running in the background without me noticing. And then out of the blue leads to the blockage of the program. Are my thoughts logical?

These Gaming Services are updated via the Microsoft Store. They are required for Xbox games. You don’t really need to worry about what version you have installed for general use with MSFS; just make sure they are up to date, as they work together with online cloud services and need to be updated.

The Microsoft store updates are automatically installed but often with a delay, which can be an issue if MSFS requires these updates to function properly, so I can recommend checking for updates in the Microsoft Store.

There are constant updates in the MS store, I’ve made it a log-in-to Windows habit to update these apps after starting the PC. You could make a desktop shortcut that will directly jump to the update page of the store. I am not at the PC right now but can share this shortcut later, if you’re interested.

You sometimes must press the “check for update” button for the whole list of available Windows Store updates to show, because of the delay mentioned above – they don’t all show up in the list, if you want to check for available updates.



You can drop that into a browser, and it will redirect you. I’m just looking for a way to get that to work as as URL.

The following works from a script:

start ms-windows-store://downloadsandupdates

1 Like

The Microsoft Store can be evoked via a Windows Explorer shortcut.
To create a shortcut you could use the below:

One way to add a Windows Store shortcut is by using C:\Windows\explorer.exe ms-windows-store:updates as the destination. It will look like an explorer.exe shortcut on your desktop but you can change the icon to something recognizable and a name of your choice.

I have it pinned as Store Updates in the Windows Start Menu, which is also an option.

I hope this makes starting updates a bit easier.