Ground texture - Low resolution - Internet incorrect Bandwidth

You can change the LodFactor in UserCfg.opt between 0.1 to 10.0 (at least) (10-1000 in-game) to achieve the same. With Cheat Engine you only get the added benefit of changing the LODFactor on the fly.

alright got it, thank you! And where can I find this config file as I have the simulator through game pass

I think unplayable is stretching it a bit

1 Like

You can find it in the file which holds all the graphics settings: %LOCALAPPDATA%\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\UserOpt.Cfg

This file will get overwritten by the game at least when you change settings, so be sure to change it all back.

1 Like

Thanks to all of you feeding this post and your votes, Asobo and Microsoft are now focussing in the issue, and it is mentioned in the new Snapshot!

:+1:t3::ok_hand:t3:

1 Like

Further on this, I’ve tried analyzing the different files and what is happening behind the scene. It is not bullet proof a conclusion but here is:

  1. The simulator is using Bing Map REST API through a DLL installed in the “protected” WindowsApp folder.

  2. This DLL is using an external configuration file located here:

C:\Users\login_name\AppData\Local\FlightSimulator\overrides.json
  1. The file stores the various REST API strings the simulator needs to send to the Bing map server.

  2. It looks like this file is versioned and you can read there are 2 known versions: “KittyHawk” and “teolin”. I don’t know if “teolin” is patch #2 or if this is a provision for the next Japan DLC.

  3. It seems to be supporting whether Bing maps servers return compressed textures or not. I suspect the later makes the computer compressing the raw texture pixels bitmap then, because when trying this out I’ve seen the CPU activity and temperature rise a lot for a sustained period, but it is just speculation.

  4. “gpu_model” is supporting the following values: “minimal”, “low”, “medium”, “high”, “ultra”

  5. The json file is a missing a supported key name “graphics_supported” (using same values as gpu_model) but this doesn’t seem to make any difference.

  6. I’ve not tried altering this file much in changing only few of its values, like “compressed_format_support”, but if you do, you might want to set the file to read-only otherwise it gets overwritten by the simulator.

There is one thing I’ve not tried but I’d like to is removing all settings related to the “teolin” entries and see what it does. However I’m not convinced the issue with texture LOD comes from this.

In effect, whether you create a local cache or just use the global cache, you can see that when close to the ground, textures are ok, and when higher up in the sky you can see the change of texture resolution in adjusting the Terrain LOD setting.

I’d suspect this is just a bug only, if not a feature Asobo is testing with us PC users prior deciding which LOD is best for console users. If this is a bug, it has to do with the simulator code using the Terrain LOD setting value to pick up the downloaded texture from the cache wrongly, because the highest definition texture is certainly already in the cache as you can see it when near the ground.

Something which makes wondering though is whether the issue is not just due to a typo because I find it peculiar having 2 similarly named keys: “graphics_support” and “graphics_supported” (even if semantically they have 2 different meanings).


[update 15FEB2021]

There are much more LOD distance related problems now documented:

LOD: settings and suggestions
LOD problems - Trees Fix Revisited
LOD Problems - Distances revisited
Trees draw distance is different per-species AND per-Trees LOD setting
Some trees are disappearing then reappearing


[update 20FEB2021]

Something which makes wondering though is whether the issue is not just due to a typo because I find it peculiar having 2 similarly named keys: “graphics_support” and “graphics_supported” (even if semantically they have 2 different meanings).

It seems this entry is now gone which might indicate it was indeed a left-over from older versions.

7 Likes

Every time I make an edit in this file it is overwritten back as it was by the system >_<

I FOUND THE SOLUTION !!
It was a long way to understand why the textures were poor.
The culprit is the IPv6 technology used by the MS server
Therefore, some have a problem, others do not. Dependent on internet provider.
If you have an internet that uses IPv6, you are fine.
However, if you do not need to establish a bridge between IPv4 and IPv6, the Windows service TEREDO is used for that.

Before:


Now:

Below is information on how to start it!

  1. Windows Keys + R
  2. gpedit.msc
  3. Under Computer Configuration > Administrative Templates > All Settings
  4. Find “Set Teredo Client Port” , “Set Teredo Default Qualified” , “Set Teredo Refresh Rate”, “Set Teredo Server Name”, “Set Teredo State”.
  5. Now, what you do is double click it, choose “Enabled” and change it to what I write below, some of these are not necessary but just change all of them :).

Set Teredo Client Port - Enable - input " 0"

Set Teredo Default Qualified - Enable - choose " Enabled State "

Set Teredo Refresh State - Enable - Choose " 30 "

Set Teredo Server Name - Enable - input " win10.ipv6.microsoft.com "

Set Teredo State - Enable - choose " Client " (If after doing all steps it fails, try choose Enterprise Client instead.)

After that, Win+R , services.msc, look for “IP Helper” and restart services.

Now , Win+R, cmd, input " netsh interface teredo show state" and you should be seeing something like this:

Freaking finally, hope it’ll help people like me who struggled with this ■■■■■■■■ aged adapter!

Edit: In case you are on Windows 10 Home and no Group Policy available follow these steps on here:

Source:

10 Likes

You’r my God !

I have permanent Teredo connection ON in XBox parameters now !

Thanks a lot :crazy_face:

unfortunately,this didn´t help. This is the 2345th Tutorial for how to get this Teredo thing work on my machine. Still all fails.

Win10Pro

1 Like

Yes, doesnt worked for me too, Win10 enterprise

Have you tried to mark the client a corporation in one of the services? There are two options: client, corporation client

1 Like

I’m not sure to understand what is the difference before and after per your screenshots. the problem with ground textures as I understand it is that it takes something like Terrain LOD 200% with v1.8.3 to see ground textures with the same resolution as Terrain LOD 50% with v1.7.14. This is particularly visible if you for example slew up to 5000 or 10000ft and then zoom the view when looking down to the ground either beneath you or around you.

The other problem is photogrammetry polygons displaying at their lowest LOD level too early (i.e. too close to you).

Are you saying in just setting up Teredo settings like you’ve explained above, you’re getting back texture resolution to the same levels as v1.7.14?

5 Likes

Your before shows you further from the buildings then your next screenshots shows you closer to them.Would be great we see a screenshot with in the distance after like the first one.

1 Like

I don’t have an “All settings” selection in gpedit…what am I missing?

I give up, I have windows 10 home, trying to get all the options in GPedit seems impossible.

Fair questions CptLucky8 - not sure how NAT can make things better on this specific issue? But maybe it does?

the best would be @PATNoe posting some screenshots with the aircraft at 10000 ft in external view looking down from above the aircraft with maximum zoom.

3 Likes

Agreed makes sense that would really help us out.

I’ll just leave this here…good lord it seems like its getting worse!

2 Likes