Holy moly! How do I "interact" with the cockpit now?

Now I feel very stupid, but how do I click (“interact”) with cockpit elements with the mouse? Like, you know, left-clicking on some button in order to switch it, like this worked since ever?

With 3rd party airplanes simply nothing happens, with some stock aircraft I get at least some kind of “tooltip”, like:

Of course hitting the ? on the keyboard does nothing, so I assume that FS2020 is now trying to tell me that I first need to assign some “interact” action with my left mouse button or what?

Help! I feel really stupid now, like someone asking for the “any” key when asked to “press any key to proceed” - like, really!


Your not alone I’m having same problem in the A320 that’s if I don’t get a CTD

1 Like

Okay folks, I quickly figured it out, but I must say that this is borderline ridiculous:

So yes, there is a “Cockpit Interaction - Primary Action” (under “Miscellaneous”!) now. In my case that was unassigned (I also checked under “Keyboard”, no key assigned either by default.

So I had to manually assign it first to my left mouse button! This can’t be intentional, that we have to manually assign basic functionality (which was working previously, that is)? I mean, this should be assigned to some reasonable default keys and buttons - like the left mouse button, for instance!

I guess they where more consumed with testing all the XBox controller assignments than existing peripheral devices, such as the good ol’ mouse :wink:

Hope that helps someone else to get quickly into the air…


You could have disabled that new cockpit interaction feature in the Accessibility settings as well. I’m not a big fan of it yet, but some people seem to enjoy it.

1 Like

Actually it could really be my bad (*): I must have (unintentionally?) re-assigned some mouse button (I can’t remember right now why I might have done that, but doesn’t matter).

In any case, I had a “Mouse Profile”, which is different from the “Default” (sic!) profile! So switching back to the “Default” profile gave me the following assignments:

That looks much better now.

So in case anyone else is running into this: check your “mouse profile” and you might need to switch back to the “Default” profile (and restart with custom assignments from there, as needed)!

UPDATE: Thinking about it some more this is my bad - sorry about the fuss! But could still be helpful for others who fall into the same pit.


I also had the problem that I couldn’t click anything in the cockpit. It’s not Asobo’s fault though, it’s my own. I had changed my mouse profile and had been using my personal mouse profile ever since. Now Asobo has changed the assignments. Of course, my personal mouse profile no longer works. The solution: Simply set the mouse profile back to standard, then everything works again as it should. With the new standard mouse profile, you can then create and adapt your own again.

1 Like

Interact with it just like you did before…

You know where is the “mid click” key? Im new using mouse and keyboard

Unbelievably poor roll out on that one.

If you’re going to completely change the way users are going to interact there needs to have been weeks of forewarning. At the very minimum some splash screens of warning during the extended update period.

Instead what you got yesterday were people already frustrated at literally a minimum of hours updating finding in many cases could no longer use the program.

I have enough stick and throttle plus memorized keyboard shortcuts that I didn’t figure it out until I was airborne and trying to adjust AP altitude. In a fluster I went to flying by hand, touched the trim up and smashed into the ground as it was now super sensitize and backwards.

Actually it is the opposite: the update did the absolute correct thing™ and did not touch my custom profile (the fact that I forgot about my custom profile is my fault!).


Congrats, glad it worked for you.

I would have much preferred to have been informed of the “new option” and allowed to select it myself.

However the financiers of the XBox launch have been left behind as so much jetsam and have to deal with whatever changes are needed for the aforementioned to work.

Asobo announced that the interaction system in the cockpit would be revised. From this, one can conclude that if there are problems, it could be due to the mouse setting.

Microsoft Flight Simulator Available Today on Xbox Series X | S and Xbox Game Pass - Community / News and Announcements - Microsoft Flight Simulator Forums

1 Like

From the amount of threads on the subject they did a rather poor job of it.

I’m a forum hound and I heard nothing about it and I had quite clearly gotten the message that AI was to be a problem, empty your cache, community folder, ect.

And your point is…? That from all the gazillion of updates, discussions, YouTube videos, release notes, … distributed all over the internet I missed exactly this one important piece of information?

1 Like

Wow. I missed that (mouse profile changes) but found a way to select and click buttons and toggle switches.

  1. Grab and move
  2. Grab and right-click

The guys are amazing devs, BUT, and here I fully agree with you, the changes were extremely poorly communicated, no excuses here. One has to admit when things aren’t delivered well. They need to learn from that(whoever is in charge of communication between devs and forum) and I hope the forum mods here do their job and tell the devs that people aren’t happy about some of the changes, because if you leave barking dogs unchecked, it can get really loud and uncomfortable. They better hurry and provide an official statement that they acknowledge that this wasn’t a smooth update. Seems to be the one that divided the community most. Not happy about this.

1 Like

What is your point? I wasn’t talking to you, I was responding to Salem. The information was in the link and was published before the update. And if you subscribe to “News and Announcements” in your profile, you won’t miss news from Asobo.

For the record: I did not want to imply that I blame anyone except me for my stupidity: I was stumbling over a small issue, figured it out after 5 minutes and thought I’d let it stand here, as a help for other people!

Yes, the changelog might have been a place that I could have consulted in more detail - but just imagine: how would you inform people about each and every tiny little detail, without creating an “information overflow”?

Or asked differently: did you really read the provided changelog/new feature description that came along with the update? (And yes! There is one, I’ve seen it myself - I just didn’t bother just yet to read it in detail ;)).

P.S. @admins, if you stumble over this: this thread can be “closed” from my point of view - it has already served its purpose.

1 Like

All clear :wink:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.