"Home cockpit mode" does not hide the virtual cockpit and never has since it was introduced

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No

Brief description of the issue:

Home cockpit mode was introduced in late 2020. The earliest post in the forums about it is this one from December 2020, so it was probably introduced in Sim Update 2 (1.12.13.0).
It is a camera option with the following description:

Enable Home Cockpit mode.
This places the camera in the center of the cockpit and disables the virtual cockpit from rendering.
image

The only problem is that it seems to move the camera, but the virtual cockpit is still there.
This has been corroborated many times in the forums by other people, but never in Bug Reports, so I’m creating this bug report now.

Provide Screenshot(s)/video(s) of the issue encountered:

Video showing me turning Home Cockpit Mode on and off. You can see the cockpit moving behind the modal dialog box, but the virtual cockpit does not disappear, as indicated that it should.

Detailed steps to reproduce the issue encountered:

  1. Start Microsoft Flight Simulator.
  2. Click on the World Map and start a flight. I have not tested with every possible aircraft (and have not seen any posts saying that it works on some aircraft), but I can tell you that I just tried it with the Cessna 172 G1000, Beech Baron, and the A320neo (base A320neo, no FlyByWire).
  3. Go to Options > General Options > Camera.
  4. Toggle Home Cockpit Mode on and off.

Expected result: The virtual cockpit disappears.
Observed result: The camera moves inside the cockpit but the virtual cockpit does not get removed.

PC specs and/or peripheral set up if relevant:

Should be irrelevant, but here:
2.60GHz i7-10750H
32 GB RAM
GeForce RTX 2070
1 TB SSD
Windows 10 Home 20H2
OS Build 19044.1706

Build Version # when you first started experiencing this issue:

I originally reported this in Sim Update 2 (1.12.13.0), Zendesk ticket # 87729, and again in 1.13.17.0, Zendesk ticket # 95676, which clearly didn’t fix the problem because it’s still a problem in 1.25.9.0.


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

4 Likes

Do you have the same issue if you follow the OP’s steps to reproduce it?

oh certainly! still, after 2 years, nobody at Asobo or MS seems to bother that they put a dummy menu item in their software, their answer: ¯_(ツ)_/¯

4 Likes

Do you have the same issue if you follow the OP’s steps to reproduce it?

yes

Provide extra information to complete the original description of the issue:

still not operating in SU10

If relevant, provide additional screenshots/video:

Unbelievable!

It is there for such a long time and never worked?

I am just to byuy Air Manager and have the Insttruments on another PC.
So I exepected just using this function and get rid of the virtual cockpit.

sh*t

Just using finally the contribute button.

Turning the cockpit mode to “on” does do nothing. No mre information required.

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

yes

Provide extra information to complete the original description of the issue:

nothing more

If relevant, provide additional screenshots/video:

na

Do you have the same issue if you follow the OP’s steps to reproduce it?

yes

Provide extra information to complete the original description of the issue:

bizzare a nonfunctional option has been in the sim for years.

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

mhm…:slightly_frowning_face:

Provide extra information to complete the original description of the issue:

meh…:tired_face:

If relevant, provide additional screenshots/video:

naah…:face_exhaling:

Do you have the same issue if you follow the OP’s steps to reproduce it?

yes

Provide extra information to complete the original description of the issue:

same problem as mentioned

If relevant, provide additional screenshots/video:

I just noticed this was moved out of the experimental area, which implies Asobo somehow thinks this still works. Has anyone been able to get this to work at all or do anything?

1 Like

I hope that it will be added soon …

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes, it has never worked as described. Seems a pity.

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

Same in DR400

If relevant, provide additional screenshots/video:

na

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

This is the same scenario I’ve had since this non-functional “option” was introduced.

If relevant, provide additional screenshots/video:

Not required

Do you have the same issue if you follow the OP’s steps to reproduce it?

yes

Provide extra information to complete the original description of the issue:

exactly as stated above

If relevant, provide additional screenshots/video:

same as original post

Hello,
If you are experiencing the same issue but don’t have any more detail to add, you can just vote for the bug report. (That is true for any bug report, not just mine!)

Sorry, I was not aware of that. My mistake.

No worries at all. Welcome to the forums! :slight_smile:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video: