Hp reverb g2 error after 3090 upgrade

I’m at a loss here, hoping this has been seen before.
Here is my current rig.
Ryzen 9 3900X
64 gigs ram, SSD

Prior to installing the 3090 I was using a EVGA GeForce RTX 2080 SUPER FTW3 HYDRO COPPER
and everything was fine. After installing my new 3090 card open XR didnt recognize a headset and WMR gave error 7 - 14. I looked at the open xr tool and under system status/ exceptions it says: The active OpenXR runtime does not have a head mounted display system avail. You may need to setup XR platform or plug in your head set. Head set is plugged in and it seems to power cycle every other 5 to 10 min or at least i believe it is. My 2080 had a designated c port on the card to provide power and this 3090 does not, however my mother board has a usb c port so I’m a bit lost. My open XR is on runtime 108.2109.21002. runtime manifest is still runtime.json in c/windows etc…
The HDMI port displays to my monitor but right now nothing from the display ports. I haven’t checked display port on a monitor yet to see if the ports are active which they probably are. So I’m wondering if the c port on the motherboard is providing the proper power to the G2 or not. Also if I am to setup open XR like it stated I’m not sure what its talking about. There was other app on the Microsoft store for openxr mixed reality not the tool, but I cannot download it because it says I already have it but it doesnt show on the apps and it still tells me to download it. I was hoping to have a smooth graphic card swap but now it has become a frustrating event. Lastly I contacted Microsoft support and all they told me to do was uninstall the display adapter in device manager and that would fix my problem. I had doubts. I hope someone has seen or heard of this. Need to get back in the VR skies.

I can’t remember all of the errors exactly, but I also had problems after going to my 3090 and having to use the M/B USB C port. But my woes were similar to yours, and from my search history I was looking at errors 7-12 and 7-14. I also remember trying to get things worked out on the Device Manger, but it was impossible. Sometimes things would show, sometimes they wouldn’t, and sometimes they’d show as an error. I installed drivers, uninstalled, reinstalled, nothing worked.

After HP replaced the entire unit in Feb/Mar (it had a bad Gen 1 cord) and I still had problems, it was clear that the USB power was an issue. So I bought a $20 USB expansion card (ULANSeN 3A1C). Since then, it’s been perfect.

So I’d suggest checking with HP and see what they say, but based on everything I would agree with you that this is likely a USB power problem.

My specs: ASRock Taichi x 570, 5950X, 3090 FTW3 Ultra, M.2 NVMe, 32 GB 3600, Reverb G2 w/lens inserts, 300Mbps/T3 Internet, TM 1600M HOTAS.


I just ordered a pcie usb A+C integrated card, should be here sat. I hope that’s what it is. I makes sense since the 2080 was supplying its own power to the headset. We will see. I have a few other options to try.

I read on other web articles that there is a fix within a BIOS upgrade that addresses this issue. AGESA MSI has a BIOS update for the X570 and B550. I need to search ROG and see if they have an updated BIOS that could solve this. Still have doubts. Will update with results. when able.

I have a G2 as well and a 3080 which has no USB C port, but my motherboard does. I use the USB C port from the motherboard without issue. I don’t know if that provides any power or not, but I was surprised you were concerned about that as there is a separate power supply to the headset that connects to the “box” on the cable. So I’m not sure the headste will be getting power from the USB C cable at all - but I’m no expert.

My G2 also came with a USB C/A convertor - have you tried using that instead of the USB C on your motherboard to see if that helps?

I’ve been trying to find specs in regards to the purpose of usb c for the cable. I thought it was power due to when i unplug the c port I get the windows device disconnect tone. I do have the version 2 cable on order and should arrive within a couple weeks according to hp. Now for the converter I need to look for it as to I packed all my motherboard and pc stuff together. It is on my list to do.

Found details about the cable C port, It does not supply power but does supply data. As soon as I get home from work I’m going to look for the adapter “IF I CAN FIND THE BOX” I am determined to beat this frustrating issue. If my 3090 only had a c port I think it would work fine.

I’ve had a g2 since January and it would work for 2 weeks or so then fail. I returned the unit and simply got a new one. I actually did this 5 times before the new cable came out and fixed all issues.

During that period I was constantly asking Dell (my computer manufacturer) when they would release the AGESA update. Not only did they not give me an indication they never actually said it was an issue and put all the blame on HP. I think most of the big motherboard manufacturers have released this for a while now although I’ve read it is not 100% a solution. I also called AMD themselves and they admitted this is the issue.

I tried both an internal pcie board and external USB hub but neither solved it.

The v2 cable is the thing every G2 owner needs but especially those with an AMD motherboard. I’ve had mine 2 months now with zero issues.

X570 motherboard

Good to hear about the ver 2 cable, mine is supposed to ship on Oct 12. previously it was Oct 4th but you know how that goes. I will be pleased if that solves this problem I want to fly with the 3090. Thanks for the feed back

Had the exact same problem and code 7-14… I’m also on AMD and latest BIOS but it’s not enough. You need the V.2 cable. I received mine 2 days ago, after 4 weeks of wait and it works perfectly now. No need for a USB hub anymore :slight_smile:

I found my usb a to c adapter plugged it into a 3.0 slot and hp powered up. WMR started working and no more error. However the second I get that cable I’m swapping. I’m thinking that c port on motherboard is not active. need to investigate that. Also have a pcie card on the way just incase. I do appreciate the info given, it really helped me more then you all can imagine. Thank you. Will update until cable arrives on any other issues.

Check thread below, and if it’s a v1 cable you have (look for SilverSeraph913’s photo), get it replaced under warranty and you can keep the v1 cable as a backup (use it with add-on pci-3 card)


Idk about the USB Type C but the USB A 3.0 (or better 3.1, which is running with my A/C Adapt.) must have at least 5Gbps transfer power

I have the v2 on order

usb 3.1 on my rig. It working now but I’m going to have options if it fails. So far so good. No usb drop outs

I have an HP Reverb G2 and the USB-C cable is plugged into a motherboard USB-C port and I am using the power adapter. I’ve had no problems with either an RTX2070S or now with an RTX3090. I’ve changed the VR LODfactors for object and terrain detail from 1.0 to 2.0 in usercfg.opt (and from 2.0 to 4.0 in the 2D section of usercfg.opt) and it’s been working great for me. My configuration is listed here: Windows 11 and VR / Win11 VR - #28 by JALxml. I wonder if it’s an AMD vs. Intel thing? My RAM is relatively underpowered, too, compared to what most people are using, only 2600 MHz, nothing overclocked except the built-in speed of the i9-9900K cores. (sorry for any irrelevant comments - I’ve just skimmed the thread and am gratuitously adding my $.02 worth). I’m also running Windows 11.

BTW, I don’t have any liquid cooling. The Sword of Damocles hanging over my head is without doing anything both the i9-9900K cores and the GPU, especially the memory, literally get boiling hot. Cranking up the GPU fan speeds to 1700 to 1900 rpm with MSI Afterburner solves the GPU heat problem and I’ve decided to let the cores burn away as an Intel Support post claims anything less than 100 deg C is “fine.” (!!!).

Case Fans are cheap…$20 a piece and an internal hub can run 6 for $20….if your cpu is reaching anywhere above 80C it may start thermal throttling and reducing power hitting your performance a lot. Maybe give that a go.

1 Like

Boatloads of posts on this exact problem for a long time now and it’s why the new G2 cable was finally released (terrible testing by HP to not have caught something like usb problems with so many AMD and also some intel setups). And many also have to use a powered usb hub although I don’t have to with the new G2 cable. With the original cable I did have to use a powered hub to get the G2 to work consistently (i9 10900k, 3090). Love my G2 now that the cable is sorted out.

1 Like

Thanks for the recommendations on cooling, which I think you also made in another thread. I’m testing the Intel support person’s claim that 100 deg C is allowed as the maximum T-junction temperature! Intel Core i99900K Processor 16M Cache up to 5.00 GHz Product Specifications. I haven’t seen any sign of throttling. Turning up the 3090 fan speed keeps the memory and everything else in the GPU below 80 dec C. My performance is great. I run HWMonitor sometimes, which records maximum/minimum as well as current parameters and I haven’t exceeded 96 deg C for a core or seen the processor speed of any core radically fall below 4.7 GHz in the minimum values saved by HWMonitor. I’m too lazy and technologically challenged to tear apart my case and add more fans or liquid cooling. But if I ever build a PC from the ground up, I’ll be sure to do that aplenty. To me, it’s kinda like the difference between remodeling and just building a brand new house from the ground up. Remodeling, tear out walls, redoing wiring and plumbing is always a pita, IMHO. In the winter, when we let our indoor temperature drop to 60 deg F (~16 deg C), everything should have 22 deg F (6 deg C) cooler air to help it along! :slightly_smiling_face:

my cpu is water cooled and I have the max amount of case fans I can squeeze in. Temps are in a good zone. I flew in Hawaii today and circled some observatories on one of the peaks on the most western island. Real weather has it real cloudy and then scattered at about 8,000. Performance and quality was truly impresive!

1 Like