Intermittent Performance Spikes, high time in Manipulators

Yes, this works :slightly_smiling_face:

I just tried with the game completely stock. No mods, no Simconnect apps. Got hit with the bug before I could even take off, just taxiing around DFW.

Exactly same issues here. If I press ESC and then resume flight it usually starts behaving again.

I’m experiencing random and dramatic drops in performance to <10fps in these situations:

  • right after loading the sim in the menu
  • after clicking into Graphics Settings menu
  • after switching into VR mode

The sim was freshly installed on a new build (Ryzen 5600x, RTX 3070) and ran fine with excellent performance in VR for a few test flights of about 30 mins each. Then this problem appeared after no changes anywhere and I cannot resolve it, even after a reinstall of the sim.

Right now it’s a matter of luck whether I can load into the sim and switch to VR mode without it dropping into this performance black hole.

You can see the game struggling with the menu animations and transitions if it loads up in this state, or if it drops into this state after visiting the settings screen. If it drops into this state after switching to VR mode the display in the headset is a mess with black bars everywhere as it cannot even track the 2d menu.

If by sheer luck I get the sim loaded and into VR mode (by retrying over and over again) without it getting into this state I can have a gloriously smooth flight in the Rift S (at least in the Cessna).

Definitely a hard bug with MSFS. No problems with IL2 BOS, or Elite Dangerous on this brand new machine in VR with SS and graphics settings cranked high/ultra.

I have removed/reinstalled everything including the game, Nvidia drivers, Oculus software, not running any third party or community plugins, no monitoring software, no weird tweaks, it’s categorically an issue with the game itself.

I’d be interested to hear what the response has been to anyone who has reported this via zendesk.

1 Like

Still have the same issue. I have a nvidia card 1660Ti and set vsync on in the game (30fps). Still the same. I have now set vsync on in the cpl. I have also set freesync off in the monitor settings (fingers crossed).

Same here. With mainthread and manipulators issue after full flight Exit to main menu cause 100% CTD

Have you folks tried opening the VFR map and dragging the map away from your location? This actually worked for me yesterday, and I have been having this exact issue everywhere. There was another VFR CTD issue back in the fall, after an update, as well.

This is World Map menu


I have also this drop in fps (30 fps to 18 fps) when flying over specific zone durin 30 secondes.
Take off from “L’herm Muret” (near Toulouse), directly turn right to make a 180degree back and sudently over the campaign (without special buldings or others heavy things) and the drop appears during 20-30 secondes and come back to normal (30fps vsync) approching Toulouse (witch is heavier in term of buildings and others).
Flying over Toulouse is ok (30 fps) and want to come back to this strange zone where fps dropped : the fps drops to 18 exactely at the same position (only severals little houses, trees or river).

1 Like

Okay. Tricks with Disabling VFR map from Toolbar menu seems to work again

Has this solved the issue of the sim occasionally starting in 10fps at the World Map menu?

Nope. Issue in World Map is not solved

Someone mentioned POI filter. Knowing it doesnt stick, I doubted it.

But I did that and turned off POI in assists, started a flight.

Then after THAT every start has been good, where previously every start would end up in 10FPS map/menu.

Not sure how that works, but it did for me.

if you know roughly where you are on the map you can chose to start your flight from there, click on the map closest to where you was & chose the “select as departure” option, then on the top right of the screen there is a blue bar called Navigation options (I think) in there set your cruise altitude to the height you was at - more often than not the sim will start you at the cruise height selected. I had to use it 2x last night after I experienced a sim freeze on two occasions using a new payware A/C I’d bought.

Here is the location where i always have a drop in fps (30 to 18-19) without any reason.
Again and again drop when flyinf over this particular town during a couple of seconds.

Is there anyone who would try to fly here and confirm me he as also this strange drop in fpx here ?

I think you were just lucky, I haven’t flown with the POI marker since August.

1 Like

Hello reporting this up to QA. Could I ask that a few more details are posted, e.g. location where it happened, do you notice any kind of trend, basically anything to help QA reproduce.

Thank you

1 Like

Did you do to the POI filter part on the map too?

Pre-update YCBG Runway 30 does the same. Just spawn (triggers in loading phase) or taxi to it (triggers just before getting on runway).

I know this is probably not directly related to this issue, but at least it is a repro of the same situation.

See this thread for details Game has Broken! - #95 by DronkeyKlong

It seems there is something new in my problem of fps drop.
I posted just before that i had fps drop to 18 fps constant during 10 ou 20 secondes secondes instead of 30 vsync fps without any reason under special place in my region.

I found something strange :
Start MFS from windows, first flight : fps drops are always here under the same localization, and it always come back at the same place even i fly severals times over it.
Go to the main menu, restart the flight (with same settings, same plane) and the fps drop desapeared : it still 30 rock solid fps now!!!

Exiting to windows, restarted MFS, first flight, and fps drop to 18 are back again
Going again to main menu, restart the flight and the fps are constant to 30 fps under the localization which had problems before.

Exiting to windows, restarted MFS, first flight (but now without take off, only show the plane and waiting a few seconds)
Going to main menu, restart the same flight and now fps drop is coming back at the begining on the airport 'before i take off).

R5 3600 + 32 Go ram
Diseabling File cache, deleting it didn’t change anything.
Tried to seseable SVM (i saw this tip in another post didn’t change anything at all for me.)

Sorry for my english spoke , i’m french :slight_smile:

Taking off from LFBR (Muret l’Herm) and flying near “MUT” where my fps drop appears