Making Tobii eye tracker work with SU9


Has anyone advice for the setup for this or how to make it work?


Making Tobii work with the additional features delivered (what was found and tested so far)

  1. Go into the controller options and find “Tobii” among your list of controller
  2. Go into the “Sensitivity” options
  3. Set the “Position slider” away from ‘0’ - maybe start with ‘1’ and then change it to what suits you.
  4. Go to your keyboard controller options and ensure you use the default keyboard profile and its reset to defaults.
  5. In a loaded flight press the F12 key to reset the view.

Troubleshooting notes:

  • If you experience issues with not being able to lean back and forth and to the sides, try pressing the F12 key again
  • If you experience 3DoF, but not with 6DoF and F12 does not, the installation of Visual C++ 2015-2022 x86 could be corrupt. To check this run the following Powershell command:
Get-WmiObject -Class Win32_Product -Filter "Name LIKE '%Visual C++%'" | Sort-Object Name

and make sure a version number is listed. If there is no version you need to do the following:

  1. Uninstall the Visual C++ 2015-2022 x86
  2. Reinstall C++.
  3. Uninstall the Tobii software
  4. Reinstall Tobii software

How to ensure a clean updated installation for native support:

  1. Revo to remove ALL software ( )
  2. Reboot
  3. In Device manager under USB, remove EyeChip and check the mark to remove drivers
  4. In Device manager under software components, remove Eye tracker 5
  5. Reboot
  6. Install the latest drivers (Tobii Gaming | Download or Setup Eye Tracking Software and Drivers )
    All this while the device is connected

Correct versions should show:
App version: 1.55.15390.0
Middleware Bundle:
Tobii Experience Software For Windows (EyeTracker5):
Tobii Hello Sensor Driver:
Tobii Experience Driver:
Tobii Eye Tracker Generic Base Driver:
(there is a button to collect it in the Tobii experience software)

Checking USB and power settings

  1. Quit MSFS.
  2. Unplug the Tobii Eye Tracker 5 from a USB hub and plug it directly into a rear USB port preferably a USB 3 port.
  3. Click on the Windows Search Bar.
  4. Type in:
    Control Panel
    and click on it.
  5. Click Power Options.
  6. Click the down arrow to the left of where it says Show additional plans.
  7. Click the radio button for High performance.
  8. Click Change plan settings.
  9. Click the drop down menu for Put the computer to sleep: and click on Never.
  10. Click on Change advanced power settings.
  11. For Hard disk → Turn off hard disk after → Setting (Minutes): click and hold on the down arrow until it changes to Never.
  12. For USB settings → USB selective suspend setting → Setting: click on Enabled and change to Disabled.
  13. Click OK.
  14. Click the X to close off Control Panel.
  15. Click on the Windows Search Bar.
  16. Type in:
    Device Manager
    and click on it.
  17. Click on the right arrow next to Universal Serial Bus controllers.
  18. Right click on the top entry and then click Properties.
  19. Click the Power Management tab.
  20. UNtick Allow the computer to turn off this device to save power
  21. Click OK.
  22. Repeat steps 18-21 for all the other devices listed under Universal Serial Bus controllers.
  23. Click on the right arrow next to Universal Serial Bus devices.
  24. Right click on EyeChip and then click Properties.
  25. Click the Power Management tab.
  26. UNtick Allow the computer to turn off this device to save power
  27. Click OK.
  28. Click on the right arrow next to Software components.
  29. Right click on Eye Tracker 5 and then click Properties.
  30. Click the Power Management tab(if it has one otherwise ignore this step and the next step).
  31. UNtick Allow the computer to turn off this device to save power
  32. Click OK.
  33. Click the X to close off Device Manager.
  34. Reboot and after logging back in launch MSFS and test Tobii.
    (Source : Settings & Setup guide for the Tobii Eye Tracker 5 - #10 by skysthelimit707 )

To be confirmed if this is still an issue :
Clash with the Freetrack plugin in Opentrack (feedback from [donka73])(Microsoft Flight Simulator Forums)

Opentrack under the Output options ensure Freetrack is selected then click the hammer icon next to it for settings. Under Select Interface, select Use Freetrack, hide TrackIR and ok this. Now start head tracking in Opentrack then stop it again. Now exit Opentrack, fire up MSFS and see if Tobii is working in sim.

Depending on the version of MSFS, the button to ON/OFF is in various placed.
I am using a Steam version and for me it was in the Camera settings, when loaded in to a flight.

(Above is just for native support.
There are other options to make this work with 3rd party tools noted in the comments)


I can not get it to work either. Looks like a no go. Maybe it just does not work with directX 12. Maybe i will switch back to 11 and see what happens.

I just went back to activating the FaceTrackNOIR and it works

1 Like

How do you choose DX version?

Why I am not surprised? I am sure someone said that the feature was implemented but no one checked it was working. I can confirm I cannot make it work on my end either.

where is that option?

It just worked for me, I didn’t do anything. It’s way too sensitive however but at least it’s in now. Hopefully they will let us tweak settings. DX11 btw, not tried 12 yet.

Are you using FaceTrackNoir or any other plug in?

No. Just vanilla tobii 5. I literally did nothing and it works.

1 Like

If you used Face track noir before you have to uninstall with all the plugins and restart pc, then it should work. compared to facetracknoir i find it super smooth, sensitivity just right and eye tracking very helpful. I agree though 6dof is a must in the future, same as tweakable settings, everyone wants different sensitivity.

thanks Tobii and Asobo


have never used facetrack noir. so that is not it. Tobii works in every game i have that supports it. just doesnt do anything in mfs

You DO NOT need to uninstall facetracknoir to get it working!

I have both TrackIR and Tobii 5 installed on my PC. I also use Facetracknoir for several other apps (IL2, DCS FS2020) when I don’t feel like using trackIR with the hat. They have worked independently without issue for a long time.

Enter SU7 MSFS2020. Poor implementation from Asobo/Microsoft. It uses the same TrackIR ON/Off switch in the camera pop-out in game options and is hard coded with zero adjustments/setting. Only 3 Dof support. Only game that has had worse tobii support IMO is X4 foundations.

Here is what I did to get the basic tobii working -

  1. unplugged trackIR and launched the game - Loaded into a AC and tested head tracking - toggled on/off track ir option (did not work). Exited game.

  2. plug back in TrackIR and run track IR software, load game and load into sim. Track IR confirmed working - toggle track IR off and back on; presto - tobii now is working independently at the same time as trackIR. Take off the hat and notice tobii is responding to head and eye (gaze) movement, as well as the trackIR still working too. Toggle track IR off and notice tobii i still working and trackIR is no longer working. Exit game

  3. Exit trackIR software and relaunch MSFS2020. Load sim up and toggle on/off the track IR option. Tobii is now working in the new mode independently. Only 3 dof support and no where near what I’d like it, though the auto center is nice.

  4. be ■■■■■■ off and switch back to facetracknoir with tobii so I get 6 dof support and just occasionally recenter the head when its off again.

Note - Tobii is much smoother on the movement and tracking with the native tobii support in MSFS2020 vs facetracknoir with the tobii plugin for msfs2020… but only 3dof and NO settings as of yet… so back to facetracknoir for me… for now.

Come on Microsoft, Asobo and Tobii - you can do better than this!

Tobii and TrackIR get super confused if you happen to own both products.

This is not good implementation. Please give us independent on/off for tobii like TrackIR gets in game and the ability to change some options like “turn off the eye tracking” if we just want head tracking, and allow us to set curves and sensitivities.

I would call this a beta implementation as it is.

P.s. I also updated to the latest driver like @MortThe2nd below posted. This was actually step 1 - always update to new drivers on new product launches IMO :slight_smile:


Hi @Eychimo,

I had the same issue, but after downloading the latest driver from this page (as per the instructions, apparently Windows doesn’t pick up on these automatically), everything just worked out of the box.

Tobii Experience Driver v1.81

Once your eye tracker has been plugged in, you should automatically get the driver via Windows Update and the Tobii Experience app from Microsoft Store. But, if you are not getting the driver or the app, please download the driver below.

Please note that the version displayed in-app is the app version, not the driver version. This version is not yet available on Windows Update so download now to get the latest driver and potential app updates.

Here’s the link to the latest drivers;

Maybe this is a stupid question, but where can I fint the settings for tracking?

legitimate question , although atm there are no settings to be tweaked sadly

I got it to work doing a clean installation of drivers and software:

  1. Revo to remove ALL software (
  2. Reboot
  3. In Device manager under USB, remove EyeChip and check the mark to remove drivers
  4. In Device manager under software components, remove Eye tracker 5
  5. Reboot
  6. Install the latest drivers (Tobii Gaming | Download or Setup Eye Tracking Software and Drivers)
    All this while the device is connected
1 Like

My Tobii Eyetracker 5 is working out of the box with MSFS update SU7 even with DirectX 12.
The preset is usable but i am seeing forward for more tweaking options in future updates.
For example when moving only the eyes in the corners of the screen, the camera doesn’t stop moving.

Im having a blast in the F18!


Thanks for all the great feedback everyone! <3
Summarising what I’ve seen around the forums.

  1. FaceTrackNoIR can somehow prevent the native integration to work
  2. 6DoF
  3. Settings in-game

Keept it coming :slight_smile:

Community Manager
Tobii Gaming


I am very happy to have this work now! VFR is soo much better and I enjoy it so much more.

I do have a question/request : Could it be possible to disable the eye tracking, so only head tracking is used? I often have to look down at my keyboard and it would be great if the screen didn’t move while I did it :slightly_smiling_face: