Mixed textures in ground at default airport

Any 4080/4090 users having this issue?

I want to upgrade from my 3080 to 4090 in order to use Frame Generation, that requires the use of DX12 if I’m correct.

Don’t want to buy a pricy GPU if I can’t use FG because of this glitch.

And for the record I also had this issue using DX12 with my 3080 and W10. Switched back to DX11 and never seen it back.

1 Like

Yes it’s not specific to GPU. I wouldn’t say the glitch is bad enough to warrant not upgrading, it will be fixed eventually and if you follow any of the MSFS streamers (Chewwy, LonContoller, Blackbox) who have 4090s you’ll see the performance improvement of FG far outweighs the very occasional incorrect graphics tile.

1 Like

Thanks for your answer.

Still debating between the 4080 and 4090 though, as DLSS3 is the main purpose of the upgrade.

In my country, I can get the 4080 FE for 1400€, the lower 4090 start at 2000€.

My only fear would be « only » 16 GB of VRAM as DX12 seems to use a lot. With my 3080 10 GB it uses more than allocated and it makes my sim stutter, reason why I sticked to DX11.

I hear you, I went through same debate in my head and eventually decided to take the pain on cost for future-proofing with extra VRAM (I was easily maxing out the 12GB on my 3080Ti in DX12 tests). Also with a little bit better performance on 4090 vs 4080. Founders Edition in UK was GBP1599 (EUR1869 I think). Brilliant card, runs much cooler and quieter than the 3080Ti and really nice in 4K even on DX11 with Fenix, iniA310, PMDG.

Yes on Nvidia website FE is priced at 1859€ but out of stock for now, while the 4080 FE is available :smile:

I’m on the same boat, just got my 4090 and had to switch to DX12 for FG… now i have on almost every 3rd Party Airport these stupid missing Tiles :frowning:
Please fix it.

Do we need to be part of the beta to get access to FG?

What I also realized recently is: while just turning on Dev mode instantly fixes the ground texture issue, it also alters the colourisation of the whole image, it looks like a filter is applied/removed when using or disabling dev mode. Very, very strange…

It’s this, watch de images attached. That was with a previous gpu (rx6900xt).
Now I’m going from RX7900xtx (has same issue in my system) to a RXT4090. I’ll report back if this issue persists with such a dramatic gpu change.

BTW: I am pretty sure I found the reason why switching on/off dev mode results in such a visible shift in my case: Bijans terrain masks. It seems that when I activate dev mode, those masks are disabled/inactive. Not a huge deal, but also something I never observed in DX11…

Bijan’s are way outdated. Bought them and it’s been months uninstalled… Almost like a “scam”.

It seems I don’t have this issue anymore when using DX12.

I now have a 4090 and a 5800X3D but even with my previous 3080 it was gone. Don’t know the reason, but I still keeping my fingers crossed.

I still have it and seemingly more than ever, really annoying. As of now, not even the dev mode trick works for more than some minutes, usually when I taxi out to the active, mess starts all over again. This is such a bummer, again back to DX11 and stutterfest for me sadly…

Can confirm, I’ve just upgraded to a 4090 and I still get this issue. DX12 performance is excellent though with FG/DLSS.

Interestingly, there still seems to be a strange DX12 (I think) related memory leak, where after a few hours of flight, performance degrades to a frame every few seconds and system memory usage goes through the roof until all RAM is consumed. The debug graphs show Main Thread spiking into the purple with times in the order of 000s of ms. At full RAM usage, system starts trying to use page file, at which point it seems MSFS gives up the ghost and crashes to desktop.

It’s really hard to reproduce so hard to say 100% with confidence that DX12 causes it. I refer to the state of DX12 being in Beta and Asobo themselves saying there could be some “performance regressions” as a disclaimer in the settings, based on memory usage, and it does appear to be a memory leak.

I hadn’t had it on my previous GPU (6900XT) for a long time, so is it possibly MSFS/nVidia driver related. Possibly not, as I did clean fully with DDU on install.

Frustrating because DX11 strangles the 4090 with being so heavily CPU bound. But DX12 is where it shines with superb performance in 4K and VR.

1 Like

I don’t have the issue anymore since I got my 4090, I went back to DX12 for FG.

I get great performances with the 5800X3D except the vertical panning stutters in complex airports with complex airliners when I am at the gate. (MSFS / stutters when panning vertically / 4090 and 5800X3D - YouTube ). There is a one year old topic about this issue but Asobo doesn’t care.

What a shame having a 4090/5800X3D/32GB/NVME/2Gb fiber setup and still having to suffer these because the sim doesn’t know how to cache objects…

I had a 7900xtx on my system and changed to 4090, when benchmarking I realized it didn’t let me use ray tracing benchmarks, nor games with this feature enabled. GPU-Z reported back that the CUDA , Physics and OpenGL were disable… don’t know why. Tried DDU many times and same result.
Ended up reinstalling Windows. Fresh install and drivers were installed normally with all features activate. So… something got messed up with my old 7900xtx drivers in windows deep code. I say this because my amd gpu didn’t like any undervolt with MSFS, And in one of the CTDs crashed even my Ryzen igpu driver.
I still have to do the Dx12 tests to see if the issue of this topic remains. But at least in Dx11 4k native with all set to ultra the performance is at another level. Just a little more fps in my case (cpu limited) but I have virtually ZERO stutters now under Dx11. Also the card is at a chilling temperature vs the 7900xtx.

Anyways I’ll report back about the ground textures issue. And also check if I have the memory leak issue with Dx12 since I use to do around 4h flights continuos sessions (turnarounds) in the sim.

1 Like

I did a flight with DX12 last night in the Fenix, performance was great, and no ground texture issue. Interesting. No memory leak - I kept RAM usage open at all times, total system hovered around 20GB of 32GB, MSFS using around 10GB. It decreased slightly once airborne, indicating it is correctly clearing memory usage from ground items of a hand crafted airport.

Interesting point to note, the flight was in the UK. Most of mine are. The flight where I exhausted resource and CTD the other day was over Europe, specifically around the alps. To try and reproduce I’m going to do a few more flights to see if this is indeed related to terrain/location in the world.

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No

Have you disabled/removed all your mods and addons?

Yes

Brief description of the issue:

Every airport I go to, besides addon airports. The textures for the taxiways and just the airport in general will disappear chunks at a time. (as imaged)

Provide Screenshot(s)/video(s) of the issue encountered:

ICAO or coordinates (DevMode > Options > Display position)

Literally all airports

Detailed steps to reproduce the issue encountered:

Load into any airport.

PC specs and/or peripheral set up if relevant:

4090, Ryzen 9 3950X, 4k monitor, T16000 joystick and throttle

Build Version # when you first started experiencing this issue:

Since the previous update


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

Almost every default airport. Mostly the textures are mixed when i switch between cockpit view and external view.

If relevant, provide additional screenshots/video: