New Utility Release - Aircraft Manager Free

I’ve done a lot of testing with different sets of planes and liveries via add on manager and didn’t encounter that, but then I wasn’t changing the data, just changing what was in the community folder.
Also had many cases of not loading planes between sessions, but when I do load them tags are retrieved correctly, because the keys haven’t been modified.

It sounds to me like somehow the planes reference name has been changed in the data, or reset, I’m not sure. You could try putting it all back to the same state everything was when you saved the tag and see what happens. There is no active tag deletion code, so the only way it can lose the tag is if the reference plane name has changed. If the other planes are retrieving their tags ok, then you can see it’s working, especially if the only one missing is one you’ve been playing with.

As to what changed the planes name, unsure.

I have to draw a line somewhere though, and manual changes by users to the underlying data is it.
That’s an endless can of worms with too many use cases to cater for, and simple code is the best code.

I have been considering adding a reset all button to nuke all tags/notes to start again, maybe at some point. But if an individual aircraft metadata for keys has changed (by dev or user), easier just to recreate the tag for now.

I think you are still missing my point? :slight_smile:

This is the case already. I added the tag, but name was already changed before that so I have not changed the name in the eyes of AM.

Then I removed the livery for 1 boot up. When I put the livery back in (no changes, just activated again with Linker) it no longer has the tag. As of loading and viewing the “list” without the livery there has wiped its tag out? Maybe I’m wrong but seems to be what occurred.

No, I understand, but the only way AM rewrites tags is via manual edit of the tag to fire off that process.
If the rest of the planes tags are there, then code is fine as far as I can see.

The only possibilities I see atm are:

  • Plane name has changed somehow which means unable to retrieve previous plane name key

  • Tag was accidently deleted manually

  • ?

I’ve done livery testing as well, with no issues like this, but then I also didn’t edit them.

or if I rename the folder and the references in the JSON and CFG files to make it appear first if I WANT it to be the default)

I’m not referencing livery data, though I did do some extensive work looking into the livery system as well, but I’m not implementing anything there for a number of reasons.

But I’ll run some more tests again just to be sure.

The only other possibility is one of the Asobo devs did mention a possible issue with persistant storage:
A known limitation to DataStore right now is, that it is often only properly persisted across sessions when the game is closed gracefully. Not via CTD or killing the process.

Not sure this applies, though, as it seems fairly robust so far and this seems to be an edge case with manual intervention triggering something.

1 Like

Don’t worry about it - minor point. I just won’t remove that livery again! Just thought I would mention it that’s all :wink:

When you removed it, were there any liveries in there? I guess it comes with some embedded, or did you remove them?

Seeing as I’m up working on a new addon (sssssh) I ran a quick test using the Milviz Corsair.

It has a bunch of embedded liveries, and I have 3 add on liveries.
It was installed with the addon liveries, and has tag.
I tried various combinations removing the addon liveries (one set as default) via addonslinker, restarting, check tags, exit, reenable addon liveries, restart , check tags, select addon livery again++ etc, and tags are there every time.

btw if you have a livery set as default and the plane is active, if you remove that livery the plane automatically gets unselected as the active plane on next start up, which is sim behavior.

In any event, I’m seeing the expected behavior when doing various combos of adding/removing liveries, without doing any manual editing of livery or aircraft files. I don’t cover those use cases.

In each case the plane tags are always there. So it appears to be working to me as expected.

1 Like

If you can replicate it with another plane and 3rd party livery let me know.
Just because “it works on my machine” doesn’t mean there might not be an issue, but at least the way I anticipate it working (and how users might add/remove liveries) it seems to be aok.

Yes two default ones are always there.

Yeah that is how I first noticed. But moreso that if you tagged it WITH that livery active, then after adding it back it was not tagged. When I went back to find it after re-enabling the livery, it wasn’t tagged with my “Y”.

But yeah I take your points and appreciate the time you took to test it your side. I will try and test it with another plane and see what happens. Probably not today though!

Ooohh… looking forward to an announcement then!

1 Like

Update:

Apologies for the delay, though I’m not sure if anyone is actually waiting on the edge of their seats for this :rofl:

I’ve been held up on release waiting for a few blockers to be cleared.

  1. One of them was website “stuff”, which has finally been cleared so I can move ahead on that for launch.

  2. Size of notes storage in AM.
    I was waiting on some more information about how the DataStorage worked on XBox/PC and one of the Asobo devs kindly replied with a little bit more info (see below). So I’m going to cut the notes down to 200 characters (down from 1000 characters) for now, maybe increase later. It’s only room for a para or two, but longer than the tags and you should still be able to save some working notes or whatever.


dga
answered • 1 hour ago

@sonicviz,
The JS Datastore writes to the savegame which is cloud synced. I don’t believe there are restrictions to it on Xbox.
One piece of advice: Writing too much data into one key:value pair can corrupt the savegame. I don’t know the exact limit but I would try to stay under 200 characters per value to be safe :wink:

  1. Working on another app to scratch another itch with the UI UX, I discovered a couple of things I need to consider deploying multiple apps into this space. So I’m doing a bit of redesign and rework to tighten that up so they don’t conflict, and also stay under the currently advised safety limits with the storage. A little bit more testing time in the oven is needed.

Stay tuned!

4 Likes

aaaannd…a little update on what else I was working on while waiting on the blockers: New Utility (Coming Soon) - Location Manager

1 Like