Oculus - VR not working. Any help?

The fix for this is to make sure HDR is disabled in Windows and in-game. Requires a restart of the game, at least it did for me.

This has been super frustrating! My Oculus Rift works well with XPlane (Never had an issue), but for the life of me, I can’t figure out how to use it in MSFS2020. I would appreciate any help anyone can give me. The update was successful but not having any luck here.

What am I missing…my headset is plugged in and I use my Oculus Rift on other games no problem.

Ah, ok… thanks. This is somewhat helping me on my way

Yes. I had this problem too. Now fixed with this setting. Thanks a lot !!

I had exactly this problem. Now fixed by the audio setting in Windows. Choose advanced audio setting. You should see “Microsoft Flight simulator”. Now, choose Rift S for the headset.

While your at it, try this optimization to improve the image quality …

My app say 17: ‘Oculus app version (’ - though I am running a CV1, I can fly MSFS2020 in VR

I have the exact same issue. I have edited the registry key but still get scene error.
I can load up the game on virtual desktop but hitting switch to vr does nothing

MadDog did it work for you installing steam ? If so? How do you I install it? And where do you find it?
Many thanks

dont use openxr for oculus you dont need it, just change the active runtime and the fov stencil to off thats all you need

Once you have installed steam, open it then search in the store for steam vr. Once that’s installed, change the registry key to point at the steam version ,(detailed in an earlier post in this thread).
Plug in your headset, run msfs, once you have launched a flight press ctrl/tab and it should work.

Tried that many times and nothing

Where can I find or download steam? Thanks in advance

Watch this YouTube video, this gives a basic step by step guide

Thanks already did. Same thing. No VR. Hopefully an update will help me. Thanks again MadDog

Hi R14occurence, I have the same question about Virtual desktop and Msfs in Virtual Desktop
Did you find a solution?

I installed fs2020 from Microsoft Store and run an Oculus Rift.
I had no VR until I removed Windows Mixed Reality and changed the following the settings in the registry editor to:

For ActiveRuntime change its value to the one that matches your platform (note: default path is shown below):
C:\Program Files\Oculus\Support\oculus-runtime\oculus_openxr_64.json
It should the recognize your headset.

I’m not having success with Oculus Quest 1, should I expect it to work with the Oculus Link. I have a pretty fast PC and Graphics card. I have changed screen res to 1024 x 768.

Any ideas?

Have you tried Oculus Tray Tool? Might be worth a try, there is a tab for Quest Link .

Here is a link if you want to try it:https://www.guru3d.com/files-details/oculus-traytool-download.html