Pimax anomaly ( SU11)

Pimax anomaly
The headset image flickers a few times to once per second and I can’t fly well.
In particular, the flickering occurs severely when the viewing distance or the object changes.
Tried all the new VR settings with the latest studio version GPU drivers.
As a result of various trials, the flickering has been reduced, but it does not disappear completely.
The drawing frame rate is not bad even during flickering, so I think it’s a different phenomenon from overload.
I understand that DLSS3 cannot be used with GTX numbers.
Is your PIMAX normal?
(By the way, my PIMAX is fine for other games.)
CPU 5800x
GPU 1080Ti

Same Problem for me, it occured already during the SU10 beta phase, luckily it was possible to revert FS2020 to the SU9 state then, but with SU10 released, there is no going back anymore.
One thing that should be added: There are no flickers in the menu system, only after starting a flight. I also noticed that the flickers are less, when the viewpoint is not moved. I also have the impresseion that it is the scenery (ground and sky) that is flickering, not so much the interior of the plane for example.

I also tried different VR-Runtimes, I normally use openxr via open composite, but switching to SteamVR did not help, also enabling and disabling OpenXR Toolkit had to effect.

Right now I am out of ideas and really hoping for some kind of hotfix, like we had a couple of times with the last sim updates.

FS: Shop Version
OS: Win 11
CPU: 5600X
Chipset: B550
VR Settings: OpenComposite + Pimaxxr + OpenXr Toolkit

1 Like

I also made all environments plain, but the problem seems to have become minor, but there is no big solution.
What is happening is exactly the same as you.
In my environment, disabling the OpenXR Toolkit did not solve the problem.Did you ever solve it with this method?
When there was a problem in the beta test, did this happen even though I reported it?
Either way, it’s one of the leading headsets and I wonder if they haven’t even tested it.

I have no issues. Just completed a very nice VFR flight in the improved Beech G36 Bonanza.

RTX 3090
i9-10900k @ 5.1 Ghz
32 GB RAM @ 3000
Asus Z590 mobo
2TB Samsung 970 EVO M.2
Pimax 8kx @ 75 Hz
PimaxXR , OpenXR toolkit

Just wondering: Why are you using Open Composite? From what i understand it is not needed for MSFS2020,
Also, the version of MSFS 2020 , is it STEAM?

There is a new version of OPEN XR TOOL KIT 1.2.0 , plus PIMAX OPENXR 0.2.6 is also out.
Try those…see if it helps.
you dont need STEAM VR with these.

The issue seems to be with the game, and no update to OpenXR Toolkit or PimaxXR will fix it. Are you using Large FOV by any chance? This was broken in SU10 Beta at some point in the way you described. @DJSlane did you report that bug, I think you had a thread?

1 Like

Here was the thread:


Angeli662 [Angeli662]

Exactly the same thing as this video has occurred since SU10.
It happens even with PIMAXtool and Steam only.
There were no issues prior to the update, and no other games had any issues.

Hi @MonkeePooPoo ,

Sorry, my mistake. I have downloaded Open Composite, but not installed.
Edited my post above to reflect this.

Same issue here … Is this similar to what everyone is seeing ? Imgur: The magic of the Internet

1 Like

You shouldnt need it for msfs. Its open xr native?

I made it vanilla.
And I also tried VR using the following, which bypassed STEAMVR.

The situation has not changed at all.
I think there is no doubt that the cause is a bug in SU10.
It seems that some people are working well, but I guess that it is probably limiting the field of view of PIMAX.
(Or the 3090 doesn’t trigger any of the new built-in support functions this time, so the bug doesn’t occur?)
Unless a workaround is released quickly, PIMAX users won’t be able to play properly.

How I understood it, Pimax XR and Open Composite are components that are supposed to work together: Open Composite as a OpenXR Runtime as SteamVR Replacement, and Pimax XR as a kind of “translator” between OpenXR and the Pimax Headset, wich is an OpenVR Headset as far as I know.

If I understand you correctly, you just have Pimax XR installed and not Open Composite?
I will try removing Open Composite and just use Pimax XR too and see if it makes any difference.

For me the flickering can be controlled by adjusting the antialising settings in conjunction with the object detail sliders… If I use TAA antialising and lower the rendering it made a difference… it also definitely seems to get worse closer to the ground… I’m also running a 3090 card. And in the end, the better I see graphical quality … The worse flickering gets.

I had the same issue as well.
I improved it by activating DLSS and lowering the cloud quality.
Name plate slightly flickers, but is playable.

Yeah this is because most other games dont speak ppenxr natively, so openxr passes the calls in other games to a opencomposite orst. Unnecessary with MSFS.

This is the current situation.
The situation disappeared when I lowered the rendering resolution to the limit.
However, it was too dot world like the world of Minecraft, so it was totally unacceptable.
So, I increased the set value a little to about 60, but it still looks like it has degraded about 10 years compared to before SU10.
And I was hit by this screen before takeoff.
No matter what I do on the user side, it doesn’t improve.
Other games are working, and I was able to fly comfortably before SU10.
A fix update is required.
スクリーンショット (454)
スクリーンショット (455)
スクリーンショット (456)

So an update on my situation is I have noticed that if I change field of view from large to normal in PiTool… The problem goes away completely the minute I go back to large field of view it’s a mess

Yeah but I guess the question is… who going to fix it? I don’t know for sure but my guess is pimax users are a small minority of VR users… I’m not even sure if a Osobo or whoever even acknowledges that they support pimax… I guess there could possibly be a fix implemented through open XR… Not sure about steam… Situation is very frustrating.