PSA: OpenXR Toolkit mod is not expected to work with SU10 during beta phase

Some progress on DX12 - it looks like DX12 works fine if I completely disable foveated rendering (not the menu option, but some of the early initialization code). So it looks like all issues left are related to FFR and DFR.


Hello @mbucchia, did some testing with my Varjo Aero, SU10 beta, DX11, VarjoOpenXR and OpenXR toolkit 1.1.1
Fixed Foveated rendering and hand tracking worked fine. Only Eye tracked foveated rendering seemed to be broken with the update. So less feature broken than expected :slight_smile:


I think FFR works Ok but if you look closely, the foveated circles don’t line up nicely which means it’s not the most comfortable. It’s usable.

Hand tracking I was having many problems getting my leap motion to work, so I wasn’t sure if the issue was it or the Leap Motion so I declared it Broken. But good to hear you got it to work.

1 Like

Contrary to things said in certain YT video, there is NO known issue with DLSS and OpenXR Toolkit. You can use DLSS and OpenXR Toolkit together as long as you use DX11.


Any ideas on when we may see an update to allow us to use DX12 with the toolkit? Sim Update 10 with dx12 seems to be very very smooth overall!!

I belive you can try today to add a registry key to fully disable Foveated Rendering

  • regedit
  • HKEY_CURRENT_USER\Software\OpenXR_Toolkit\FS2020
  • create DWORD 32 bit named disable_interceptor
  • set value to 1

Not sure it work, but worth a try. Let me know if it works. If not, delete the key so you dont forget it!

If this works, this will fully disable all foveated rendering options, even with DX11, until you delete that key.

EDIT: Finally got to a PC, and the regkey does the trick for DX12… as long as you don’t care for Foveated Rendering.

EDIT2: Finished investigation and I have a proper fix for DX12.


didnt understand… what should i do to make my vr headset working? Oculus Quest 2 and MFS2020 from MS

This is a thread about OpenXR Toolkit, an add-on that is not needed to play the game. Your question seems completely out of place.

1 Like

do you mean vr isnt working properly on sim updt 10 because of OpenXR or what and is there any thread about fixing this

No, OpenXR Toolkit is an add-on, you don’t need it to play the game in VR. Please state an actual problem if you have one, instead of writing those cryptic messages.

1 Like

it means i cant play vr?

If you’re not going to spend time writing comprehensible sentences, I will not spend time replying anymore. Please file a new thread for your issue that seems 100% unrelated to OpenXR Toolkit and 100% unrelated to the current thread… sigh


Dude this is nuts! DX12+DLSS+OpenXR toolkit with the resolution turned up to oversample is giving me by far the best experience on this sim in terms of clarity, smoothness, high FPS - both on the ground and in the air, all leading to much improved immersion.
Adding FR back in will be the icing on the cake.
Thank you so much!


I have DX11 with DLSS and OpenXR Toolkit running and this gives me a nice perfomance boost, although graphics are a bit more blurry. However I am not able to use VR with DX12. The sim will not switch to VR, nothing happens when using the the assigned button or the menu. No crash, nothing. I tried to disable OpenXR Toolkit but also no joy…

I think you have to read this thread from the top. It should answer your question. :grinning:

1 Like

I want to report something for your openxr toolkit. If Pimax XR is active in the control center, the horizontal offset in fixed foveated rendering is not working. And it appears C_/_.
If I change to SteamVR in the control center, it works but they move towards the same direction (both right or both left).
I hope it helps. Thanks.
Any posibility to add any sharpening when using dlss? In msfs it appears amdsharpening but it doesn’t do anything.

I added the new key in the registry. That fixed the DX12 CTD problem but now I get a shaky video no matter what I set the Openxr render to or turning my MSFS graphics down. It’s acting like a continual tracking problem in that every head movement is tracked with a slight delay. This remains the same when I adjust the Shake Reduction in the OpenXR menu or adjust from 0 to -100. My FPS remain steady about 30. When I lay the headset on my desk (and look at my monitor) the image is totally still with a crisp detailed image that looks great.

When testing using the DX11 setting everything performs terrific, better than SU9.

I hope this helps.

HP Reverb G2 (latest bios - April 22)
AMD Ryzen 7 3700X
ASUS Prime X570 Pro
32GB 3200 MHZ
AMD Radeon RT5700XT - (Driver 22.6.1)
PS 1050w
Windows 11
MB and GPU set to defaults

Edit 1: I also uninstalled and reinstalled WMR, OpenXR, OpenXR Toolkit and the HP Reverb G2 bios.

Edit 2: RESOLVED!!!
Not that I have an understanding why but I always had “FSR” selected in the in OpenXR menu when I was using DX11 and it looked great.
In DX12 I had to turn it off. Now I have a great video!

1 Like

You mean that you have fix for having DX12 and Foveated Redering? :smiley:

No, foveated rendering remains broken. I have a fix so that DX12 can be used for other features like post-processing etc.


I have identified a few things:

Regarding DX12, thanks!, the regedit key works :slight_smile: but you still have to disable Overlay. If overlay is on, it will fail. I had to reinstall OpenXR and remove the whole key:


To later identify it’s the overlay messing up.

Also, side note. DX12 is not really smooth for me even with OpenXR, it’s a stutter fest. I have a 3080ti. Looks great, but I couldn’t make it work.