Screen tearing introduced by 16/02/21 update

After loading the sim following today’s update I’m suddenly getting significant screen tearing in full screen mode. Up until now I have had V-sync off. I have now tried with it on, at 60 and 30 and also tried turning it on using N-videa control panel.

Nothing seems to help - except running in windowed mode.

I’m baffled and would welcome any suggestions. Nothing has changed at my end, was using the sim perfectly fine this afternoon - no screen tearing - did the update and now I have screen tearing.

So frustrating.

Thanks

also having the same issue since just updating now, screen tearing all over the place and causing a lot of visual distortion its impossible to play, changing the graphic quality doesn’t stop it.

2 Likes

If I switch into windowed mode and maximise the screen, it’s fine. But it’s distracting having the windows menu bar etc there. You could try that for now. There must be more than just us 2 with this problem I’d have thought!

2 Likes

thanks ill try that now, im sure more will pop up soon

I’ve got the same issue myself. It’s slightly resolved by applying V-Sync at 60fps within the sim’s graphics options.
I’m about to try it with G-Sync disabled now. Will report back my findings shortly.

I’ve noticed this too- windowed mode helps for sure. I don’t like it though. I hope they fix it. I don’t like using Vsync because I lose a lot of FPS.

im getting an awful framerate too, cant reach 30fps even on low settings :S

Having the same problem. None of my Nvidia or MSFS graphics settings changed before or after the update.

I just removed the screen tear by disabling G-Sync on my monitor and turning on V-Sync 60fps in the graphics options.

Unfortunately I don’t have G-sync on my monitor! Glad you’ve got yours sorted though. Cheers.

Users in another thread suggested setting the v-sync to “Fast” using the N-Vidia control panel.

This has solved the issue for me.

I’m still baffled as to how it came about in the first place.

Thanks to everyone for their input.

3 Likes

Same problem here when I first loaded the sim. But when I changed my monitor refresh rate to 144Hz (from 60), the tearing went away. I’d suggest checking your control panel and looking at the refresh rate.

Confirmed, setting it to Fast in Nvidia Control Panel worked for me too.
Note, you have to restart the sim to see the effect.

2 Likes

See this thread for an explanation: V1.13.16.0 - screen tearing not a bug but a design change - #2 by kaese5128

Worked for me too…once I restarted sim! Thanks for the info :+1:

nice, will try this later :slight_smile:

Anyone figure out a fix for those on AMD GPUs ?

3 Likes

My 60Hz screen is ok and also VR (which appears to have improved visuals, a noticeable tiny bit)

It worked for me. Thanks. :slightly_smiling_face:

I’ve been reading a couple of threads about this new issue and 9 out of 10 posts are for nvidia. Clearly AMD 6800s are hard to find… So the workaround found for nvidia cannot be applied to AMD hence we need a different solution.

Voted.

3 Likes