Toolbar broken in VR

Yes indeed. Seeing this too. Also when the mouse is on top of the opened windows like atc, no control Inputs possible then.

I think this will affect all VR users. If I am wrong then it will be really interesting to see how the systems of those affected differ from others.

I have just flown some further test flights in a plane I am not so familiar with. A simple circuit in the cub crafter. On final approach, I moved my mouse to the ATC window to announce on final at this un-towered airfield. inadvertently, and as I have done a thousand times, I left my mouse over the window. On approach I throttled to idle but unknown to me, throttle stayed at about 20%. I didn’t lose airspeed and floated right to the end of the runway before I realised what had happened, and attempted the landing too late and crashed.

I am annoyed that this is happening and don’t want to have to learn a new trick (move mouse away from window) when I really shouldn’t have to.

I hope this is fixed soon.

I don’t have this issue with a X1 gamepad, that’s why I was saying this.
For me, if I use the mouse but touch any button/yoke, the mouse pointer goes back to my view center but buttons/yoke work fine even if I leave it on a window/top bar (since it moves back to the center anyway).

  • The issue is that if I want to use the mouse, I can’t touch anything else or my mouse pointer will keep moving to my view center and therefore, make any interaction impossible.
  • Oh and another issue is that if I move the mouse and then touch the left stick (yoke), the mouse pointer (that goes back to my view center) transforms into a big white dot. :grin:
  • I also can interact with any instrument with the center of my view because even if the white dot is usually not displayed, it still exists.
  • Oh and a last one for the fun of it: If I focus on any intrument (blue highlight), and move the right stick (that usually moves the view in 2D), well it works like in 2D and moves my head and breaks the reset function (reset view will then become where I moved the view with the right stick).

I think that this is far from being over and there is a lot of issues that are piling up. :sweat:
They implemented something but didn’t think of (and tested) any edge case.



The 1.21.17 patch that’s in public beta seems to have fixed it, at least for me.
Follow the indications in Pre-release Testing - SU7 Update Public Flight - #2 to get the patch (at least for a while) until it goes to production.

If you used the “Home cockpit” trick, you should change it back in order to get full functionality in the beta.

The public beta patch works for me too (7 Dec)

o Set:

  • General Options
    • Camera
      • Home Cockpit Mode = OFF

o ‘VR - Camera Reset’ button works

o Toolbar responds to mouse clicks

Can you test, if you leave the mouse over a toolbar windows, for example the VFR map - can you still use your thrust lever?

bug thread:

1 Like

I managed to repro it. If I leave the center of my view on a window or menu, I can’t do anything but move the yoke.
Thanks for the thread, I added my vote.

@smitty9792 @Flobud

fortunateley they where able to reproduce the error:


Question without notice: I’m not part of the Beta test however I have not been in the sim for the last couple of days. I just attempted to fly from LFPG on runway 27L and as I was generating speed down the runway the aircraft just stopped and I got a message that I had collided with an object (there was nothing on the runway) and crashed. Tried to return to the main menu and CTD. Previous to the test version being released I had no issues, no CTD’s and my VR was working really well (with the hotfix of turning on camera cockpit home view to access toolbar). Would this test version be affecting the normal game version?

I have not used VR for a while. Surprise! I plan a nice night flight, click “fly” and find the ATC screen LOCKED open in the center of my view. I can’t close it, I can’t move it, and I can’t open any other toolbar menu items with the mouse.

Not wanting to have to read through 478 posts about the bug, is their a cure for this? Or, is VR unusable now?


Click Left Ctrl + 0. Then you can use the mouse to remove the panel. It”s a known workaround for a problem that is expected to be fixed shortly.

They released the beta for Steam also.
So if you really itch to fly in VR before the official patch, I strongly recommend the beta.

The rudder & throttle freeze is still in effect. I don’t know if there will be a hotfix for the beta (really doubt it) but that should be fixed for the production release.

Check the release notes for the beta


Has it fixed the vr issues?

It has for me (Rift S) with Locking interactions and with home cockpit disabled.

It introduced a new bug (if your mouse hovers over a window, the rudder and throttle are unresponsive). It’s annoying, but the workaround is to just move the mouse cursor out of the window after using it.

It’s not perfect, but It makes the sim usable again in VR.

Give it a go. The more of us testing and giving feedback the better the patch will be in production.

1 Like


HP RG2. Mouse or controllers cannot controll toolbar.

I am sorry, but this workaround doesn`t work for me. I use WMR.

Do you mean ctrl-0 doesn’t work for you or did the Beta not fix this issue for you?

1 Like

I’m using WMR as well. Should work for you. Make sure you are using the left CTRL key and the top row 0, not the number pad.

I just tested the (Steam) beta and that fixed it for me (G2 Reverb). No more pressing ctrl-0, yay :slight_smile:
BTW the issue where the throttle doesn’t work when the mouse is over a window - i had that issue directly after the SU7 update so that’s not a Beta version issue.