Ucrtbase.dll // need help / work offline but not online

Spec : PC // Steam version (All drivers and updates are ok)
AMD Ryzen 9 3900X 12-Core
Nvidia 3070 RTX
Ticket Zendesk : https://flightsimulator.zendesk.com/hc/requests/121179

Hi everyone, i have already submit a ticket but no one in zendesk find the solution, i have a crash to desktop (in safe mode and normal mode) since the last update for xbox (1 month), I have never been able to play this game (in online mode) again since. This is strange, because offline it’s work but not online.

I waited for this update but it was useless. This is my error message :

Nom de l’application défaillante FlightSimulator.exe, version :, horodatage : 0x00000000
Nom du module défaillant : ucrtbase.dll, version : 10.0.19041.789, horodatage : 0x2bd748bf
Code d’exception : 0xc0000409
Décalage d’erreur : 0x000000000007286e
ID du processus défaillant : 0x9de4
Heure de début de l’application défaillante : 0x01d7a4a15b6b8dbd
Chemin d’accès de l’application défaillante : C:\Program Files (x86)\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Chemin d’accès du module défaillant: C:\Windows\System32\ucrtbase.dll
ID de rapport : 5542386d-0e78-4ee9-88f5-e1b889839341
Nom complet du package défaillant :
ID de l’application relative au package défaillant :

And here the message from Zendesk :
Thank you for contacting Microsoft Flight Simulator Support today. I see where MSFS2020 is crashing due to:
Nom du module défaillant : ucrtbase.dll

Note - we are currently looking into an issue just as you described where the crash only occurs while online.

I have had no answer since. I try to

  • Change the language settings to eng US
  • Uninstall Win updates
  • Update the drivers
  • Reinstall all the C-runtime libraries
  • Fix the registers
  • update ftom Win10 20H2 to 21H1
  • disable all tiers app
  • authorize in firewall
  • reinstall the game 4 times with NTFS disk
  • i also tried to check every update on all my software include steam, nvidia, microsoft, xbox,
    i tried to restore steam cloud save
    i tried to disable all sound device / drivers
    i tried to disconnect all my joysticks, screen, disk and i tried to reinstall my windows

Thanks for you help

By the way, any chance to have payback ? some players massive request to move things ?

Hello @mamiegrosbisous .

You seem to already have tried alot.
I don‘t have an answer for your specific problem, but the following things come to mind:

Thanks mate but i try this :wink:

1 Like

I cannot find the link, but disabling audio services and other running (background-)applications like nahimic, discord, msi afterburner may also be worth giving a shot.

Thanks i just try again, and same problem here :wink:

Then I am currently out of ideas, sorry :frowning:.

1 Like

Would be interested in your solution, if you find it: Unofficial Reference Guide to CTD Solutions

I don’t have a solution, but to comment; you actually get a “safe mode” option when you ctd! That’s further than I have ever come… I get the blue bar at the bottom, and then it crashes. Same DLL as you mention is what I got.

Not been able to fly for a month… It’s frustrating.

note only the installed language pack English US is necessary, not need to switch the whole system lang.

this was the summary:

So, if you have disabled the serive “nahimic” and uninstalled asus sound * tools, then may be

  • the Anti-Virus tool block somewhat
  • there is a invalid setting ( try start offline )
  • login issues ( relogin xbox & reboot )
  • note: one time was also again HAGS under suspection

PS.: in case you have VR hardware installed, check the VR topics. Then different issues, coming from VR drivers, are possible.

1 Like

I have exactly the same problem since the UPDATE 5 .

I tried on my old computer, same problem, and now it’s the same on my new computer with : RTX 3080ti / Ryzen 9 5900x / 32 go ram 3200 mhz / MSI MPG X570 pro gaming carbon wifi.

I tried everything and nothing happens, so i think the problem it’s may be with the WINDOWS store … may be or corruption with my Microsoft account, cause i can download easily the game but during the starting page the game crash all the time.

i reboot my xbox account, i restart i can fly. Thanks you very much

1 Like

How did u do that?

Mod edit: This post was moved here from another topic.

Hello guys,

first sorry for my english, i’m french so i will do my best :slight_smile:

So, i cannot play the game since the UPDATE 5, and now with the 6 it’s the same the game crash during the mid loading. I’m thinking we have a problem to communicate with windows microsoft to authenticate our account.

My tweak is to start the game, when you have the UPDATE CHECK disconnect your ethernet cable … and start the game OFFLINE, and in my case, the MFS2020 loading normaly and i can see the menu.
Now you can connect your ethernet and the game will connect with the server … .

I don’t know why but with this process it works for me . :confused:

I hope your fix is permanent, but in the case your CTD returns, I’ll fill you in on what I had. I was getting several CTDs over the last three weeks or so. I could simply move a screen within MSFS and both my monitors would go blank, and eventually the PC would reboot. I have an RTX 3070 myself, and I went on a google witch hunt. I found that the latest driver (471.96) is apparently causing some havoc with the RTX 3070’s (and who knows, maybe other cards as well). I backed off to 471.41 as a test and I have not had a CTD in the last three days or so. And that sound you hear is me knocking wood.

Best of luck to you.

I just tried disconnecting from internet, start the sim and… WOW! It works! It actually loads.
But the instant I connect to internet again, crash to desktop. So… where’s the problem really?

Is it some corrupted cloud data? Can I reset/delete this? Is it something else the sim is downloading and can’t handle?

1 Like

I don’t even know at this point, I don’t even have any saved data when I start the sim and I still crash, I legit think this is some sort of authentication error.

If you have steam e.g. this is how other people solved issues with cloud data:

As this topic has been solved, it was closed.
If users still experience issues, please post in an existing thread or open a new topic, if no appropriate one exists.