Unknown Random CTDs

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

Yes (just aircraft crashes disabled)

Brief description of the issue:

Random CTDs are getting beyond the joke. I literally cannot play this game anymore after Asobo released SU5. CTDs are completely random and come out of nowhere, at any point, any stage of flight, anytime. No explanation whatsoever.

Provide Screenshot(s)/video(s) of the issue encountered:


Detailed steps to reproduce the issue encountered:

Cannot specifically reproduce, as CTD encounters are random and unsuspecting. Mostly when on ground and approach, but can happen even before loading into the game world.

PC specs and/or peripheral set up if relevant:


Build Version # when you first started experiencing this issue:

Latest at time of post

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

My apologies if this is the 3934924th time this has been posted, but I’m very upset about this. I don’t know what happened to Asobo, but MSFS when it first came out was incredible and worked perfectly. It’s ever since SU5 I’ve been unable to properly play or complete a flight without getting some kind of CTD. It’s beyond the joke now. I’ve shelled out a fair bit of money on buying the game plus peripherals, you’d expect some degree of quality and stability. I’m always fearing the next SU/WU because they just create new and more problems for everyone, it’s like QA testers at Asobo don’t exist anymore.

Again I apologise for my little rant here, but this is something that’s been bottled up in me for months and just needed to get this (portion) off my chest. I just wish they will focus on adding stability over content updates. (psst, a crash logger would be nice)

Rant over. Thanks! :slight_smile:


Well, they actually are working on your wishes.
From the SU9 beta release notes:


Several crashes have been fixed across the title.

And from the March23 Q&A

Would it be possible to get a more complex crash report if the sim has a CTD [crash to desktop] so users can better identify third-party issues or conflicts? - Timestamp

Martial - We are working on that.

Jorg - I think stability has been a focus. We see pretty significant stability improvements in Sim Update 8. Sim Update 9 is also looking at this, including tooling that you were just asking about. I think it’s rolling out with Sim Update 9. (Martial, I think so?)

Martial - I don’t know if we had the time to include everything we wanted to bring.

So they are getting there!

As for your issue:
I would wait and see what SU9 brings before you get too far involved in trying to diagnose your issue.
However, when and if you do want to dig into it, this is a good place to start. At the bottom of this checklist are links to three other more-in-depth lists.

1 Like

can you post a message from windows event log ? … at least sometime it is helpfull :wink:

Give me a minute, and it’ll fetch. Would you like it posted plain text, or parsed like Pastebin?

Nevermind I’ll put it into Pastebin for ya. MSFS CTD - Pastebin.com

1 Like

ah… you are faster…

I re-paste it here, its better for searching.

Unfortunately it is the common 00000005 which give us not much info and we can only point to the common hints ( installed mods, limit fps, checking pagefile, no OC, just such things ).

In special these CTD while loading points to installed mods ( best case ). But its allways hard to find.

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Application Error" /> 
  <EventID Qualifiers="0">1000</EventID> 
  <TimeCreated SystemTime="2022-04-16T16:59:47.4319977Z" /> 
  <Correlation /> 
  <Execution ProcessID="0" ThreadID="0" /> 
  <Security /> 
- <EventData>
  <Data>C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.24.5.0_x64__8wekyb3d8bbwe\FlightSimulator.exe</Data> 
  <Data>C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.24.5.0_x64__8wekyb3d8bbwe\FlightSimulator.exe</Data> 
1 Like

That’s great then knowing they’re working on it.

I’m sorry if my little rant post came across rude or bad mannered. I’m just so passionate about Flight Sim, and it just upsets me I can’t properly play. Thanks for posting those notes, it gives me some hope. :slight_smile:

1 Like

Yeah I figured it would be some generic/common error. I’ve tried to narrow it down with various things, clean installs, safe mode, graphics driver updates. I’ve even gone as far to restore my UEFI BIOS to defaults and removing overclocks. I can’t really pinpoint at which point it’ll crash, it comes anytime. Mostly on approaches and on ground.

Same issue here, Sim was great and no CTD, since SU5 I get random CTD about 1-2 hours of Flight.
Temps are great on my Water Cooled system, everything is updated and I got plenty of system to run it, also have a very clean system and just did a full reinstall of Win 11 and MSFS and still having same issues.

If you read every update release note you will find the same sentence repeated. And it is partially true. They fix one crash cause (i.e. USB disconnection CTD, missing keybind CTD…) and create probably other 10 ways to CTDs. I had no crashes until SU4 or 5. Then they started and increased, update after update. AND THE WORST THING IS THAT THIS WEEK IS UNPLAYABLE.
Today it worked in the morning with no crash. This evening I started loading the first time at 9:30 PM, loaded different times, always not responding on flight loading (and consequent manual closure from Task manager), I ended at 11 PM with 0 minutes of gameplay.
That’s absolutely ridicolous.

Yeah, it’s getting very bad. I just hope they are able to pinpoint the cause and fix it. I was doing a flight with the A32NX from London Gatwick to Dublin this afternoon, and just as I was about to capture the glideslope, it crashed. Safe to say it really infuriated me. If it happened prior to departing I’d be like ok, whatever. But it’s 10x worse when you’ve gone through all the effort and then crash at the last hurdle.

Edit: I’m almost confident enough to start flying on VATSIM, but I’m worried I’ll crash during flight, and get banned or something from the network.

1 Like

wonder why you not simple link your own topic instead to write a post with no helpfull content.

Mods… as mentioned is these is one of the possible reasons :wink:

As same here: Endless CTD... Please fix CTDs before doing anything else - #9 by AndrewDavix79

FBW A320 (dev)

Related to:

We have e.g. two topics about Dublin
one where users get CTD with the Third-Party-Add-On ( and a possible fix ):

and a more generall

I assume its something with a garmin replacement mod or just a third-party-addon.
( in special these working-title replacements seem to create additional folders in “packages” which needs manualy removed ).

You won’t get banned from VATSIM a CTD. Just make sure that vPilot disconnects you from the network if you do get at CTD. It should do it automatically.

Removed all addons: Still CTD, loaded in safe mode, still CTDs, downclocked CPU, still CTD, downclocked also GPU (and is not overclocked) still CTD.
As MSFS is the only app causing freezes or CTDs, even with no addons, is Asobo/microsoft who has to find the cause. I cannot spend my time loading and troubleshooting and adding/removing addons as msfs is unable to tell you what is wrong.

Please, stop always telling it is a conflict with addons. It is not 100% sure, and, I already proved this is not related to addons.
It is not related to msstore, it is not related to system time, it is not related to xbox app or system updates.
All started, for a lot of people, with SU5 and never stopped. The last week started for a lot of users also the freeze on loading with the needing to force the app closure from Task manager. And it happened in the same week for everyone who is having the issue.

There is no more we can test, other than fresh install after formatting the PC. Already tried (by Asobo automatic decision) to reinstall the simulator when it decided to reinstall everithing.

We don’t have days to spend on a PC checking and fixing. We want to spend some free time (and is not a lot) flying. Yesterday I spent all my free time loading and not flying…

For sure the marketplace and other sellers will not see any money from me until the crashes are fixed. Why I should pay something I cannot use?


Touche. Every other game works perfectly fine, it’s just MSFS. Never had an issue with other games. It’s just after SU5 is where it all went downhill. Why do you think FlyByWire pulled the A32NX from the in-game store?

If it is the FBW addon, now, all the users with it should have the CTD. Or, all the users who removed the FBW should confirm and inform FBW about the problem.
But it is not the problem. Same crashes are present with or without it, with or without any addon in the sim.
When we say “RANDOM” it means that it crashes in game, during the flight (so someone may think about an addon conflict), however it happens anywhere in the world, from a very busy addon airport with a lot of AI planes/ships, to the middle of nowhere with no AI and no addons. It may happen on the default cessna or in the most complex addon. But it also happens during sim loading page at the beginning, or as soon as you click to load the flight from the world map, or on the world map.
If it is an addon problem, it should crash 100% of the time in the same way in case it happens on the loading phase. Not randomly.
If it is an addon (an airplane used in AI traffic) it should crash most of the time in busy airports and may stop crashing by disabling AI and multiplayer. If it is a scenery addon, it should crash always when we start from the same place.
But no, it is all random.
Except during this week where random means that most of the time it freezes on flight loading.
And no addon may be the cause on my system as I’ve not installed/updated anything. And, even removing them, the problem is still there.

It is an Asobo issue, Asobo has to find the cause, Asobo has to find the solution.

1 Like

I read also topics about crashes on Xbox… So the problem is even not hardware related.

I can’t confirm any crashes on Xbox from personal experience, but I definitely have seen plenty of complaints about CTDs on the Xbox platform also. I’ve still got my Series X (for now, as I’m planning on selling to upgrade my PC) so I might download it on there and give it a spin.

Welcome to the forum, we can try to help possibly if we know a bit more about your system configuration including what your graphics settings, mods, memory, cpu, mainboard, power supply, graphics cards are, including the operating system!
I have been running fs2020 since the very beginning and I have had only two CTD. There is something very wrong with your system, I do not believe fs2020 is the culprit! :grinning:


Ignore the compatibility warning on there, it’s just saying you need to update the BIOS for Ryzen 3000 series (which I have, I’m on 4801)