VelocityOne Flight Universal Control System - Turtle Beach

My pre- purchase research pointed the Yoke movement to be sticky while moving forward or backwards.It was said that after a use of a couple of months it will smoothen out.It hasn’t and it kind of jerks out of neutral position.It is very annoying especially when one is coming into land and needs to give a bit of correction to glideslope.Otherwise the movement is quite smooth.
BTW just as one can change colours of the quadrant is it possible to do that with SIP.Mine is green.Changes to light amber if I may call that colour when something like landing gears are engaged.Its white when the flaps are down.In case of release of Parking brake it just goes dark.Overall I am happy with it and have been using for close to a year.

I bought the Velocity one binding fixer Ver3 from Etsy and it really works.

4 Likes

@JamesTBS6584 Hi James, contacted support regarding the full nose down trim issue and they wrote back say they aren’t aware of any issue and I sent them back an email with a screen shot of your post on the tb discord acknowledging the issue and a statement that a new firmware was forthcoming in summer 2023 (but not seen). I love my flight one and rudders and it’s a shame this one issue spoils the experience and tb don’t seem interested. On another note I came across another issue today and found at least one other mention of it on redit. B33 on Xbox (I believe it’s b33 on Pc) it’s the top row second from the left on the quadrant, it seems permanently tied to the fuel pump toggle. I’ve tried checking all my mappings created and deleted a mapping for all fuel pumps options, so there is definitely no bindings in the sim to any fuels pumps but the button still toggles the pump (at least pump one as I noticed it on the Beech Bonanza v35) I’m thinking it’s a sim issue rather than the yoke as it isn’t bound to the function in the sim so shouldn’t do anything. I have it bound to the taxi path toggle and that works fine just it keeps toggling the fuel pump. All this is my experience on Xbox series X.

2 Likes

I know I’ve contacted them about the random full-peg trim when the pedals are used with the V1 Flight, at the time I was on XBSX a few months back. It started around SU12 I think, last winter.

If they are slaved in the flightstick(even still using the yoke at the same time) it doesn’t happen(had all three in use at once on XB-so I could also use the quad with the stick), or plugged straight in as on my PC (now). I haven’t tried plugging them back into the yoke as they’re right into the USB hub now.

ETA: heh I just saw ‘SU 12’ when I went back and read the above TB post.

I decided to add the TB Flightstick based on my great TB Rudder Pedals that is built like the proverbial tank and super responsive.
However, I can NOT say the same about the TB Flightstick. The center spring is so stiff that it makes this device unusable for me.
Also since I am on a PC it requires an additional cable to connect which was not included.
So I am returning this stick to TB for a refund and replacing it with a MS Sidewinder Force Feedback 2 that I found on eBay. That is a a well designed product made in the USA before we started to make things in China.

Change the spring it makes a big difference except for twist. It’s a hero paired with the v1 flight quad.

The resolution is excellent but the stock spring sucks on ice. I have NO idea what they were thinking. But using it with the yoke’s quad is a great $100 item. I have setups from the vast Cub family(including split lever/vernier assignments) to PC6 to Wildcat to SR22 using a couple quick clamp brackets, throttles left or right depending. 2 minutes to move it all around to a completely different ‘pit’.

I used a cut down spring from my Traxxas box 'o springs. Just enough to always return to center with authority, but probably about 40% what the original spring was.

You can technically cut the spring, but it’s not the same as a proper length softer spring. What they chose to use is absolutely stupid.

1 Like

I like the yoke set up, I don’t have the peg full down problem although some aircraft respond differently in regards to trim when coming off AP. I also get random button inputs from the button panel bellow the throttles, again with some aircraft worse than others. The A2 Commanche applies the park brake and turns off landing lights randomly and the Daher 930 continuously auto starts and also turns off the master switch all though the last time I flew it for a few hours with none of those problems. Obviously if those buttons were assigned differently those random things would be different, but I find it odd that it is only affected with these two aircraft.

My Turtle Beach V1 works very well however with this controller I highly recommend that you use the USB supplied cables and a USB3 connector on your PC. Also check for duplicate bindings if you have multiple controllers connected.

I think they’re just super easy to bump those two accidentally. I thought the parking brake was a bug but it was my knuckle.

1 Like

I bet you’re 100% right about the other commenter’s problems, if they’re using some of the default mappings and using the levers/plungers accurately to what the plane has(who wouldn’t) the upper left button(auto start by default iirc) is the easiest to hit when using the lever throttle, and bottom left(parking brake) is the easiest to hit when using the plunger.

Lmao actually just the other day I had a nice gear up landing in the 414 because I bind the upper left button to gear and hit it by accident when pulling the power down to idle during my flare

I moved Nav lights over toggle taxi arrows on the far left set. Then tail wheel lock over Parking brake on the lower button, then increase/decrease AP Alt Ref great to have when they’re slow and you have to stand on the increase even into taxiing. Then landing over taxi lights , then gear up/down. I actually have orphaned some bindings on the quad with the octavi and stuck tail wheel lock and taxi ribbon on there.

Yeah, I’ve eliminated that as a cause. For example I’ll land at an airport, taxi and park and go and make a coffee and be sitting in front of the sim sipping away at my coffee and the Daher 930 will start up on it’s own. This has been noted by a few others as well. I haven’t however had the 930 start up on its own since SU15, which may just be coincidental.