[WARNING] Faulty AirportServices configuration on Marketplace is breaking game features

This is an old issue that started with SU8 if I´m not wrong. Many airport addons, specially small fields, include a custom AirportServices configuration to disable ground services. As of today (SU11) a wrong configuration of that file produces the following errors in game:

  • Gliders takeoff doesn´t work: no ground crew appears holding the wing and neither tow plane nor winch methods are operational. You can´t takeoff therefore, nor in free flight nor in training/activities.

  • Marshallers don´t appear

  • Complete set of ground services vehicles don´t appear

Those errors are reproduced worldwide on any other airports that don´t include their own AirportServices configuration, as the faulty ones will override the ground services system globally.

The correct configuration shall be something like the following, including the compiled Services.spb file:

<airport addon name>/AirportServices/<ICAO code>/Services.spb

Uncompliled xml/txt files or wrong subfolder setting (using the ICAO code is the best solution) will produce the error. There are some actions needed as this is preventing some game features to work:

  • For developers: fix the configuration definition, recompile the addon and reupload it.

  • For Asosbo/Third party stores: several airport addons on Marketplace and other stores still contain such errors. They need to be updated so please contact developers, publish an SDK warning notice or correct them directly on the Marketplace or your stores if possible. I have reported some during the past months and they were fixed by authors but others are still faulty (mainly due to uncompiled files):

aerosoft-airfield-egte-exeter (it´s missing the ICAO subfolder)
justflight-airport-kszp-santapaula (it´s missing the ICAO subfolder)
EGTR Elstree Aerodrome (ORBX)(it has an extra uncompiled file that must be removed)

  • For users: manual fixing of files, or eventual removal of the whole AirportServices folder can be required until updating comes. MSLayoutGenerator.exe can be used to update the layout.json files on the addon folder after manual corrections.

I include a couple of old topics where those errors and corrections were discussed:



Unfortunately I had 4 of them (LEWG PHDH ENMH LECD) and deinstalled them right away. What is best to proceed? Trying to figure out eMail addresses and contact the corresponding developers? :thinking:

Yes, reporting is a good idea. You can find the emails at the product page on Simmarket for instance in case Marketplace page does not include them. Or go via Aerosoft/ORBX support directly.


1 Like

Thanks for pointing this out. This is a problem which bothers me for a long time. I already contacted several developers about this but some even refuse to believe this problem exists.

It´s a real problem, so it exists. Even the gliders can´t take off now so it´s not limited to ground services vehicles only.


1 Like

I don’t have any of the airports listed and I’m having this problem. I disabled GSX in case that was the cause and it didn’t fix anything. So I guess I can’t fly gliders.

The list only includes the addons I own but more can exist. Do a search for services.xml because it’s the most common error. If you have any of those files that’s the reason.


I only found one services.xml file in my entire Community folder attached to a freeware airport I don’t use. So I deleted it. Going to try again.

Edit: And of course it’s not that simple. Didn’t work.

Then you need to check every single airport, including the ones from Marketplace. Do a complete search for “services.” (that will include all type of files) and check one by one to find issues as the ones I described in my original post.

Due to this issue now everytime I install a new addon this is the first thing I check.


I searched for AirportServices folders and found a few suspects. Deleted all of them. Started the game, started the first glider tutorial, and the guy holding the wing is there. Should work now.

1 Like

Presumably you didn’t delete the official Asobo-services one?

That’s the only “AirportServices” and “services.spb” I can find in official. I just removed the contents of the community folder No services.xml files at all and the problem persists!

No, I didn´t delete any official content from Asobo. The third party airports are the reason for this error.

If you still have the error then search for “services.” instead of “services.spb”. That will display all airports including custom definitions. Either you still have any uncompiled file (even if the compiled version of that file also exists) or you have any wrong folder name inside AirportServices.


Do you think this will ever be fixed? If not I’ve wasted quite a lot of money as i have loads!

Fix it manually and check every new asset you install from now onwards. I have 0 faith in MS/Asobo support to Marketplace according to the experience in the past 2 years. If they wanted they could have fix it months ago.


If this is affecting Xbox, then fixing it is only solved by uninstalling the offending airports.


1 Like

I found another one. This was tricky as the error was introduced by a recent update:

justflight-airport-kszp-santapaula (it´s missing the ICAO subfolder).

It has a couple of subfolders inside AirportServices instead of the one with its ICAO code (KSZP). Therefore a KSZP subfolder shall be created and services.sbp needs to be moved there. The other subfolders can be deleted.


1 Like

I have the Marketplace version of this airport and it appears to have been fixed in the last update they issued. I show a version 1.3.1.

I can confirm ENMH and ENOV. Both created by the same creator. After uninstalling these the service guys came back

1 Like

I tried to talk to these guys but they don’t understand what happens and obviously are not willing to do a quick test to verify the problem. May be they cannot or are unwilling to check it on Xbox. Unfortunately with every installation of a new airport one has to vetify that the services still work. It’s best to try this after every single install, otherwise it is difficult to pinpoint the problem dlc.

I’m not sure how Asobo can be expected to fix this? All these issues are the software “working as designed”, unfortunately. The SDK is extremely clear on how these files should be created, and they have tons of examples and the exact file naming procedures. The problem is developers don’t pay attention to all the words.

I don’t think Services.xml files cause issues as long as all the parameters are followed. As @geloxo noted above, the File should be in packagename\AirportServices\ICAO\Services.spb or xml. Capitalization is important I think, or at least it used to be when I first started creating these files, but I could be wrong on that. The spelling and location has to be exact, or else FS thinks the file is meant to be the global Services file and it then causes “issues”. But sometimes, developers actually mean for the file to act globally. For instance, LVFR’s Services addon, their Services file is supposed to be the global Services file. Of course, most of the time it shouldn’t act globally.

As I’ve developed products, as long as I’ve followed the above procedure, Services.xml files have not caused issues for the rest of my installation. Though I’ll admit that, now that I have the Services thing down, I haven’t experimented with .xml files in quite a while. I have been compiling to .spb for a long time now.

For Asobo to fix this, they would have to make a judgement that something is wrong (see LVFR’s addon as an example). As far as Asobo is concerned, if the Services file is not in (see above), then the developer meant for their Services file to be a replacement globally. Ultimately, bugs in Third Party software are not Asobo’s responsibility. It’s up to the user to be careful what they install and for developers to read the SDK.

Then again, I suppose I could be convinced that, given that Xbox users have no recourse to fix this issue, and the problem is so easy to detect that products destined for the Marketplace could be scanned for Services files and the addon held back and the developer warned about the situation. The developer would then have to prove they know what they’re doing with their Services file before the product is released.

(Yet another reason I don’t purchase from the Marketplace. I understand the purpose of DRM and encrypting, and I wouldn’t have a problem with it, but, there are too many issues like this that can’t be fixed when the files are encrypted. And I feel super bad for Xbox users for 1. their inability to access the huge library of addons for PC, and 2. the fact they can’t fix the many issues with their installations.)