"Your Game Licence Cannot Be Authenticated" Xbox X MSFS Premium Deluxe

:wave: Thank you for using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No

Have you disabled/removed all your mods and addons?

Yes

Brief description of the issue:

Since the first day I purchased MSFS 40th Anniversary Edition “Premium Deluxe” on Xbox X during the last week of November 2022, I have received this message once per week (on average) and been entirely prevented from using MSFS:

“Due to an unexpected error, your game license cannot be authenticated.”

Server’s go offline - that is not my complaint.

There are 2 things wrong here:

  1. The error messages are 100% incorrect, as shown below
  2. The fallback behaviour when server is down, is 100% incorrect, as shown below. A customer who has purchased a “Premium Deluxe” product, and has an “Ultimate” subscription, should not be locked out once every couple of weeks when your servers are having issues - especially when “offline data files” are properly installed.

This is NOT acceptable of a “Premium Deluxe” product, especially after it has been reported, and reported, and reported. I get that server issues happen - but you CAN fix the messaging and fallback behaviour without waiting for MS Azure to fix their servers.

Provide Screenshot(s)/video(s) of the issue encountered:

5 screenshots, with some feedback to the person deciding on error message


I AM signed in to the Microsoft Store and MSFS with the account that made the purchase

I am “online” but it can’t find its own servers. Xbox Network Test verified 1 Gbps connection, these screenshots were uploaded from Xbox, every other online function of Xbox works, except the MSFS notary server can’t be reached.

I am NOT offline, and I DO have the optional “Offline World Data” files installed, they take up 60 GB, Xbox > Manage app just showed it to me, so this message is completely wrong.

Again, I am ONLINE.
IF it thinks I am not online, how does it expect me to download optional files (that I already have)?
When I click “Exit and download offline content”, guess what, it goes to Xbox and a page that says “error, cannot be found”… so the link is also bad.
If I click “OK” I cannot fly. So, I’m locked out of my “Premium” purchase
No amount of unplugging cables, rebooting, signing out and in, nothing works.

Detailed steps to reproduce the issue encountered:

I did try reporting this to Zendesk before, and was completely dismissed. I do understand that server issues happen - but the MESSAGING needs to be fixed, AND, there needs to be graceful fallback so an installation that has worked the previous day (without hardware change) can continue to work while MS fixes their servers. Every single message above was 100% wrong. That’s not acceptable.

PC specs and/or peripheral set up if relevant:

Xbox X
MSFS 40th Premium Deluxe 1.30.12.0

Build Version # when you first started experiencing this issue:

Whatever the version was the last week of November (Thanksgiving sale)


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

You do know not to launch the Premium Deluxe tile? You need to launch MSFS by clicking on the standard MSFS tile, even if you have the Premium Deluxe version. The version tiles only relate to the extensions (its annoying the way they are displayed and very confusing).

Its a bit like clicking on a FORZA addon pack, and expecting it to launch the game, but much less obvious in MSFS.

Hope this helps.

Not helpful (but thank you)

On Xbox, I have only an “MSFS 40th Anniversary Edition” tile - 1 tile - purchased on Xbox X from the Xbox Marketplace.

When I open it, INSIDE MSFS, there are the additional “Premium” and “Premium Deluxe” content packages in Content Manager, which were automatically installed. I have also factory reset and clean installed Xbox and MSFS multiple times (since joining beta testing last summer). I did such a clean install the day AAU1 final was released, and it has worked fine (almost) every day since, including yesterday… but not today, with NO changes.

1 Like

Take some solace that you are not the only one this is happening to. Happened to me a week ago and somehow the issue resolved its self. I think it’s Xbox servers, as there was a huge worldwide outrage yesterday afternoon… frustrating I know!

Thanks - but as I said, I’m not upset that there are server issues… those happen… I’m upset that:

  1. The error detection is so lazy that it doesn’t detect it’s just the notary server offline
  2. The messaging is 100% wrong
  3. It fails to detect the offline data files are installed (allowing offline play) are installed
  4. It fails to allow offline play - preventing me from using MSFS at all
  5. It has no graceful fallback - eg, detecting that it was already authenticated, with no hardware changes, and that other MS services are online, so… allow offline play
  6. The link to download offline files is broken (after it fails to detect they are already installed, and how does it expect download if it insists that it is offline…)

EVERYTHING about the messaging, and behaviour, is wrong. Servers go down, fine - but fix the rest of it so it behaves like All Other Software in the same scenario. Sorry to rant, but I have reported this over, and over, and over, and ZenDesk just dismisses, and dismisses, and dismisses. I’m really fed up.

3 Likes

What are your NAT settings on your router?

This happens to me consistently when my router NAT settings are set to Type 2. If you can, set it to Open NAT and relaunch the game.

However, I will note that while my NAT settings are set open this error message still appears for me at least twice (sometimes more) a year. I just have to wait awhile, less than 24hrs, and the issue resolves itself. There may be some correlation between the Xbox live servers and this message but it’s just a working theory of mine.

Thanks - it is NOT my router NAT settings (which are default ISP) and every other function on Xbox, and every other device in my home, have no problem. Only the MSFS authentication server can not be reached. Changing NAT, DNS, etc, makes no difference. It is obviously an MSFS server issue… but that is not my complaint.

My complaint is that (1) the messages to the user, and (2) the fallback behaviour, are both 100% wrong. Asobo can fix both. Microsoft servers can go down, and MSFS should still work if you have offline files installed (I do). Only Asobo can fix the error handling and logic… and the current behaviour and messaging is NOT ACCEPTABLE.

3 Likes

I am locked out of being able to fly in MSFS, because of a server issue - even though I DO have the offline files installed.

This is not acceptable. Jorg, Seb, Martial, are always talking about “balance” between new features and fixing issues… What is the balance when a purchased “Premium Deluxe” software won’t allow offline use (even thought it is supposed to, and I have all the offline files), because a server is unreachable?

I’m voting with my wallet - until this issue is fixed, I’m cancelling my GamePass “Ultimate” subscription.

1 Like

This morning I did a full, 100% uninstall and factory reset of Xbox X, and new install of MSFS 40th Premium Deluxe. And, MSFS 40th Premium will not open properly or play for me, with all new, default settings.

Here is a full documentation of what I did and my specifications:

  1. Sign out of MSFS
  2. Xbox > MSFS > Manage > Delete Saved User Data “everywhere”
  3. Xbox > MSFS > Manage > Uninstall
  4. Xbox > Settings > System > Console Info > Reset > Delete Everything
  5. Factory reset Xbox initial set up:
  • English
  • Canada
  • Identify Controller
  • Sign in with Microsoft Account
  • Optional Data Collection = ON
  • Use settings from previous Xbox = NO
  • Sign In preferences = No Barriers, Instant Sign-in
  • Make this your “Home” Xbox = Yes
  • Choose Time Zone = UTC -5 Eastern Time (US & Canada)
  • Keep games and apps up to date = Yes
  1. Xbox Specifications:
  • OS 10.0.22621.3446 (xb_flt_2302ni.230208-1530)
  • Shell Version 2302.0.2302.6003
  1. Xbox > My Games & Apps > Check for Updates:
  • Microsoft Purchase Host, “Update Now”
  1. Reboot Xbox (for good measure)
  2. Xbox > Settings > General > Network > Speed Test = 964 Mbps down / 273 Mbps up
  3. Install MSFS 40th Premium Deluxe:
  • Go to Xbox Store, note GamePass “Ultimate” subscription is recognized and active
  • Search Xbox > Store > Search > Microsoft Flight Simulator
  • Microsoft Flight Simulator 40th Anniversary Edition Premium Deluxe “You Own This”
  • Click “Manage”
  • Base Game = 62.9 GB = selected to install
  • World - Offline Mode = 59.8 GB = selected to install
  • Click “INSTALL”
  1. Xbox downloads 129 GB and installs MSFS in 35 minutes (7:46 to 8:20 AM) so obviously my internet is working well.
  2. Installed MSFS File Info:
  • FullName: Microsoft.FlightSimulator_1.30.12.0_neutral__8wekyb3d8bbwe
  • OneStoreProductId: +9NRRJLLXM68V
  1. Reboot Xbox for good measure, test network connection again… all ok.
  2. Open MSFS for the first time… and right away I get “Due to an unexpected error your game license cannot be authenticated.” The only option is click “OK”
  3. It proceeds to check for automatic updates, it finds and offers 3 updates to install (proving MSFS itself IS ONLINE):
  • Mandatory Update
  • Premium Upgrade
  • Deluxe Upgrade
  • I choose just the “Mandatory” update for now, and click “Update”
  1. It downloads the update - therefore, MSFS is online
  2. Accessibility Settings page, I click “Next”
  3. World Data Streaming Settings page, I choose “Satellite”, “Next”
  4. Data Cap Settings dialog: I choose “Manage Data Usage Settings”
  5. The Data > Online Functionality Settings are GREYED OUT but ON. If I hover the point over it, the GUI freaks out and jumps around. There is NO option to turn it off or on as instructed by the forum staff and Zendesk.
  6. I proceed past the initial setup screens to the MSFS home page - and, it shows me as Signed in with my Gamertag in the upper right, and the Marketplace is accessible - I can open and browse, indicating yet again, MSFS is indeed online.
  7. I open Content Manager, and my previous purchases - World Updates, Premium and Deluxe packages - are there IN my account, but not yet installed.
  8. I click on Gamertag, and servers show “Automatic…” and spinning, with no servers available. Usually it shows North America East, Europe, Asia, etc.
  9. So I sign OUT as previously suggested by Forum / Zendesk, quit MSFS, Reboot Xbox, Open MSFS again (unexpected error, your license cannot be authenticated > OK"), It signs me in automatically, I load the World Map, default C152, Sedona, and click “Fly” … and … I can’t fly. Instead I get this error Message:
  • “You are currently offline and do not have the optional Offline Mode files installed, so cannot start a new flight. Microsoft Flight Simulator will automatically attempt to reconect to the internet. Please check your connection, or alternatively you can download the Offline Mode files.”
  • Every single sentence is wrong:
  • I am ONLINE because you just installed MSFS, and updates to MSFS.
  • I can access Marketplace, and Content Manager shows my purchases…
  • I DO have the “World - offline mode” files (59.8 GB) installed.
  • I follow the contradictory offer to download offline content, and MSFS quits, and takes me to an Xbox screen that says, “Something Went Wrong”, with error code CV:Cvv/LTTGckf/BpbEmJiu4G.21
  1. So, on a factory reset Xbox X, with a fresh new copy of MSFS 40th Anniversarry Edition installed, I can’t fly, at all.

I took a photo of every step, but forum won’t allow me to upload all, here are 5:


New install of MSFS 40th Anniversary Edition Premium Deluxe on Xbox X, including “World - offline mode” files.


Xbox X on fiber optic, takes about 35 minutes to install 129 GB, so my internet connection is PERFECTLY FINE.


First launch of MSFS 40th Premium Deluxe on factory reset Xbox X, and obviously it is connected to the internet, becaue it is installing a Mandatory Update within MSFS.


The initial setup screen > Data options > Online Functionality is screwed up, greyed out and the GUI jumps around when I hover over it with the pointer … note, this is a new install, and I haven’t even got to the MSFS home screen yet, this is ALL DEFAULT settings and behaviour.


After everything, I go to the world map, load the C152 at Sedona, and click “Fly” … and I am not able to fly. I AM ONLINE, and EVEN IF I’M NOT, I DO HAVE THE OFFLINE CONTENT… what is wrong with MSFS? … IF I click the “Exit and download offline content”… MSFS closes, and Xbox throws up: “Something went wrong” with an error code: CV:Cvv/LTTGckf/BpdEmJiu4G.21 …

MSFS 40th “Premium”, 100% broken for me.

Something here is seriously wrong with your account or system that seems unique to you.

With an issue of this magnitude, I’d think we’d be seeing it with other users and not just you.

You’ve been having multiple issues with your sim for awhile now, that seem rather strange (the inability to change data to offline/online, this issue and another you reported awhile back regarding the premium deluxe install, too).

You’re getting nowhere on Zendesk with this level of an issue?

Hi Nixon, I’m told that Asobo is aware of the Data > Online Settings GUI being screwed up, so it’s not just me.

Is your purchase of Premium … MSFS “2020” or MSFS “40th Anniversary” (I’m not sure if they are different or not)?

I’m starting to suspect there is a logic issue between having GamePass and a Purchased license for “40th” … when you go through the setup screens of Xbox (as new, or after factory reset) there is a choice, “Is this your HOME Xbox” which has some sort of special priveledges … so somewhere in that matrix they’ve got faulty logic.

I’m good at documenting, troubleshooting, and communicating - so I will persist with reporting and asking for attention on the issue until it is fixed. I try to keep everything 100% generic because MS / Asobo should be aware if an issue would affect a NEW customer and thus give a negative first impression. I’m happy to beta test and troubleshoot as long as MS / Asobo are receptive.

I knew your online/offline wasn’t unique to you, but I was beginning to wonder if it had any bearing at all…

For your main issue, you tipped me off to something that is definitely different between us, at least. I am not a Game Pass user. I bought the sim, originally (dumb), as the base sim. Several months later, I made the, expensive, move to upgrade to the Premium Deluxe version via the Marketplace.

Of course, now, that is the 40th Anniversary Edition simply by default due to the renaming of the sim, as a result of that release.

I wonder if the issue for you lies in your Game Pass access vs. outright ownership.

It’s obviously a logic issue - and/or a server issue.

When I reset Xbox, I sign in to Xbox as if new - my Microsoft / Xbox online account exists, and I sign in, but explicitly choose to not use previous settings, so that everything is generic and I’m starting fresh.

When I go to the Xbox Store, my purchase is recognized with “You own this”. And I have my receipt with all the UUID codes, etc, downloaded from the microsoft account website. Also, MSFS itself has a Marketplace, and Content Manager, both of which recognize that I am signed in, and that I “own” MSFS, and the Premium and Deluxe content packages.

The only 2 issues are, that when MSFS launches, it is confused about the license and/or is unable to reach an authentication server.

This tends to only happen when it can’t reach a server - as indicated by clicking on the Gamertag in the upper right corner of the MSFS home screen, and seeing if the various servers are even listed. Sometimes mine says “Automatic” and spins, with no list of East USA, Europe, Asia, etc… when those servers are not listed, there is no authentication, and I can’t play.

What’s worse, is that it doesn’t recognize that the offline files are installed, and insists that they are not… Then like a crazy person says, “You are currently offline and cannot start a new flight… but … you can download Offline Mode files.” … How does it expect me to download files if it thinks I’m offline?

AND, when I click to actually follow it’s offer to ‘download offline content’, MSFS closes, and I get Xbox > Something went wrong … LOL, yup, sure did. Asobo needs a new logic flow chart, I think.

At any rate, I think I’ve made MS / Asobo sufficiently aware, and believe (hope) they are starting to see there is actually a problem with the logic and behaviour when a server isn’t reachable. If necessary I will hookup a Wireshark and pull the entire data stream to/from the xbox and send it to them for analysis.

I REALLY shouldn’t have to go to that extreme… no customer should.

No kidding, the entire logic is completely wack. I read all of your posts and the wording is ridiculously circular.

Probably my wording is now circular too. It’s an amazing day outside and I’m glad to abandon Xbox for a few days (and consider cancelling my Xbox subscription). Better things to do. It’s one thing to volunteer to beta test and troubleshoot - but when it takes this much effort just to convince Asobo there is an issue, I question if I’m just wasting my time and effort, and should probably move on to better things.

2 Likes

Dear Microsoft / Azure / Asobo / Zendesk / Forum staff.

I have now hooked up a Wireshark to capture all traffic to/from Xbox X and so if you want a PCAP file of the traffic during authentication errors, or of the fixes (I hope) you are working on, let me know.

2 Likes

OMG, it seems as if I am affected by this bug as well now. I hope it will clear up once a server problem is fixed (Sunday overload problem?) and not persist, as it is in your case @GimbalAxis

The problem has existed for a while, starting the day I switched from the GamePass version to the “Purchased” 40th Anniversary Edition Premium Deluxe version, on Xbox X.

My understanding is that - while MSFS contacts a list of servers for all the aspects of the sim (weather, bing maps, photogrammetry, multi-player, and licensing check) - it is the Xbox Live servers that are responsible for checking the licenses. The issue seems to be (my guess) that Microsoft’s “Content Delivery Network” (CDN) caches content, and either doesn’t refresh or has trouble routing the requests to the Xbox Live servers, or… something like that.

Regardless - the burden should not be on customers to diagnose or solve the problem. When there is a server connectivity issue, MSFS should REPORT the issue to MS / Azure / Asobo so they become aware of the pattern of problems. What’s worse, is when you ask for assistance, Zendesk assumes it’s either you or your ISP is the problem.

All we can do is raise awareness with the developers. They seem to have a blind spot (or at very least, are too silent) when it comes to server-related problems. When a server-issue makes MSFS completely un-flyable, I hope they start to wake up to the problem.

We now have the “feedback-logged” tag - which is a step forward - but until they mark it as “bug-logged” it means they haven’t been able to experience it themselves (and historically that tends to mean the assumption that it’s still a user problem).

1 Like

Indeed I have also “Purchased” the 40th Anniversary Edition Premium Deluxe version on top of the Game Pass version, on Xbox X!

Xbox X user - I suffered from this bug tonight. Came home from work, couldn’t wait to fly New Zealand but ran into this nightmare. Found this thread, tried everything but nothing worked.
What did solve it for me was,
I created a hotspot from my phone and connected the Xbox to the network. Launched game and boom, got past the authentication.
Once the game was launched (Using quick resume) I could go back to the network settings on the console and connect back to my home wifi.
I was simming last night with no issues so not sure why there was issues today. Never had issues with my wifi before and everything looks stable now.
I just hope this quick fix can help someone else who runs into this hair puller.

1 Like