After playing a few hours, FPS drops from 40 to 5FPS

Yeah! Happy to fly with Microsoft!
After 2h fps drop to about 5. Yeah!

I really dont understand - can anyone explain this?

I left only crj in community folder. Everything else move out folder. And im during long flight and after 3h everything is cool - fps doesnt drop.

Maybe some content drops fps down?
In next step im going to put to community folder some content, but not as much as earlier. Only departure and ariival airports.
I will report the results.

Your results confirm what many users are experiencing. Since the minimum hardware configuration is 8 GB, MSFS not working with 7 GB is “working as designed”.

I assume you only changed available RAM and nothing else. It might be interesting but very time consuming is to try each RAM size with each general graphics settings of low, medium, high, and ultra.

Asobo must have had good reasons to create four separate, distinct graphics profiles. If they wanted everyone to use ultra, MSFS would only have the ultra setting. If they wanted to have one universal setting that would run on all modern hardware, there would only be a low setting. But MSFS has the four different settings. They must know that only certain hardware will perform well using ultra while other hardware would have terrible, unusable performance.

I still believe that most of these CTD could be avoided with better exception handling.

Also, the drop in FPS, while the Coherent thread takes longer & longer to complete should not be that difficult to debug, and the cause determined and eliminated.

If MSFS can run Initially at a given Frame rate, it should be able to tale care of itself, and maintain that rate, or close to it under varying conditions, of which TIME should not be one that cause a slow down.

3 Likes

I’ve noticed in the couple of videos from sufferers that I’ve seen not just their vram use changes (normal) but also the vram size which actually baffles me as I haven’t ever seen it happen on my system… Maybe some kind of so called optimiser is being used or a 3rd party mod isn’t all it says it is. Riva tuner is another suspect.

We over at the sdkdev community have been experiencing these issues but a lot faster when working on complex airports over a period of time (20-40mins). This has caused us to every 30 mins or so reboot the sim to continue work.

This week after the Dev Q&A and the heads of development explained they were having issues with use cases, I reached out to them and supplied them with a 45 min video showing the whole issue, and at the end a lot of diagnostic data.

They reported back this allowed them to identify and fix the memory leak causing this issue. Not sure when this will make it to production and im sure they will officially have some news about it at some point after more testing, but I’m glad they have found it and should be able to go back to stable FPS over time.

25 Likes

Hopefully this is one and the same issue.

Thanks for reaching out to them let’s hope they can fix it.

1 Like

Here’s for hoping, this was reported fixed a long time ago

But then again, is it a memory leak? My memory usage never really goes really high, looks like old tasks pilling up on the mainthread and not getting killed when they should

2 Likes

Exactly – a lot of my “run sim for long time” eventual CTD seem to be caused by something like this.

ntdll!NtWaitForMultipleObjects:

   **ntdll!NtWaitForMultipleObjects:**
00007ffc`623ad8b0 4c8bd1                 mov     r10, rcx
00007ffc`623ad8b3 b85b000000             mov     eax, 5Bh
00007ffc`623ad8b8 f604250803fe7f01       test    byte ptr [SharedUserData+0x308 (00000000`7ffe0308)], 1
00007ffc`623ad8c0 7503                   jne     ntdll!NtWaitForMultipleObjects+0x15 (00007ffc`623ad8c5)
00007ffc`623ad8c2 0f05                   syscall 
00007ffc`623ad8c4 c3                     ret

The memory leak thing is a very generic programmer thing to say where there is bug with slow loss of system resources. I have an idea of what went wrong based on the behavior and 3d geometry loadings that were causing it but not really going to go into it on here as its just my speculation and won’t really be helpful. Good news is they’ve have seemed to have nailed it so that’s the takeaway.

1 Like

If you wouldn’t mind PMing me the details of your therory, I’d be very intrested to hear

Same story today, changing aircraft mid flight doesn’t fix it either.

image

2 Likes

Same here, shame cause I like to do long hauls while working… :S… But this is terrible.

3 Likes

Yup! Reporting the same issue myself, and latest patches as of Sim Update 7 has not affected this for me. Reported to Zendesk:

On all occasions of flying a long haul flight, by the time I return to the PC later in the trip the sim is heavily stuttering maintaining 10 fps (Salty 747 mod or Heavy Division 787) I don’t usually have this problem with Longitude as flight does not last as long, but it did happen when I pushed limit on range once (so we’ll say flights that are longer than 5-6 hours can see this problem). All online services are disabled, all AI / Player traffic is disabled as well as ground equipment and it does not affect the occurrence of the problem. Current trip as I am reporting this: EGLL-VTBS 8-1/2 hours in, no applicable mods to this trip other than Salty747. This issue has been applicable for me since more than a year, and I’ve tested WITHOUT mods and no change. Live Q&A requested more detailed reports, so here’s mine!

From hardware metrics: 15-22% CPU utilization; 4800/32000 MB Memory usage (49% system overall); GPU 14% usage / 6.7 Gb of 10 Gb memory usage HOWEVER, task manager reports GPU power usage as “very high”.

1 Like

Hi All,

I found solution to fix this issue!

  1. change windows page file size (min 50mb max 5000mb).
    U canalso try turn off it. But I have in hudge airports crash before final landing (I think due to big size of addons).

  2. remove all not using during flight content from Community folder. Dont use liveries for vatsim as well.

I got about 10 long trips and its works perfect!

1 Like

Nice find … and yes it does sound like a paging issue. Advice to all users is to let Windows manage virtual memory however if the drive it is on is getting full it may be wise to move it to another SSD (Note: I had to reallocate it as manual first and then confirm before setting it back to Windows managed otherwise it reverts back to C:).

1 Like

note: never turn windows pagefile off… wrong setting in windows pagefile , or also that auto-increasment not works as expected e.g. because of less disc space, is a common reason for issues and I guess one in the top10 list :slight_smile:

You can find recommendations for pagefile settings in forum… A manual setting of 5Gig may be too low , also in case you own 32GIG RAM.

1 Like

I had before automaticilly automaticily page settings and fps drops down due to memory leak.
After I set manual bufor for max 5GB performance is great. FPS doenst drop. I have 32GB ram and rtx 3080.

And at beginning of process first I turn off and as I mension before mafs crashed to windows at hard level airports landing (maybe ram was full).

Before this every flight above 1h was terrible experience, fps drops 40 to 2.
Now Is like never before.

that I mean… windows increase the pagefile automaticly, but only if some preconditions are given ( e.g. mentioned here ). Very often the drive which contains the pagefile have less free space and windows does no increase the pagefile. Then we often recommend to set forced min value and a sufficent max value ( as example 8192 / 32000 ). So far I know Windows use pagefile also to defrag the memory, and therefore it is imporant in special for MSFS.

Yeap You might be right, but in my case decreasing max page file to 5gb stops memory leak.

Before it as fps drops down as ram use was about 40% and fule page size was 32gb (cant technical explain this).

I also decrease content in community size from 300gb to 30gb.

Maybe some of content impact to this issue too.

1 Like