After playing a few hours, FPS drops from 40 to 5FPS

Well this is interesting. My flights are mostly short hops of around an hour or so. But today I had a long flight with a stop to refuel but not quiting the flight. Had diner while the sim was still running with the plane parked at the fuel pump.
After diner I took of for the next part of my flight. Approching my destination (LFBZ Biarritz) I noticed performance drops and stuttering in VR. I managed to land and thought it was caused by the freeware scenery of the airport which came with additional scenery for the city.

However, after reading this thread I loaded up the same airport again to test and it was smooth…

I had something similar to this. It was due to an overheating GPU but for me it didn’t take hours, maybe 10-15 minutes. I can see from a later post that your temps aren’t an issue so its most likely not that in your case.

Does the issue occur in even the simplest scenery, and you just leave the plane sat there? I realise you haven’t actually tested this, as why would anyone do that!? But if you have a few hours spare doing something else try finding somewhere with very little scenery detail like a bush strip in the middle of nowhere, spawn the plane, and just leave it there for a couple of hours to see what happens.

I have experience the same. Some kind of memory performance leak in flight that are longer than 90 minutes.

3 Likes

Never experienced this before.

But this happened to me when I was doing a 3hr flight today. Roughly an hour in the fps started to get worse and worse - until I landed with 5fps.

The funny and interesting thing is that EXACTLY as the landing wheels touched the runway it was like someone flipped a switch back to my usual 40+ fps. In my case it very much seems like it has to be software related and not hardware, as it completely snapped to buttersmooth as the wheels touched the runway.

aircraft was the CRJ-700, and a flight from russia to alaska.

3 Likes

That’s really odd.

There are a lot of threads now about this issue, maybe the mods can merge them.

For example

to list a few.

It will become eventually more expedient.

Thank you

5 Likes

I suspect the probelm is just the same as it was in FSX - after all, MSFS 2020 is based on FSX.

After some time of allocationg memory, using it, and then releasing it, memory becomes so fragmented, that there is no longer available in required contiguous block to meet allocation requests, and then the request has to be serviced by the Hard Drive.

Its not so much a question of not having enough TOTAL memory, its that none of that memory is now suitable for its required use.

OR

Its something else – who knows – Clearly NOT Asobo (or me !!)

2 Likes

There is definitely something going on with the game when it comes to long flights. Constantly getting low FPS usually on descent phase. My guess is that after a certain amount of time the game utilizes the CPU instead of the GPU for rendering.

As you can see on outside view normally the game utilizes the GPU more than the CPU but at this point the GPU just remains on IDLE as seen on hwinfo. I have tried everything changing settings, disable game mode, gpu scheduling, latest drivers, increasing paging file etc. None works except restarting the game. And no my pc is not Overheating and is far from thermal throttling and is well above system requirements.

Maximus XI Code Motherboard
i9 9900k OC to 5.1Ghz
RTX 3090 FE
64Gb Trident Z 3600mhz
Western Digital Black 1tb nvme (FS install drive, nothing else)
1300w Seasonic Prime Gold PSU
NZXT x73 AIO
9x Thermaltake Riing Plus 12 Fans

Cant even land with this FPS.

1 Like

Issue still there, anyone have a workarround when this happens. Only way is to restart the sim by now? Using rtx3080 with avg of 45-60 fps and suddenly drops to 10 fps and cpu usage from 80% to 30% or less

1 Like

I have the same problem here too…after 1 hour FPS starts dropping til i can´t fly or land…
I’ll try to disable photogrammetry and enable it back to see what happens.
And also i´ll try to install a free memory program.

1 Like

Just chiming in to add that I am having the same problem. About 90 minutes into a flight today, FPS went from 55 to 15 to 2. Task manager showed CPU usage at about 15% and GPU usage at less than 5%. I tried dropping the settings all the way down to low with no improvement. I saved my flight, dropped out to the main menu, loaded back into the flight, and was able to continue with about 35 FPS. Didn’t feel like doing a whole restart. I’m running a 10900K and 3080 TI. Temps are fine.

Maybe the July patch will take care of this…

4 Likes

I’m getting the runaway ram usage problem again since I switched to Bush flights. I started with the Pyrenees and Alps. It went fine at the start but in leg 7 it just got slower and slower.


I landed at sub 5 fps, 39GB committed, 21GB working set

While exploring NY at low altitude committed was no more than 21GB, I haven’t seen the working set get that high since stress testing London after the UK update. (with double the terrain detail settings I’m using now)

Return to menu only freed up 4GB, still 35GB committed. Returning the menu and quitting the sim took several minutes. Ram use just steadily kept on going up during the flight.

After restarting the game, continuing the bush flight right from where the screenshot is, 16GB committed, 11GB working set, normal for my settings (high, terrain detail 100)

I also encountered the same problem after this update, I flew again yesterday
Use TBM930 to go from VHHH to RCKH. At the beginning, the FPS was about 45. After 40 minutes, the FPS dropped to 10 or lower.

There were no such problems before the update
Equipment R5 3600
RTX 2060 6G
32G RAM

1 Like

Did SU5 solve the issue for you guys?

I have not had any runaway memory problems since SU5, but I did have performance issues after a couple flights in a row with crackling audio and increased stuttering. Restarting the sim made it all smooth again.

3 Likes

Unfortunately not. It worse.

2 Likes

How about deleting the Rolling Cache and creating a new one?

I’m on Xbox and just wanted to say that I have the very same problem. After around 1.5 hrs the fps decreases rapidly and the crackling audio intensifies. When it comes to the actual landing I have the “power point presentation” already mentioned by many users. Changing the photogrammetry setting or deleting the rolling cache doesn’t help. Only after a restart of the sim everything is back to normal, but again only for about 1 hour or so…
I’m sure Asobo is aware of this issue and they will fix it eventually. Fingers crossed :slightly_smiling_face:

3 Likes

I am facing the exactly same issue guys! the FPS are so unstable in this release. In the same aiport, same conditions, same settings, same hour, etc I have sometimes 25 to 30fps or… 45-50…
I am saying this without moving the camera… maybe you press the restart button and you’ve got a fps increase… This is weird…
I have been playing a lot with the usercfg parameters and I can state I did’t find any root cause of this… even when I change everything to low the sim cannot increase the fps as well…

I did also a fresh install and still have the same issue…
Everything at default without addons…

2 Likes

Facing the same issue. Cannot complete a long-haul flight (7 hrs +) without some serious FPS degradation. Start with 80-100, end up with 20 FPS.

My specs:
RTX 3080
i9-9900
32Gb RAM

5 Likes