Axis and Ohs: Help and questions

Hi there,

I have 2 small questions regarding this great little peace of Software (axisandohs) :

I just installed axisandohs (the demo version) and basically the Panels work and are detected by the SW Tool.

First topic regarding the rotary knobs:

When I use the rotary knobs to tune in a frequency or an altitude it jumps over the numbers and it is not possible to select the exact numbers. Is there a possibility to adjust the sensivity?
Update after edit:
In the XPDR Mode on the radio panel it changes both values at the same time regardles in which display I am.

Second topic regarding the switch panel:
With the Switch Panel only the Magneto Switch and the Gear lever work.
I allready tried the single click and double click option and played around with the update frequency.
The Power Management for the Panels is switched of.
The assignment of the switches look correct.

Did I miss some other settings?

Thanks in advance and many thanks @LorbySI for this great workaround solution.

2 Likes

@LorbySI Getting back on the Saitek Switch panel light issues.
There is something weird:

  • At windows start, the test app from Saitek works well and lights are working
  • I start MSFS, and once in cockpit I launch Axis and Ohs
  • From here, switches are working (with some issues in some aircrafts, like the avionics master in the VL-3 is not triggered by the Avioncis Master panel switch, but maybe it is a Microsoft issue)
  • However the landing gear leds stays off
  • If I relaunch the Saitek test app, this time it seems to lag severly and LEDs do not work anymore as well…
  • Then, If I unplug and plug back USB cable of the switch panel, the test app is working back again…

Thanks for your help

I am having the same issue with the landing gear LEDs

1 Like

This has been an issue since before release. Mainly with the VOR tuning for me as it skips around +/-10 or more. I have had success in axisandohs update using the CRS to tune VOR 1 radials with more accuracy but still believe it to be an actual Asobo issue. Axisandohs only seems to tell the panels what event to occur when a knob or button is hit. Since newest update my radios have been fine.

1 Like

Hi all,

my feeling is that each system behaves individually. E.g. my landing gear LEDs work fine. Green when the gear is down.

Maybe it helps to post also the plane used?
I fly the Beech Baron G58.

1 Like

Thanks for the hint. I have this skipping numbers issue only with the XPDR Mode beside changeing both values at once and on the multi panel especially in the VS AP Mode.

Do I need to install the Logitech Drivers for useing the panels? So far I have nothing installed from Logitech.

No axisandohs is all you need. Installing the Logitech drivers could potentially cause a conflict.

Thanks a lot for the quick reply!

Only for FIPs you need drivers, the 3 Panels don’t need drivers.
Thanks

1 Like

I tried to uninstall the Saitek drivers to fix the LEDs issues and now only the gear level and the magneto switch works… so it seems Saitek drivers are required for Axis and Ohs to work

I confirm: You need the Saitek drivers (FSX plugin) to have all the switches working or only the landing gear and rotary will work.
Just reinstalled them and it works again

Still no LED indicator :frowning:

ÉDIT: i did another test with FSX plugin des installed and the switches still work so just disregard above comment it is definitely not required !

Weird I had to uninstall the drivers to get mine to work (Radio, Multi panel, and switch panel). I can’t speak on the FIPs as I don’t have them.

Hi all,
a small update on my first post.

Now the switch panel works incl. the LEDs.
What I did:

  1. disconnected the USB Hub and ensured it is connected to a USB 2.0 only port.
  2. reset the energymanagement to disable for the newly detected panels.
  3. loaded to a cold and dark situation and startet axisandohs. --> now it works. (no logitech drivers installed)
  • radio multi and switch panel are OK except the avionics master switch.

Remaining issue is still the number skipping thing when using the rotary knobs and sometimes no working switch panel. But the not working switch panel starts working after enableing and disableing the panels in the axisandohs SW several times.

So by far not the desired panel behavior but for now a great workaround! I try now the driver install in parallel as Gneu06 as reported.

1 Like

I’ve tried all that you’ve suggested here, but unfortunately, my landing gear LEDs on the switch panel are still inop

Hi all,
now the drivers are installed.
I could check on the panel test-page, if the avionic switch is ok. --> switch works, but still not functional in MSFS.
But on the other hand the number skipping thing when using the rotary knobs is much better now.

So to me there are now a lot of parameters and hypothesis´ which could affect the functionality of the panels. I don´t really know the answers. Maybe the dev brings light into this.

Hello @ll,

at the present stage I am hesitant to follow up on bugs that are related to SimConnect. I have read reports that some events cause the sim to freeze. It is better to just wait until Asobo releases the first fix, then take it from there. You never know if something else might break instead.

For me the panels work every time, the Switch too. I didn’t install any drivers from Logitech for the panels, I guess that I am on the Windows default drivers. Only for the FIP you need to install the drivers (but not the plugin).

About the gear LEDs (which sounds strange)

  • please post the aircraft type and/or if it is the same for all aircraft
  • make sure to disable Windows Enhanced Power Management (start AxisAndAohs “As Administrator”, then the option in the “Tools” menu becomes available. Restart your computer after making the change)
  • make sure that “Ignore sim electrical power” is active in the Tools menu
  • start AxisAndOhs before you start the sim (*)
  • I always cycle one of the lights buttons or the gear lever first thing after loading the aircraft. For whatever reason the SwitchPanel is not transmitting the button positions on load.

(*) I have found out the hard way that MSFS is apparently constantly polling the USB devices. Any change while the sim is running (for example simply starting the panels through AAO) results in an MSFS crash to desktop.

The missing or just different simulator events (like the avionics etc.) will be addressed once the SDK is complete and all variables and events are known. I will also add an option to save different events assignments to the panels for the different aircraft.

“Number skipping”: this is also affected by the “Single / Doubleclick” setting in AAO. There are different types of panels, some require Single, the other Double action on the rotary encoders.

Best regards
Oliver Binder
Lorby-SI

2 Likes

Hallo Oliver,

thanks for your reply!

I´m useing the Beechcraft G58 --> lights are working fine.
Regarding the avionic switch I´m patient. I´m very happy that there is a so far so good solution in order to use the panels!

The only thing I did different so fa in comparison to your described steps is the point when I start AAO. I´ll do it next time before the sim.

Again thanks a lot for this cool tool!

@LorbySI:

  • I ran the tool in admin and disabled EPM for the Switch Panel (there was 3 boxes to put to off) and I restarted the computer
  • I launched the tool before MSFS. I ensured EPM is still off, as well as “ignore sim electrical power” in active state
  • Still once in aircraft and tool connected, I have all the switches working (except avionics) but no lights, whatever the aircraft.

Note, I have the FSX plugin installed, however you mention there are drivers which is not the plugin, however on Logitech support page I can find only plugins, there is no Driver as such. Can you highlight which Driver you have installed? Thanks!

I ll try the USB 2.0 stuff

@LorbySI
Hi Oliver, once again, thank you for all your help and efforts.
I have tried all that you’ve suggested on multiple aircraft with retractable landing gear, but still my LEDs on the panel are still dark.