Bush Trips don't go to 100% even after I finished them

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
Are you using Developer Mode or made changes in it?
Brief description of the issue:
I noticed the denmark and finnish bush trips were at ~88 percent so I thought I’d finish them(even though I thought I already had.) it put me a few miles from the last airport, I landed got then completed screen. but in the bush trip menu it still says 88 percent(or about that)

Build Version # when you first started experiencing this issue:
SU 5
Are you on the Steam or Microsoft Store version?
Did you submit this to Zendesk? If so, what is your ticket #?

Same here.
Did the last leg of my sweden trip (was at 80%) AND tried denmark trip (was at 83%). Altough I got the “finished leg successfully” screen after the landing, I do not get to 100%
It seems after SU5 the trips are not counted.

1 Like

None of my previously completed bush trips are showing as completed now. What an utter gong show…


Same issue. Twice completed last leg of Denmark bush trip. Overall completion remains at 83%


I can confirm all of the above - after installing SU5, previsouly finished bush trips are listed with an overall completion below 100% and the one I’m currently flying (as long as I do not encounter any CTD ;-)), i.e. Norway, just cannot be finished. I can fly the final leg as often as I want - the bush trip will always start again from the second last airport …


Hi folks, be sure to not engage time acceleration during the flight. It is known to invalidate at least that leg.

And, of course, don’t click on the “i’m lost” button :smiley:

It seems all legs finished before SU5 will not count. I was able to fix by starting the bush flights from the beginning. Activate developer mode, teleport to first destination, first leg finished. continue, teleport to next destination, second leg finished. I was able to finish the french trip in about a minute - it went to 100% this way. Hope it helps somebody here…

1 Like

I just did the Balkans trip after SU5 on xbox and I got the achievement for not using assistance, but it shows 97% complete.

Also, The Nevada bush trip would not complete at leg 1 landing at the correct airport. I can’t restart it at all. I can continue at that airport and taking off and landing again still does not count it.

1 Like

Just to capture the status of Bush Trip: Norway (on Xbox).

I was able to successfully complete the trip (no cheating) to 100%.

Watch out, leg 12 doesn’t have a route shown at all (empty leg information and navlog)
But if you fly from Bodø Airport [ENBO] to Svolvær Airport [ENSH] it works.

I was also experiencing the engines cutting out (despite the fuel being fine).
I mapped ‘repair and refuel’ to a keyboard shortcut to get the engine going again when that happens.

1 Like

Well, I all my bush trips seems to be correct after SU5 except one.
Sweden says 80% where all other I have done says 100%.
Today and yesterday, I flow Norway and Finland, which both says 100% after finish.
Now I only need 1 more, lets see if that goes to 100%, I sure hope so after reading this thread.
It was Sweden with 80% that made me come here in the first place.
Seems I only need a solution for that.

EDIT: Found the solution, and it could be the solution to this thread as well.

About the issue with leg 12 in Norway bush trip, I experienced the same on XBOX and write this topic showing, with pictures and details, how to complete this trip. Later, I found this one where this issue is also discussed.

Nice to see that, as promised, we share the same experience on PC and XBOX - some bugs are common to both versions :grinning_face_with_smiling_eyes:.

Regarding the bush trips which remain incomplete, I also had the same concerns.
This is because the logbook does not always record flights correctly. Often this happens when we go through the steps. For my part, I imposed a rule:

  • when I finish a leg, I leave towards the general menu. And I make sure, in my profile, that the leg is well recorded in the logbook before moving on to the next one.Then, I go back to the activity menu / bush trips, to start the next leg.

I had that of Finland which remained locked at 91%. The error was at the start, where the logbook had incorrectly recorded the second flight. I had to start all over again! but sometimes it is sufficient to resume only from the last valid leg.

I also lost (three times!) my logbook :rage:. The numbers in the progression was set back to zero, but in the activities screen, I was seeing 100% for some bush trips :face_with_raised_eyebrow:.
To correct the error of wrong numbers (in the profile screen), I only had to redo the last leg of each trip. It works, it revalidates the whole trip (even if the logbook doesn’t contain all the legs).

Note that, as I mention in my other topic, the Leg 12 of the Norway trip is recorded in the logbook as ENGM - ENSH (instead of ENBO - ENSH) but this works. The startup popup at ENBO, also show “ENGM - Gardermoen” ! but of course, you are really on the runway at Bodø!

1 Like

Agreed on Xbox.

The profile correctly credits completed Bush Trips (3 trips)

But it did not finnish properly (because it’s Finland) and it only went to 88% (8/9 legs completed) despite the sim crediting the BT as finished.

Same problem with Norway - 13/14 recognised, though this has changed as it had previously reached 100%, but now it’s fallen back oddly. (leg 2 is not showing as complete strangely)

Sweden was fine.

(also one of the legs in Norway isn’t listed in the Navllog, but you can look it up and fly there anyway)

same problem here with France (Bordeaux to Mont Blanc).Finished last leg, but stays at 94%. When I enter the bush trip it shows check marks for all but the least leg🤷‍♀️

I did have some issues with the Scandinavian bush trips but I’ve got them all to 100% now.

I did need to re-fly some legs to do it.

This makes sense. I see a lot of progress reset with everything since SU5

Landing challenges and training is the same.

I can (sort of) understand it for the training courses as they have added extra content but I have landing challenges that reset as “new” and not completed despite having been completed several times over before SU5 hit.

It reminds me of the sort of progress wipe you get when a game shifts from closed beta to release.
So I guess the last year on PC really was nothing more than an open beta test.

I’ve had this issue also, I’m on Series X and before update 5 I had completed every leg of every trip before I was even aware that my progress was not being logged correctly. Stupidly I decided to delete and reinstall just the game but not my profile data only to find I would have to fly every bush trip again from scratch .
Since restarting the flights though I have noticed that I’ve never had a leg not register properly if I go back to the main menu at the end of the leg instead going to the bush trip menu. Probably just a coincidence tbh.

I also now have a similar issue with the landing challenges, I’ve currently flown and completed every one at least twice and yet my profile stats still only show 37/39 completed. I’ve dropped a support ticket about both these issues only to be met with a deaf ear and thus I’m getting a bit fed up with it all. I have no clue about programming these things but I would’ve thought that being able to save progress properly is a fundamental?
I’m genuinely starting to regret getting the Premium Deluxe instead of just playing on game pass now. Ty, mini rant over!

1 Like

I just finished my Swiss Bushtrip with 3 legs. Astrong textt the end the Sim confirmed that i finished leg 3 which is the last one but it remains on 67% Completion. Same with the Bushtrip that i created myself, just not getting the 100% completion rate. Tried exiting by going either back to main menu or to bushtrip menu. Anybody with a solution to this? Thanks.

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
Yes I have the Bushtrips in the Community Folder. But if I remove them then …?*

Are you using Developer Mode or made changes in it?

*** No not on Dev Mode *****

Brief description of the issue:

see above

Provide Screenshot(s)/video(s) of the issue encountered:
*** see above*** little airplane stays, final leg not ticked off****

Detail steps to reproduce the issue encountered:

PC specs for those who want to assist (if not entered in your profile)

*** ASUS 570 Motherboard with latest bios / AMD Ryzen 7 5800X / Nvidia Gforce 3070 ****

Build Version # when you first started experiencing this issue:

*** Current version****

Did you submit this to Zendesk? If so, what is your ticket #?


Sorry, i am not a technician, just a simple user. What is a community folder and what is an add-on?

Nothing reported to Zendesk.

For the rest, i described and the hardware is offshelf hardware that workes fine.

It could ve with a recent update of the Garmin or with the last update in September.

How did you identify the legs to refly?

I had also some legs invalid on my Serie X, and identitfy them is quite easy.
On the Swiss lakes trip, there is only 3 legs (and thus, 4 airports):

  1. LSGG
  2. LSZB
  3. LSZH
  4. LSZR

Open your logbook, and use the “search” entry zone to look for airports.

:point_right: Check that you have the corresponding leg, but above all, make sure that there is a value (and not zero) in the takeoff and landing column. If one is 0, then this leg is invalid.

:white_check_mark: - Reflight the leg using the bush trip menu.
:no_entry: - Don’t use the “fly again” button (shown when you click on the line of the leg in the logbook), because this one will refly in the same conditions, but not validate the leg in the bush trip section.