CTD On StartUp

Hey All,

New problem! #73645

I have made no changes to the sim, settings, scenery or anything else however, today I am unable to start the title.

On starting, the sim crashes as soon as it passes the ASOBO and MS splash screens. The circle in the bottom right starts spinning prior to a CTD with no error code etc.

I have read somewhere this may be connected to my XBox account? Does anyone know how I can bypass this or get it going?

I have the same, and no solution yet.
I tried the hint from another user to reset the app (you then have to reinstall in the store, but it should not download much if anything).
When you unplug the internet connection one sec into the loading screen and replug it after around 7 seconds, a window will appear stating “please wait while we sync your data”.
If I proceed, it will CTD again. If I click cancel, the main reinstall process starts, which is quickly done when pointing the installer to the already existing installation. Then the profile is fully reset and the sim starts successfully. I can then fly and do whatever I want to.
The other user stated when you have some flight hours logged in this session, on the next start you will be asked if you want to use cloud data or local data. Choose local, and the cloud data will be overwritten by the working local profile. For me, this step didn’t work, it just started syncing and CTDing again.
I now had 5 days of troubleshooting, updating stuff, reinstalling stuff including the whole sim, Xbox and associated apps, but nothing fixed it.
Right now I’m back to P3D as it seems there nothing I can do from here to make things work again, other than waiting for the next useless Zendesk reply.
Also didn’t change anything-flew one day, the next it was broken.

I solved reinstalling the graphic drivers.
See my post here

Not convinced this is GPU related. This is definitely something on the XBox side.

I have just attempted to sign out of XBox live and log back in with a new account I created. This passed the part where I CTD however, confused FS2020 as I was logged into Windows as myself.

Hopefully someone can resolve this.

Exactly. My drivers are up to date (all of them, after this troubleshooting week, even my bios…). If the GPU driver was faulty, it wouldn’t start and run properly when cloud syncing was skipped.

I have a new PC on order which should be with me by late Feb/early March. It will be interesting to see if that rectifies it or if it something XBox side.

I’ll keep chipping away at some other ideas. Let me know if you crack it.

RESOLVED

Following some research and with some tweaks I have resolved this issue. Credit to @CHOPPER2935 for the fix! See his post below:

For those needing to do this I followed the following steps:

  • Disconnect the internet and reset the app (I only reset FS2020, not XBox or AppStore) in the Windows settings as per Chopper’s post.
  • Restart your machine with the internet connected.
  • Launch the game and follow Chopper’s advice reference timings as a baseline.

I used a stopwatch and had to tinker about a little to get it right. In my case I had to wait 6 seconds to disconnect. Having not reset the XBox App or Store App I have retained my logbook and settings. I will update my support request in the hope that it will get ASOBO to publish this as a workaround until a fix can be implemented.

I also got it running again just now. I took a different approach though:

-Deleted c:\Users(user)\appdata\local\packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\systemappdata\wgs everything in that folder.
-disconnected internet
-started the sim
-several 'your’re offline blabla messages will appear, until you end at an XBOX popup giving you the options to abort or retry connection
-reconnected the internet
-selected reconnect
-update starts
Now it gets a bit confusing, I don’t know if it worked because of it or despite…:
-I chose a different folder that what I used before, full 100+GB download started
-I aborted by closing the window
-restarted the sim
-now I was asked if I’d like to keep the cloud or local profile
-choose local
-update process starts again
-now chose the already existing folder
-nothing downloaded, sim starts ans is fine again

Downside: logbook deleted (doesn’t bother me), controls and other settings deleted.

1 Like

28 posts were split to a new topic: Steam - CTD on Startup (after splash screen)

Hi,

this seems the same “solution” as described here:

but instead for Steam-Users ( where you can backup your data former ) then for MS-Store users.

The issue seems a Game-Setting which let cause the CTD and with the solution all former settings are reverted to Default ( overwriten within the cloud ).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.