CTD Problem with MSFS2020(Microsoft Store App)

Hi everyone! Recently I encountered a problem using MSFS2020 (Microsoft storeapp), which is I got alot of CTD issues. Previously I was using MSFS2020(Steam) borrowed from shared library from a friend and guess what? There are barely any CTDs.I installed the same mods like the present and hardly no CTDs. And why is that?Some suggested to me that Steam edition seems to be more stable than the Microsoft App Store ones but how true is this, nobody knows.It occurs to me at cruising altitude and after I check with event viewer, there are no crash logs of MSFS2020 which is kinda weird for me.

Here are the list that Ive tried working on so far and still FAIL:

  • Ive tried increasing the cache of my RAM to 20000Mb, doesnt work.
  • I tried removing uncessary things from community folder also doesnt work
  • Tried running on administrator
  • Disabling antivirus windows defender and windows firewall
  • Disabling AI Traffic & Live Traffic
  • Graphics card driver updated to latest
  • Windows 10 updated to latest
  • Setting my FSX to medium as default settings
  • Uninstalling all Asobo A320 Liveries
  • Visual studio C++ is all updated to the latest
  • Disabling steam app
  • Disabling non-windows app in startup tab from Task Manager

My Specs:

Acer Nitro 5

i5-10300H @ 2.5Ghz

GTX 1650Ti 4GB DDR6


First, welcome to forum mate. If you check there are too many topics related to this issue. Browse a bit on forum, maybe you will find you solution there.

For example:

1 Like

Couple things that caught my attention.

not sure what you mean, are you referring to the rolling cache size or something else?

don’t remove the “unnecessary”, remove them ALL, and try again.

latest isn’t always the greatest, you will find that most people trust version 457.30

not sure what you mean here

Ive tried browsing through each and every post in the forums but none really work for me. Hence why, I asked this question in hopes of getting this problem solve. Eitherway hopefully Microsoft will fix this problem.