Discussion: Update #4 (

How long the update take ?? Im waiting 1 hour and still in the same position


Have you seen that critical comments over at AVSIM are now locked right away? Not that it surprises me, but something is heading in the wrong direction here.

1 Like

I mean, their rationale arguably justifies the complaints and concerns expressed in this thread. I’m guessing that the only reason people aren’t more irritated about that response is because it was buried in the bottom of that thread and nobody has read it yet.

I hoped this got fixed, but seems nay.

I9-10850K and 2080ti.

Was getting around 50-55fps out in the sticks and GPU was 99-100% and mostly GPU limited

Since patch #4 today I’m down to 34fps in same place/same conditions and GPU is at around 55%, and limited by main thread again.

I’m not one to complain but I built this machine just for MSFS and it is being under-utilised again. :face_with_monocle:


You might want to read this, it might help you getting more fps (or not):

1 Like

Cessna Longitude jet STILL doing the famous Butterfly swim above 34,000 feet.

1 Like

I am still stuck. 5 hours in. I have restarted it many times. Trying Net limiter. But it just sits on a file and never progresses. Have had NO issues with downloading before. I am really unhappy, and believe me I have been a pretty big defender of ASOBO and Microsoft. They have to figure this out… 120 bucks I paid and It will not even work.

1 Like

Those of you with tall buildings still displaying, you might want to further read this:

1 Like

Have you tried any of the fixes for this, is it just slow or is it looping?

it’s sunny outside my house – now when i fly over my house, an Armageddon-like thunderstorm

After the update, the simulator got worse again. Aircraft flying to the same region have a benchmark. Very large performance degradation … FPS decreased by 5-10 units. The simulator stutters at 40 FPS. The trees appeared in some places, disappeared in other places. Tragedy, I don’t know when this nightmare will end … What’s going on with the developer? They are so out of the picture …

With so many important things to fix why focus on this.

Have you tried to change network setting changing speed to 10mbps full duplex, I have to make chnage every time. Is it looping.

Just that they could doesn’t mean they did already.
There was an issue with a very big building in Australia where there was just a typo in the number of floors in OSM data and the sim generated the building accordingly.

Also the position of power towers which was introduced in a recent patch was probably based on the OSM data.

I guess they will add churches etc at some point but it needs various models, especially for different religions. Having one simple model would probably cause big discussions depending on the religion of the real building.

I finished the installation and my a320 has disappeared

@Jummivana: The thread about the “press any key” was deleted/hidden now but the issue isn’t solved by the patch. Why is that?

1 Like

It might be time to pick a ga plane, Trying to reinstall to fix this might be risk not worth taking

Daher TBM 930 Garmin Screen Freezes on aproach. This is a known issue since earlier update.
This problem is not fixed in this update.
Anybody has the same issue?

They made a typo in the dev update when they said it would be fixed for this patch. Nobody noticed it until today when people complained. They have said it will be added in an upcoming patch. So no real reason for the thread to remain open I’d imagine.